当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : amule_2.2.6-0ubuntu1-DLP39_amd64.deb
帖子发表于 : 2009-10-21 9:07 

注册: 2007-11-12 18:09
帖子: 146
地址: 四川
送出感谢: 0 次
接收感谢: 0 次
amule-2.2.6源码+DLP3902补丁,9.10 for amd64+酷睿2 T5250,./configure --disable-debug --enable-optimize --enable-upnp --enable-geoip --enable-nls --enable-mmap(没有要那个什么wscas在线统计,命令行和aLinkCreator),使用checkinstall打包(个人能力有限,只能用软件协助,不会手动打包)。使用的描述尽量和官方的amule deb包描述相同,本人的版本可以直接覆盖官方的升级。从昨晚6:30开始(11:00停电睡觉),反反复复实验,到今早7:30起床,终于弄好了我理想中的amule.deb。心情那是舒畅啊~


附件:
文件注释: 3903
这次因为想要很明确的在包的名字上描述DLP的版本,打的包又和原来不一样了(貌似最好sudo apt-get remove amule,以后都以这种格式为准)。还是推荐各位用http://forum.ubuntu.org.cn/viewtopic.php?f=95&t=233117的ppa源,添加源就能智能升级,何乐而不为呢?

amule_2.2.6-0ubuntu1-DLP3903_amd64.deb [3.53 MiB]
被下载 71 次
文件注释: 3902
amule_2.2.6-0ubuntu1-DLP39_amd64.deb [3.53 MiB]
被下载 38 次
文件注释: 名字也改了,再看看右下角被封杀的,太舒畅了。哈哈~
Screenshot-3.png
Screenshot-3.png [ 348.75 KiB | 被浏览 756 次 ]

文件注释: 封杀这些该死的吸血骡!
Screenshot-1.png
Screenshot-1.png [ 278.82 KiB | 被浏览 756 次 ]

文件注释: 昨晚使用dpkg-buildpackage -us -uc -b -rfakeroot自动生成的deb包,恐怖啊~
Screenshot.png
Screenshot.png [ 779.88 KiB | 被浏览 756 次 ]



最后由 gososn 编辑于 2009-10-22 17:13,总共编辑了 1 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: amule_2.2.6-0ubuntu1-DLP39_amd64.deb
帖子发表于 : 2009-10-21 9:24 
头像

注册: 2007-10-18 17:40
帖子: 1006
送出感谢: 0 次
接收感谢: 0 次
gososn 写道:
本人的版本可以直接覆盖官方的升级


如果ubuntu升级, 你这个版本就被覆盖了。冲突描述没有, 最严重的情况是有可能安装过程会报错,这对初学者来说,解决起来很头疼


另一方面,ppa源虽然不是官方的东西,但其deb包的建立过程,是在官方服务器上进行的, 这样的二进制包安全性还是有保障的, 所以ppa源更适合推广给大众。




发布出来的deb包,需要在软件包中加入冲突描述, 依赖描述如果不加,最多程序不能运行,冲突描述是必须的



要不然, 不如把打包过程帖出来就行了。

其实你已经帖了出来,只是没有step by step

代码:
./configure --disable-debug --enable-optimize --enable-upnp --enable-geoip --enable-nls --enable-mmap


_________________

千帖户,享有论坛特权!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: amule_2.2.6-0ubuntu1-DLP39_amd64.deb
帖子发表于 : 2009-10-21 9:41 
头像

注册: 2007-09-26 17:34
帖子: 618
送出感谢: 0 次
接收感谢: 2
amule: error while loading shared libraries: libcrypto++.so.8: cannot open shared object file: No such file or directory
amule: error while loading shared libraries: libupnp.so.3: cannot open shared object file: No such file or directory
amule: error while loading shared libraries: libwx_gtk2u_adv-2.8.so.0: cannot open shared object file: No such file or directory

依赖里少了3个软件包


页首
 用户资料  
 
4 楼 
 文章标题 : Re: amule_2.2.6-0ubuntu1-DLP39_amd64.deb
帖子发表于 : 2009-10-22 16:33 

注册: 2007-11-12 18:09
帖子: 146
地址: 四川
送出感谢: 0 次
接收感谢: 0 次
john.wu 写道:
gososn 写道:
本人的版本可以直接覆盖官方的升级


如果ubuntu升级, 你这个版本就被覆盖了。冲突描述没有, 最严重的情况是有可能安装过程会报错,这对初学者来说,解决起来很头疼


另一方面,ppa源虽然不是官方的东西,但其deb包的建立过程,是在官方服务器上进行的, 这样的二进制包安全性还是有保障的, 所以ppa源更适合推广给大众。




发布出来的deb包,需要在软件包中加入冲突描述, 依赖描述如果不加,最多程序不能运行,冲突描述是必须的



要不然, 不如把打包过程帖出来就行了。

其实你已经帖了出来,只是没有step by step

代码:
./configure --disable-debug --enable-optimize --enable-upnp --enable-geoip --enable-nls --enable-mmap


我不是太懂deb包的打包过程哈,请问冲突描述和依赖描述是什么?俺觉得ppa太慢了!谢谢,受教啊!另外我觉得编译的感觉很爽啊,看着那些字符一排一排的往下掉,感觉好极了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译