StarDict (星际译王) 3.0.1.1 正式版发布

仅仅用于软件推荐,不适合发求软件或软件使用问题方面的贴子
yuffey
帖子: 193
注册时间: 2007-09-06 16:24
来自: 中国上海
送出感谢: 0
接收感谢: 0

StarDict (星际译王) 3.0.1.1 正式版发布

#1

帖子 yuffey » 2007-11-10 9:24

跨平台的国际词典软件 StarDict (星际译王) 于昨日发布了 3.0.1.1 正式版。作者向该版本添加了 Debian 支持、VS2005 编译支持、dictdotcn 插件、Win32 sapi-tts 插件、wordnet 插件、QQWry 插件、Regex 查询支持等新特性。

http://downloads.sourceforge.net/stardi ... 1_i386.deb
头像
kg7726
帖子: 402
注册时间: 2006-12-16 12:39
来自: 广东省广州市
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 kg7726 » 2007-11-10 11:27

下午去下个试试 :D
styrenes
帖子: 9
注册时间: 2007-11-10 13:28
送出感谢: 0
接收感谢: 0

Re: StarDict (星际译王) 3.0.1.1 正式版发布

#3

帖子 styrenes » 2007-11-10 13:32

碰到了如下的问题,怎么回事?
我的是DEIBAN,etch

(Reading database ... 152848 files and directories currently installed.)
Preparing to replace stardict 2.4.8-1 (using stardict_3.0.1-1_i386.deb) ...
Unpacking replacement stardict ...
dpkg: error processing stardict_3.0.1-1_i386.deb (--install):
trying to overwrite `/usr/share/locale/hr/LC_MESSAGES/stardict.mo', which is also in package stardict-common
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
stardict_3.0.1-1_i386.deb



yuffey 写了:跨平台的国际词典软件 StarDict (星际译王) 于昨日发布了 3.0.1.1 正式版。作者向该版本添加了 Debian 支持、VS2005 编译支持、dictdotcn 插件、Win32 sapi-tts 插件、wordnet 插件、QQWry 插件、Regex 查询支持等新特性。

http://downloads.sourceforge.net/stardi ... 1_i386.deb
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2007-11-10 13:33

先删除 stardict
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
styrenes
帖子: 9
注册时间: 2007-11-10 13:28
送出感谢: 0
接收感谢: 0

#5

帖子 styrenes » 2007-11-10 13:40

我的天,remove, stardict, stardict-common后
出现一大堆,算了。

(Reading database ... 152738 files and directories currently installed.)
Unpacking stardict (from stardict_3.0.1-1_i386.deb) ...
dpkg: dependency problems prevent configuration of stardict:
stardict depends on libart-2.0-2 (>= 2.3.18); however:
Version of libart-2.0-2 on system is 2.3.17-1.
stardict depends on libatk1.0-0 (>= 1.13.2); however:
Version of libatk1.0-0 on system is 1.12.4-3.
stardict depends on libbonobo2-0 (>= 2.15.0); however:
Version of libbonobo2-0 on system is 2.14.0-3.
stardict depends on libbonoboui2-0 (>= 2.15.1); however:
Version of libbonoboui2-0 on system is 2.14.0-5.
stardict depends on libc6 (>= 2.6-1); however:
Version of libc6 on system is 2.3.6.ds1-13.
stardict depends on libcairo2 (>= 1.4.0); however:
Version of libcairo2 on system is 1.2.4-4.
stardict depends on libespeak1 (>= 1.27); however:
Package libespeak1 is not installed.
stardict depends on libfreetype6 (>= 2.3.5); however:
Version of libfreetype6 on system is 2.2.1-5.
stardict depends on libgcc1 (>= 1:4.2.1); however:
Version of libgcc1 on system is 1:4.1.1-21.
stardict depends on libglib2.0-0 (>= 2.14.0); however:
Version of libglib2.0-0 on system is 2.12.4-2.
stardict depends on libgnome2-0 (>= 2.17.3); however:
Version of libgnome2-0 on system is 2.16.0-2.
stardict depends on libgnomeui-0 (>= 2.19.1); however:
Version of libgnomeui-0 on system is 2.14.1-2.
stardict depends on libgnomevfs2-0 (>= 1:2.17.90); however:
Version of libgnomevfs2-0 on system is 1:2.14.2-7.
stardict depends on libgtk2.0-0 (>= 2.12.0); however:
Version of libgtk2.0-0 on system is 2.8.20-7.
stardict depends on libgucharmap6; however:
Package libgucharmap6 is not installed.
stardict depends on liborbit2 (>= 1:2.14.8); however:
Version of liborbit2 on system is 1:2.14.3-0.1.
stardict depends on libpango1.0-0 (>= 1.18.2); however:
Version of libpango1.0-0 on system is 1.14.8-5.
stardict depends on libstdc++6 (>= 4.2.1); however:
Version of libstdc++6 on system is 4.1.1-21.
stardict depends on libxdamage1 (>= 1:1.1); however:
Version of libxdamage1 on system is 1:1.0.3-3.
stardict depends on libxrandr2 (>= 2:1.2.0); however:
Version of libxrandr2 on system is 2:1.1.0.2-5.
stardict depends on zlib1g (>= 1:1.2.3.3.dfsg-1); however:
Version of zlib1g on system is 1:1.2.3-13.
dpkg: error processing stardict (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
stardict


BigSnake.NET 写了:先删除 stardict
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2007-11-10 13:43

..这个是ubuntu的包?..
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
styrenes
帖子: 9
注册时间: 2007-11-10 13:28
送出感谢: 0
接收感谢: 0

#7

帖子 styrenes » 2007-11-10 13:46

从楼主的连接里下的,没有说DEBIAN的版本号,也可能是UNSTABLE

跨平台的国际词典软件 StarDict (星际译王) 于昨日发布了 3.0.1.1 正式版。作者向该版本添加了 Debian 支持、VS2005 编译支持、dictdotcn 插件、Win32 sapi-tts 插件、wordnet 插件、QQWry 插件、Regex 查询支持等新特性。

http://downloads.sourceforge.net/stardi ... 1_i386.deb




BigSnake.NET 写了:..这个是ubuntu的包?..
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#8

帖子 windwiny » 2007-11-10 14:38

还是不能输入中文



5楼的,可以用 dpkg 加 一个强制忽略参数安装那个包
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#9

帖子 BigSnake.NET » 2007-11-10 14:41

styrenes 写了:从楼主的连接里下的,没有说DEBIAN的版本号,也可能是UNSTABLE

跨平台的国际词典软件 StarDict (星际译王) 于昨日发布了 3.0.1.1 正式版。作者向该版本添加了 Debian 支持、VS2005 编译支持、dictdotcn 插件、Win32 sapi-tts 插件、wordnet 插件、QQWry 插件、Regex 查询支持等新特性。

http://downloads.sourceforge.net/stardi ... 1_i386.deb




BigSnake.NET 写了:..这个是ubuntu的包?..
安装前先卸掉原有的stardict, 并更新系统
你的ubtutu什么版本
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
owwbu
帖子: 614
注册时间: 2006-11-15 14:14
送出感谢: 0
接收感谢: 1 次

#10

帖子 owwbu » 2007-11-10 16:36

输入汉字又得在输入框右键菜单里头选X输入法。
还是用源里的stardict 3.0.0 省心。
头像
forrid
帖子: 659
注册时间: 2007-04-23 17:40
送出感谢: 0
接收感谢: 0

#11

帖子 forrid » 2007-11-10 17:08

靠你个StarDict!
对你那么钟情,却玩死了我。
为了安装你,安装了libc6,结果,系统依赖性被摧毁,只好咬牙升级,当然,肯定是失败了,现在呢,呵呵,崩溃呗

吾生也有涯,而知也无涯,以有涯随无涯,SB啊~~~~~~~~~~
头像
suncanoe
帖子: 476
注册时间: 2005-12-07 0:17
来自: 昆明
送出感谢: 0
接收感谢: 0

#12

帖子 suncanoe » 2007-11-10 22:39

安装成功了,但是自己感觉很是不爽,怎么突然会出来一个广告???而且还在比较显眼的位置!!!这算是什么gnu精神??

妈的,我决定了,自己开发一个。
头像
FFFrog
帖子: 621
注册时间: 2006-05-12 23:28
来自: 江西乐平
送出感谢: 0
接收感谢: 1 次
联系:

#13

帖子 FFFrog » 2007-11-11 9:59

官方网站上下载来的deb包,在feisty下不能用。好多依赖关系没法满足…… :?

代码: 全选

(正在读取数据库 ... 系统当前总共安装有 209404 个文件和目录。)
正预备替换 stardict 3.0.1-1 (使用 .../stardict_3.0.1-1_i386.deb) ...
正在解压缩将用于更替的包文件 stardict ...
dpkg:依赖关系问题使得 stardict 的配置工作不能继续:
 stardict 依赖于 libart-2.0-2 (>= 2.3.18);然而:
系统中 libart-2.0-2 的版本为 2.3.17-1。
 stardict 依赖于 libc6 (>= 2.6-1);然而:
系统中 libc6 的版本为 2.5-0ubuntu14。
 stardict 依赖于 libespeak1 (>= 1.27);然而:
系统中 libespeak1 的版本为 1.21-0ubuntu1。
 stardict 依赖于 libfreetype6 (>= 2.3.5);然而:
系统中 libfreetype6 的版本为 2.2.1-5ubuntu1.1。
 stardict 依赖于 libgcc1 (>= 1:4.2.1);然而:
系统中 libgcc1 的版本为 1:4.1.2-0ubuntu4。
 stardict 依赖于 libglib2.0-0 (>= 2.14.0);然而:
系统中 libglib2.0-0 的版本为 2.12.11-0ubuntu1。
 stardict 依赖于 libgnomeui-0 (>= 2.19.1);然而:
系统中 libgnomeui-0 的版本为 2.17.92-0ubuntu1。
 stardict 依赖于 libgtk2.0-0 (>= 2.12.0);然而:
系统中 libgtk2.0-0 的版本为 2.10.11-0ubuntu3。
 stardict 依赖于 liborbit2 (>= 1:2.14.8);然而:
系统中 liborbit2 的版本为 1:2.14.7-0ubuntu1。
 stardict 依赖于 libpango1.0-0 (>= 1.18.2);然而:
系统中 libpango1.0-0 的版本为 1.16.2-0ubuntu1。
 stardict 依赖于 libstdc++6 (>= 4.2.1);然而:
系统中 libstdc++6 的版本为 4.1.2-0ubuntu4。
 stardict 依赖于 libxdamage1 (>= 1:1.1);然而:
系统中 libxdamage1 的版本为 1:1.0.3-3。
 stardict 依赖于 zlib1g (>= 1:1.2.3.3.dfsg-1);然而:
系统中 zlib1g 的版本为 1:1.2.3-13ubuntu4。
dpkg:处理 stardict (--install)时出错:
 依赖关系问题 - 仍未被配置
在处理时有错误发生:
 stardict
styrenes
帖子: 9
注册时间: 2007-11-10 13:28
送出感谢: 0
接收感谢: 0

#14

帖子 styrenes » 2007-11-11 12:15

呵呵,看了大家的回帖,不折腾了。
我还是比较保守,保存系统的稳定性是关键。
windwiny 写了:还是不能输入中文



5楼的,可以用 dpkg 加 一个强制忽略参数安装那个包
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#15

帖子 zhuqin_83 » 2007-11-11 12:23

注意,仅针对gutsy,feisty是不支持的。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
回复

回到 “软件推荐”