GMLive发布0.11版

仅仅用于软件推荐,不适合发求软件或软件使用问题方面的贴子
88djy
帖子: 87
注册时间: 2005-09-12 20:06
送出感谢: 0
接收感谢: 0
联系:

GMLive发布0.11版

#1

帖子 88djy » 2007-12-13 15:57

http://cyclone.blog.ubuntu.org.cn/2007/ ... 1-release/

GMLive发布0.11版

Posted by lerosua on 13 Dec 2007 at 03:22 下午 | Tagged as: GMLive

我们很高兴,终于有一款能用的版本发布出来,目前只提供源码下载。(由于我们并不是

编译的专家,对于各种包的制作并不熟习,上次做了一个deb包却有各种依赖。因此我们希望

能有此方面的高手帮忙打包. )

源码:

http://gmlive.googlecode.com/files/gmlive-0.11.tar.gz

(这是基于C++和Gtkmm的软件,所以编译前请确认您的系统已安装

好需要的开发库)

说明:

GMLive并不直接提供P2P直播服务。因此我们并不能对提供的服务负责。
它尝试成为一款通用型的流媒体播放外壳。
它以全能的Mplayer播放器为引擎。目标是支持Linuxx下多种类型的P2P广播视频
流,提供一种方便快捷的观看网络视频的方案。

添加nslive流支持请下载
http://www.newseetv.com/soft/nslive-0.1.0.tar.gz
添加sopcast流支持请下载
http://download.sopcast.com/download/sp-auth.tgz

下载后,将它们的二进制文件拷贝到/usr/local/bin/或/usr/bin/
即可

关于nslive流。
nslive是一款Linux下的p2p的网络直播软件,由andycl98@163.com所开发。
关于此软件的支持请访问http://andycl98.blog.163.com/以获得详细信息。
nslive流本身会调用mplayer,所以为了让它更好与gmlive一起工作,请将
nslive的配置文件中的播放器选项注释。
~/.ulive/ulive.conf
#mplayer install path
#mplayer=/usr/bin/mplayer

*注意,获取nslive流支持前请先按照nslive软件里的方法初始化。

关于sopcast流。
sopcast流提供的服务请访问http://www.sopcast.org以获得详细信息。
另外,我们获取sopcast播放列表的方式用的是wget这个程序,请保证您的
系统中存在这个命令。

关于MMS流
此列表中的流服务并不是基于p2p形式的。只是网络上散落的各种网络电视
的mms地址。例如,mms://xxx. 我们将它收集起来,以方便您观看。当然您
也可以将收集到的mms流地址发给我们。在以后的版本中将会支持你自己添加
地址。但在当前,如需要,您可以自己手工编辑源码中的mms.lst文件。并将
它拷贝到您的目录下面~/.gmlive/ , 我们程序将优先读取这个目录下的列表。

0.11版本截图:

gmlive 0.11 version
图片
上次由 88djy 在 2008-09-07 11:15,总共编辑 1 次。
加入五岳剑派,即可获得以下杀人武器
Cyclone QQ 基于gtkmm的QQ
Italk linux下的gtalk
Gmlive linux 下的网络电视
加入方法 :
http://groups.google.com/group/Cyclone_QQ/
lb_bn
帖子: 1261
注册时间: 2007-02-25 16:56
送出感谢: 0
接收感谢: 0

#2

帖子 lb_bn » 2007-12-13 17:08

支持原创。。 :D
头像
守望伊人
帖子: 189
注册时间: 2006-05-18 18:24
来自: 四川广安
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 守望伊人 » 2007-12-13 17:28

希望有高手来打一下Deb包吧
头像
sonixrp
帖子: 505
注册时间: 2007-03-28 12:39
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 sonixrp » 2007-12-13 17:36

支持支持呀。
目前研究自编译内核,有兴趣的朋友一起来吧~
xihe
帖子: 28
注册时间: 2007-03-07 19:07
送出感谢: 0
接收感谢: 0

#5

帖子 xihe » 2007-12-13 18:04

岳公子,现在五岳剑派又多了一个gmlive,是不是也把它加到你的武器列表里?
头像
bjsm
帖子: 2322
注册时间: 2007-05-13 16:45
来自: 阿拉斯加群岛其中的一个岛上一片原始森林里其中的一颗树上
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 bjsm » 2007-12-13 18:42

configure: error: Your intltool is too old. You need intltool 0.35.0 or later



(正在读取数据库 ... 系统当前总共安装有 92287 个文件和目录。)
正在解压缩 intltool (从 .../intltool_0.36.2-0ubuntu1_all.deb) ...
正在设置 intltool (0.36.2-0ubuntu1) ...

我的INTLTOOL版本明明是0.36.他为什么还说我的版本太旧,要>=0.35

搞不懂.软件秀逗了.
lyz_new
帖子: 164
注册时间: 2007-05-13 10:59
送出感谢: 0
接收感谢: 0

#7

帖子 lyz_new » 2007-12-13 18:45

:lol:

gmlive-sopcast_1.0.2-1_i386.deb是sopcast引擎
gmlive_0.11-1_i386.deb是gmlive本身
gmlive-nslive_0.1.0-1_i386.deb是nslive引擎
注意要搭配使用,sopcast引擎和nslive引擎都不包括软件本身
在debian下测试成功

如果在ubuntu下,依赖关系不满足,请下载12楼的版本
附件
Screenshot-gmlive.png
gmlive_0.11-1_i386.deb
(125.27 KiB) 下载 323 次
gmlive-nslive_0.1.0-1_i386.deb
(130.53 KiB) 下载 431 次
gmlive-sopcast_1.0.2-1_i386.deb
(654.74 KiB) 下载 500 次
上次由 lyz_new 在 2007-12-13 21:53,总共编辑 5 次。
头像
bjsm
帖子: 2322
注册时间: 2007-05-13 16:45
来自: 阿拉斯加群岛其中的一个岛上一片原始森林里其中的一颗树上
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 bjsm » 2007-12-13 19:06

下列的软件包有不能满足的依赖关系:
gmlive: 依赖: libc6 (>= 2.7-1) 但是 2.6.1-1ubuntu10 正要被安装
依赖: libcairomm-1.0-1 (>= 1.4.0) 但是 1.2.4-2 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)

装不了.
lyz_new
帖子: 164
注册时间: 2007-05-13 10:59
送出感谢: 0
接收感谢: 0

#9

帖子 lyz_new » 2007-12-13 19:11

bjsm 写了:下列的软件包有不能满足的依赖关系:
gmlive: 依赖: libc6 (>= 2.7-1) 但是 2.6.1-1ubuntu10 正要被安装
依赖: libcairomm-1.0-1 (>= 1.4.0) 但是 1.2.4-2 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)

装不了.
你用的是ubuntu哪个版本?
这个包我在debian testing下都测试成功了
按理说基于sid的ubuntu软件版本不会比testing旧吧
另外你可以尝试一下apt-get -f install
头像
bjsm
帖子: 2322
注册时间: 2007-05-13 16:45
来自: 阿拉斯加群岛其中的一个岛上一片原始森林里其中的一颗树上
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 bjsm » 2007-12-13 19:15

我的系统是KUBUNTU-7.10 安装的基本命令行,然后安装的KDE-CORE
头像
bjsm
帖子: 2322
注册时间: 2007-05-13 16:45
来自: 阿拉斯加群岛其中的一个岛上一片原始森林里其中的一颗树上
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 bjsm » 2007-12-13 19:16

我 apt-get -f install 后,它把gmlive卸载了就结束了.修复不了.
lyz_new
帖子: 164
注册时间: 2007-05-13 10:59
送出感谢: 0
接收感谢: 0

#12

帖子 lyz_new » 2007-12-13 19:29

:D这个应该可以了
附件
gmlive_0.11-1_i386.deb
(125.3 KiB) 下载 349 次
头像
hnzksq
帖子: 473
注册时间: 2007-07-11 16:21
来自: 火星
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 hnzksq » 2007-12-13 19:32

呵呵,支持一下!
------
“不要揣测神的心,我的孩子,”老头子的声音仿佛梦呓,“神的胸膛里没有心,那只是一块铁石。”
头像
bjsm
帖子: 2322
注册时间: 2007-05-13 16:45
来自: 阿拉斯加群岛其中的一个岛上一片原始森林里其中的一颗树上
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 bjsm » 2007-12-13 19:55

可以是可以了,我想问的是,为什么我编译源码安装出错啊.我到底缺什么包?

configure: error: Your intltool is too old. You need intltool 0.35.0 or later



(正在读取数据库 ... 系统当前总共安装有 92287 个文件和目录。)
正在解压缩 intltool (从 .../intltool_0.36.2-0ubuntu1_all.deb) ...
正在设置 intltool (0.36.2-0ubuntu1) ...

我的INTLTOOL版本明明是0.36.他为什么还说我的版本太旧,要>=0.35
lyz_new
帖子: 164
注册时间: 2007-05-13 10:59
送出感谢: 0
接收感谢: 0

#15

帖子 lyz_new » 2007-12-13 20:06

bjsm 写了:可以是可以了,我想问的是,为什么我编译源码安装出错啊.我到底缺什么包?

configure: error: Your intltool is too old. You need intltool 0.35.0 or later



(正在读取数据库 ... 系统当前总共安装有 92287 个文件和目录。)
正在解压缩 intltool (从 .../intltool_0.36.2-0ubuntu1_all.deb) ...
正在设置 intltool (0.36.2-0ubuntu1) ...

我的INTLTOOL版本明明是0.36.他为什么还说我的版本太旧,要>=0.35
其实就是找不到一些他需要的文件,正好这些文件源码包里没有包含
装好intltool后
从/usr/share/intltool复制intltool-extract.in、intltool-merge.in、intltool-update.in到源码目录
就编译成功了
回复

回到 “软件推荐”