无法安装 libgtk2.0-dev

仅仅用于软件推荐,不适合发求软件或软件使用问题方面的贴子
回复
linuxyeshiquan
帖子: 22
注册时间: 2007-03-19 21:00
来自: 武汉市
送出感谢: 0
接收感谢: 0
联系:

无法安装 libgtk2.0-dev

#1

帖子 linuxyeshiquan » 2007-12-21 11:39

有很多软件都需要这个东西,我用
sudo apt-get install libgtk2.0-dev
总是出错:
下列的软件包有不能满足的依赖关系:
libgtk2.0-dev: 依赖: libpango1.0-dev (>= 1.10.0-2) 但是它将不会被安装
依赖: libcairo2-dev 但是它将不会被安装
E: 无法安装的软件包
然后又
sudo apt-get install libpango1.0-dev
还是出错:
下列的软件包有不能满足的依赖关系:
libpango1.0-dev: 依赖: libcairo2-dev (>= 1.2.6) 但是它将不会被安装
E: 无法安装的软件包
sudo apt-get install libcairo2-dev
出错:
下列的软件包有不能满足的依赖关系:
libcairo2-dev: 依赖: libpng12-dev 但是它将不会被安装
E: 无法安装的软件包
怎么解决?谢谢
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#2

帖子 windwiny » 2007-12-21 12:38

用 aptitude 来装试试
linuxyeshiquan
帖子: 22
注册时间: 2007-03-19 21:00
来自: 武汉市
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 linuxyeshiquan » 2007-12-21 14:01

sudo aptitude install libgtk2.0-dev
解决了,谢谢
回复

回到 “软件推荐”