当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Davinci DM6446板子mount NFS问题,急,谢谢达人指点!
帖子发表于 : 2008-05-22 9:15 
头像

注册: 2006-09-14 10:57
帖子: 27
地址: http://szmicrotiger.blogspot.com/
送出感谢: 0 次
接收感谢: 0 次
主机host:
OS:ubuntu 8.04 kernel 2.6.24
IP:192.168.1.110
netmask:255.255.255.0

板子:
OS:MV4.0 kernel2.6.10
IP:192.168.1.119
netmask:255.255.255.0

1. Install NFS software
$ sudo apt-get install nfs-common
$ sudo apt-get install nfs-kernel-server

2.在/建立共享项目nfst
#mkdir nfst
#chmod 777 -R nfst/
保证使用者都能够读、写、执行

3.编辑/etc/exports
#emacs /etc/exports
/nfst 192.168.1.*(rw,sync,no_root_squash)
其中/nfst表示主机要共享的目录,192.168.1.*为主机所允许访问的机器名,即处于192.168.1.*IP段的机器都可以访问共享目录。

4.#exportfs -r
更新exportfs

5.然后重启nfs服务,执行下面命令
#/etc/init.d/portmap restart
#/etc/init.d/nfs-kernel-server restart

成功启动后,执行
#showmount -e
显示如下:
/nfst 192.168.1.*

6.本机测试
在自己的机子上测试一下nfs服务,具体过程如下:
#mount -t nfs 192.168.1.110:/nfst /mnt
即把主机上/nfst目录mount到主机/mnt目录,正常,可以顺利mount成功。

7.在板子(客户端)进入shell,以root登录,设置板子的IP地址和子网掩码跟主机在一个地址段
#ifconfig eth0 address 192.168.1.119 netmask 255.255.255.0

8.然后相互ping,均能够ping通。
在板子上mount共享目录,将共享目录mount到/root
#mount -t nfs 192.168.1.110:/nfst /root
等待一段时间之后,报错如下:
root@DVS6446:/# mount -t nfs 192.168.1.110:/nfst /mnt
mount: RPC: Timed out
mount: nfsmount failed: Bad file descriptor
mount: Mounting 192.168.1.110:/nfst on /mnt failed: No such file or directory

以上描述的就是开发环境的设置和出错信息,搞了大半天,也参阅了一些帖子,问题始终没有能够解决,我在做pxa270开发的时候也遇到过使用NFS,很顺利就设置好了,今天这个搞的我真郁闷,希望有过这方面经验的达人或者前辈多多指点!谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-06 16:48 
头像

注册: 2006-09-14 10:57
帖子: 27
地址: http://szmicrotiger.blogspot.com/
送出感谢: 0 次
接收感谢: 0 次
我日,此问题已经解决!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-06-06 18:07 

注册: 2007-04-24 21:43
帖子: 165
送出感谢: 0 次
接收感谢: 0 次
怎么解决的?!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-06-08 10:51 

注册: 2008-05-31 20:07
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
楼主 我也想知道你是怎么解决的?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-09 9:08 
头像

注册: 2006-09-14 10:57
帖子: 27
地址: http://szmicrotiger.blogspot.com/
送出感谢: 0 次
接收感谢: 0 次
其实很简单,我默认启动了防火墙,把防火墙关闭之后,一切就正常了!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-06 10:37 

注册: 2008-01-19 19:33
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
microtiger 写道:
其实很简单,我默认启动了防火墙,把防火墙关闭之后,一切就正常了!


linux也杀毒软件?防火墙?我都是直接裸奔的


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译