当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : qmake出错
帖子发表于 : 2008-10-18 19:14 

注册: 2008-10-13 20:39
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我在ubuntu8.04下安装了QT4.4.3,但是我在qmake的时候出现了错误(我装的是ubuntu-8.04-desktop-i386),
程序 'qmake' 已包含在以下软件包中:
* libqt4-dev
* qt3-dev-tools
试试:apt-get install <选定的软件包>
bash: qmake:找不到命令


于是我试了下 apt-get install libqt4-dev,结果出现了下面的错误:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libqt4-dev: 依赖: libglib2.0-dev 但是它将不会被安装
依赖: libpq-dev 但是它将不会被安装
E: 无法安装的软件包


要是继续 apt-get install libglib2.0-dev,
下列的软件包有不能满足的依赖关系:
libglib2.0-dev: 依赖: libglib2.0-0 (= 2.16.3-1) 但是 2.16.3-1ubuntu3 正要被安装


在继续的话就是
E: 无法找到软件包 2.16.3-1ubuntu3


请问该如何解决?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: qmake出错
帖子发表于 : 2010-01-20 11:31 

注册: 2009-09-03 18:38
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
同样的问题,我也遇到了,解决方式是:因为是UBUNTU8.10发行版的问题,安装libpq-dev 8.4.1-1~intrepid1 ,注意不能安装libpq5_8.4.1-1~intrepid1_sparc.deb (115.7 KiB),会报跟I386构架冲突,显然需要在I386平台上的,需要下载libpq-dev_8.4.1-1~intrepid1_i386.deb,即可解决!


附件:
libpq-dev_8.4.1-1~intrepid1_i386.deb [205.09 KiB]
被下载 49 次
页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译