当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]insmod :kernel module version mismatch...
帖子发表于 : 2008-10-21 21:59 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
代码:
foobar.ko was compiled for kernel version
while this kernel is versin 2.6.13

为什么我编译的内核模块没有版本啊。
可是 include/linux/versin.h

代码:
#define UTS_RELEASE "2.6.13"
#define LINUX_VERSION_CODE 132621
#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8)
+ (c))
[/code]

我用的是2.6.13的内核,用make modules编译内核模块,加载不成功,请指点一下


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [已解决]insmod :kernel module version mismatch...
帖子发表于 : 2008-10-22 19:17 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
我的问题是因为busybox的insmod的问题,重新编译busybox,
还是包错,
代码:
version magic '2.6.14.7 ARMv4 gcc-3.4' should be '2.6.14.7 preempt ARMv4,


需要抢占式内核模块,于是make menuconfig,
代码:
(用make menuconfig调出内核配置菜单):
Loadable module support --->
#  Enable loadable module support
#  Module unloading
[ ] Module versioning support (EXPERIMENTAL)
#  Automatic kernel module loading

Kernel Feautre -> Preemptible Kernel

选择preemt


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译