当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : vmware下内核编译完成后,启动出错
帖子发表于 : 2009-01-09 13:56 

注册: 2009-01-07 18:50
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
vmware下ubuntu,编译了2.6.28的内核,在重启后却找不到盘了。
google了下,好像说是要将SCSI disk support, Buslogic SCSI support编译入内核。
但我将以上重编入内核后还是一样出错,不知有谁解决过这样的问题。
抓屏如下:


附件:
文件注释: 图片原件
error.jpg
error.jpg [ 58.71 KiB | 被浏览 700 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: vmware下内核编译完成后,启动出错
帖子发表于 : 2009-01-09 16:26 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
没有initrd.img?


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
3 楼 
 文章标题 : Re: vmware下内核编译完成后,启动出错
帖子发表于 : 2009-01-09 18:15 

注册: 2009-01-07 18:50
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
initrd.img是有的,menu.lst也正确。

应该是启动后找不到盘。但是按网上经验SCSI disk support, Buslogic SCSI support,ext3,AMD PCnet32 PCI support都编译进内核了,应该不会出现这种问题了。
郁闷!!!!!!!!恼火呀,编那么长时间白忙活了!!!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: vmware下内核编译完成后,启动出错
帖子发表于 : 2009-01-10 6:52 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
试试看不要用uuid的写法...


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
5 楼 
 文章标题 : Re: vmware下内核编译完成后,启动出错
帖子发表于 : 2009-01-10 11:54 

注册: 2009-01-07 18:50
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
改用root(hd0,0), root=/dev/sda1 的方式也不行
哎,放弃了。

采用帖子 ubuntu 2.6.22 内核树建立 http://forum.ubuntu.org.cn/viewtopic.php?f=97&t=109762
的方式建个内核树还是可以的。

至于编译新内核问题还是没解决,以后在试试吧。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译