当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : QT安装求助
帖子发表于 : 2009-05-07 10:07 

注册: 2007-11-21 15:13
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
qtx11和qt-embedded-linux-opensource-src-4.5.0-x86已经安装了,在安装qt-embedded-linux-opensource-src-4.5.0-arm的时候make出错了,google了半天没找到解决方法,蝈蝈大侠们帮帮我吧!
跪谢!

make[3]: 正在进入目录 `/home/victorsummer/src/qt-embedded-linux-opensource-src-4.5.0-arm/examples/desktop/screenshot'
arm-linux-g++ -fno-exceptions -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/QtEmbedded-4.5.0-arm/lib -Wl,-rpath,/usr/local/Trolltech/QtEmbedded-4.5.0-arm/lib -o screenshot .obj/release-shared-emb-arm/main.o .obj/release-shared-emb-arm/screenshot.o .obj/release-shared-emb-arm/moc_screenshot.o -L/home/victorsummer/src/qt-embedded-linux-opensource-src-4.5.0-arm/lib -lQtGui -L/home/victorsummer/src/qt-embedded-linux-opensource-src-4.5.0-arm/lib -lQtNetwork -lQtCore -lm -lrt -ldl -lpthread
/home/victorsummer/src/qt-embedded-linux-opensource-src-4.5.0-arm/lib/libQtCore.so: undefined reference to `__builtin_exit'
collect2: ld returned 1 exit status
make[3]: *** [screenshot] 错误 1
make[3]:正在离开目录 `/home/victorsummer/src/qt-embedded-linux-opensource-src-4.5.0-arm/examples/desktop/screenshot'
make[2]: *** [sub-screenshot-make_default-ordered] 错误 2
make[2]:正在离开目录 `/home/victorsummer/src/qt-embedded-linux-opensource-src-4.5.0-arm/examples/desktop'
make[1]: *** [sub-desktop-make_default] 错误 2
make[1]:正在离开目录 `/home/victorsummer/src/qt-embedded-linux-opensource-src-4.5.0-arm/examples'
make: *** [sub-examples-make_default-ordered] 错误 2


页首
 用户资料  
 
2 楼 
 文章标题 : Re: QT安装求助
帖子发表于 : 2009-05-07 10:10 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
不太懂!不过我知道Qt4.5.1出来了,Qt的问题在Qt中文论坛最专业! :em04


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: QT安装求助
帖子发表于 : 2009-05-07 10:14 

注册: 2007-11-21 15:13
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
郁闷哪 :em20 :em20 :em20 :em20 :em20


页首
 用户资料  
 
4 楼 
 文章标题 : Re: QT安装求助
帖子发表于 : 2009-05-22 16:54 

注册: 2008-09-26 15:44
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
maybe the version of "arm-linux-g++" is not proper.


页首
 用户资料  
 
5 楼 
 文章标题 : Re: QT安装求助
帖子发表于 : 2009-06-17 19:54 

注册: 2008-10-16 23:45
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
arm-linux-gcc 版本需要3.*以上,请注意libQtCore.so是否在搜索的路径中!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: QT安装求助
帖子发表于 : 2009-06-17 20:03 
头像

注册: 2007-12-09 22:36
帖子: 841
送出感谢: 0 次
接收感谢: 0 次
额,专业了,用源里的飘过。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译