当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 急:有在ubuntu的8.04、8.10、9.04上成功安装过arm-linux-gdb 么?
帖子发表于 : 2009-05-21 10:44 

注册: 2007-07-05 12:51
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
按照网上的帖子,实验了无数次都不成功。

gdb版本用了好几个,arm-linux-gcc也用了好几个。

我的主机是ubuntu8.10。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 急:有在ubuntu的8.04、8.10、9.04上成功安装过arm-linux-gdb 么?
帖子发表于 : 2009-05-21 10:47 
头像

注册: 2009-05-20 19:32
帖子: 2462
送出感谢: 0 次
接收感谢: 2
apt-get 就是了


_________________
irc 聊天室
ubuntu-cn 的irc 频道为
irc.ubuntu.com 8001 #ubuntu-cn
UTF8编码 可用 irssi xchat pidgin weechat 登录

http://webchat.freenode.net/?channels=ubuntu-cn
irc://irc.freenode.net/ubuntu-cn


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 急:有在ubuntu的8.04、8.10、9.04上成功安装过arm-linux-gdb 么?
帖子发表于 : 2009-05-21 14:04 

注册: 2007-07-05 12:51
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
哦,是么?我试了一下,没有阿。
能具体说下么?

O_O_BOT 写道:
apt-get 就是了


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 急:有在ubuntu的8.04、8.10、9.04上成功安装过arm-linux-gdb 么?
帖子发表于 : 2009-05-21 15:18 

注册: 2007-07-05 12:51
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
找到原因了。
是ubuntu版本问题。
在8.04中,非常顺利。
在8.10和9.04中,各种错误。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 急:有在ubuntu的8.04、8.10、9.04上成功安装过arm-linux-gdb 么?
帖子发表于 : 2009-06-04 23:22 

注册: 2009-02-23 17:29
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我感觉是GCC版本的原因 ,你把GCC版本降低可以吗?一定要从新安装ubuntu吗?在网上这样的文章多的是啊?
sudo apt-get install gcc-版本号
cd /usr/bin
sudo rm gcc
sudo ln -s gcc-版本号 gcc


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 急:有在ubuntu的8.04、8.10、9.04上成功安装过arm-linux-gdb 么?
帖子发表于 : 2009-06-05 20:09 

注册: 2007-07-05 12:51
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
恩,应该是gcc版本的问题。
我一定按你的方法试一下。谢谢啦~

guan5232 写道:
我感觉是GCC版本的原因 ,你把GCC版本降低可以吗?一定要从新安装ubuntu吗?在网上这样的文章多的是啊?
sudo apt-get install gcc-版本号
cd /usr/bin
sudo rm gcc
sudo ln -s gcc-版本号 gcc


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 急:有在ubuntu的8.04、8.10、9.04上成功安装过arm-linux-gdb 么?
帖子发表于 : 2009-06-07 12:08 
头像

注册: 2009-03-05 13:33
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
正在准备建立交叉编译环境


_________________
重头开始
arm-linux群:80827637


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 急:有在ubuntu的8.04、8.10、9.04上成功安装过arm-linux-gdb 么?
帖子发表于 : 2009-06-09 11:09 

注册: 2009-06-09 10:19
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
安装多个gcc编译器,比如我有3.4, 4.2及默认(4.3)

编译gdb呢,编译器版本要 < 4.3,我使用4.2及3.4都可成功。若是4.3及以上,会有莫名其妙的问题。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译