当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问这是什么问题?(关于miniGUI)
帖子发表于 : 2009-07-21 14:27 

注册: 2007-11-24 16:43
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
使用arm-linux-gcc可以顺利编译,但是使用gcc编译是会出现以下错误:
gcc-3.4 -I/armrfid/app2.4.18/minigui_lib/include -Wall -Wstrict-prototypes -pipe -D_REENTRANT -L/armrfid/app2.4.18/minigui_lib/lib -o helloworld helloworld.o -lminigui -lm -lpthread -lc -ljpeg -lttf
/usr/bin/ld: skipping incompatible /armrfid/app2.4.18/minigui_lib/lib/libminigui.a when searching for -lminigui
/usr/bin/ld: cannot find -lminigui
collect2: ld returned 1 exit status
make: *** [helloworld] 错误 1
不兼容是什么 意思。如何解决呢/ :em20 :em20


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请问这是什么问题?(关于miniGUI)
帖子发表于 : 2009-08-01 19:47 

注册: 2007-06-13 10:20
帖子: 21
送出感谢: 0 次
接收感谢: 2
it seems that "/armrfid/app2.4.18/minigui_lib/lib/libminigui.a" is the lib for ARM platform
but when you use GCC to compile the code, will generate the binary/runnable file for the X86 platform,
so if you want compile OK, you should find a libminigui.a of X86 version .


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译