当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,编译内核出现的3个问题
帖子发表于 : 2009-09-10 12:37 
头像

注册: 2009-02-06 18:47
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
本人用联想IdeaPad Y430,编译采用dshbusiness仁兄http://forum.ubuntu.org.cn/viewtopic.php?f=97&t=222228的方法,但是出了3个小问题,内核版本2.6.30.5

1、本人显卡是GF9300M GS,编译后启动显示一大堆英语,大意是找不到匹配的分辨率,按回车查找分辨率,按空格或等30秒继续。我之前刷过USplash,以为是USplash的问题,换回原先的甚至取消USplash甚至更改分辨率
都无效。

2、我明明勾选了NTFS的支持,包括读写,可是却无法挂载U盘,Win的分区(全是NTFS格式,悲剧),要怎么解决

3、我想重新编译安装ALSA,编译时提示ALSA已经在内核编译什么的,郁闷。(借问下如果在别人电脑上编译打包ALSA后能不能在自己定制的内核中安装)

如何在下次编译内核的时候避免上面的错误,望大家给点建议。


_________________
It's a world without wall. Who needs Windows?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助,编译内核出现的3个问题
帖子发表于 : 2009-09-10 17:05 
头像

注册: 2008-07-01 20:55
帖子: 80
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
初次编译不要随便乱去选项

要很小心,还要看依赖


_________________
处女座总是在好色与纯洁之间徘徊。
My Gmail : rchardx[at]gmail[dot]com
i686 Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz GenuineIntel GNU/Linux


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助,编译内核出现的3个问题
帖子发表于 : 2009-09-10 17:18 
头像

注册: 2009-02-06 18:47
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
在室友的肉机上做了几次实验
后,在本人本本上重新编译内核,结果解决了两个问题

1、无法挂载U盘等是因为没加载fuse模块,选上就好了(奇怪,我用的是默认配置,难道Linus没U盘?机子没Win分区?)

2、把声音选项的ALSA去掉,安装完内核就可以重新编译ALSA(oh,yeah)

第一个问题始终没解决,悲剧阿,我认为和刷USplash有关,因为曾经刷USplash出现类似后果


_________________
It's a world without wall. Who needs Windows?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助,编译内核出现的3个问题
帖子发表于 : 2009-09-10 19:18 
头像

注册: 2006-05-19 9:54
帖子: 1822
地址: Shanghai
送出感谢: 2
接收感谢: 11
2的话,最好不要在内核加入ntfs支持,当然fuse要,然后装ntfs-3g

1的话,可能是编译了不适合的显卡驱动了吧?顺便把xorg.conf删掉看看。


_________________
ニンニク入れますか?
x60 with gentoo


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译