当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-06 15:18 

注册: 2010-03-26 15:52
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
我想在ubuntu中安装软件,下了源码包,在终端运行./configure后有以下问题:
checking for CHEESE... configure: error: Package requirements ( glib-2.0 >= 2.15.5 gio-2.0 >= 2.15.5 gtk+-2.0 >= 2.10.0 libgnomeui-2.0 >= 2.14.0 gconf-2.0 >= 2.16.0 gstreamer-0.10 >= 0.10.15 gstreamer-plugins-base-0.10 >= 0.10.15 gnome-vfs-2.0 >= 2.18.0 libebook-1.2 >= 1.12.0 cairo >= 1.2.4 dbus-1 >= 1.0 hal >= 0.5.9 dbus-glib-1 >= 0.7 pangocairo >= 1.18.0 librsvg-2.0 >= 2.18.0 xxf86vm) were not met:

No package 'glib-2.0' found
No package 'gio-2.0' found
No package 'gtk+-2.0' found
No package 'libgnomeui-2.0' found
No package 'gconf-2.0' found
No package 'gstreamer-0.10' found
No package 'gstreamer-plugins-base-0.10' found
No package 'gnome-vfs-2.0' found
No package 'libebook-1.2' found
No package 'cairo' found
No package 'dbus-1' found
No package 'hal' found
No package 'dbus-glib-1' found
No package 'pangocairo' found
No package 'librsvg-2.0' found
No package 'xxf86vm' found

这个怎么解决?是不是缺少图形库?有没有什么好用的图形库推荐一下?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-06 16:48 
头像

注册: 2008-01-22 19:02
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
缺少依赖文件,这个程序 恐怕不能从这个版本里面安装了吧。。。听说 hal好象已经被移除ubuntu了。。。
不过 你可以考虑 sudo apt-get install 那些文件来试试能不能安。不过 不是 太可观。。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-06 16:55 
头像

注册: 2008-12-20 15:43
帖子: 9349
地址: 心靈深處
系统: 家14.04,公司14.04
送出感谢: 13
接收感谢: 37
自己編譯還未成功過的...路過幫頂...


_________________
[论坛版主行为规定]+[PITIVI簡易教程]+[CAD裝draftsight]+[酷我音乐裝kwplayer]+[ubuntu裝迅雷]
[releases.ubuntu.com]+[cdimage.ubuntu.com]+[old-releases.ubuntu.com]
[學ubuntu必須拜讀懶蝸牛"笨兔兔的故事"=viewtopic.php?f=112&t=162040][Linux明日的希望在中國]


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-10 14:17 

注册: 2010-03-26 15:52
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
这个问题到底怎么解决啊,我是这一个一个解决,可是没下一个软件包,都要安装其依赖的软件包,这样环环相扣,都装不完,是不是有一个综合性的软件包可以一并解决这些问题?高手请帮帮忙吧,谢谢啦!!1


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-10 14:28 

注册: 2010-03-26 15:52
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
遇到此错误是下边还有两行提示:
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CHEESE_CFLAGS
and CHEESE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

是不是能用这种方法?哪个好一点,怎么弄?最后一问最主要。。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-11 15:56 

注册: 2010-03-26 15:52
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
他报错的这几个no package我看了一下我的usr/lib里面好几个都有,而且版本都对,为什么还显示no package,是不是这个软件源码包里面的makefile文件的编写和我的环境有点不符?能不能帮忙一下?


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-16 13:31 

注册: 2010-03-26 15:52
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
没人么?帮帮忙啊!


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-16 13:31 

注册: 2010-03-26 15:52
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
没人么?帮帮忙啊!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-21 16:11 

注册: 2010-05-21 15:58
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我也遇到这个问题了。在线等答案!就是装cheese 的时候出现的。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-21 16:18 

注册: 2010-05-21 15:58
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
没人帮忙我先帮你顶起来!


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-22 15:46 

注册: 2010-03-26 15:52
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
lge6de 写道:
没人帮忙我先帮你顶起来!


我现在已经解决一部分了,现在还剩下这几个问题:
No package 'libebook-1.2' found
No package 'hal' found
No package 'xxf86vm' found

但是hal我的系统中是有的,为什么还显示没有?


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-22 16:09 

注册: 2010-05-21 15:58
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
怎么解决的?是一个一个的装吗?


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-22 16:30 

注册: 2010-03-26 15:52
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
lge6de 写道:
怎么解决的?是一个一个的装吗?


装了个gtk+-2.0就能解决许多了。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 软件安装时出现以下问题,希望得到帮助
帖子发表于 : 2010-05-24 11:18 

注册: 2010-05-21 15:58
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我也试试看!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译