当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 软件移植出现了问题
帖子发表于 : 2010-11-16 20:47 

注册: 2010-03-15 13:19
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
目标移植软件:
交叉编译器:
问题:
在将cc=gcc 改为cc=arm-linux-g++ (注:环境变量已经设置好)
#make 时,出现以下问题:
/opt/EmbedSky/4.3.3/bin/../lib/gcc/arm-none-linux-gnueabi/4.3.3/../../../../arm-none-linux-gnueabi/bin/ld: skipping incompatible /opt/EmbedSky/4.3.3/bin/../lib/gcc/arm-none-linux-gnueabi/4.3.3/armv4t/libusb.so when searching for -lusb
/opt/EmbedSky/4.3.3/bin/../lib/gcc/arm-none-linux-gnueabi/4.3.3/../../../../arm-none-linux-gnueabi/bin/ld: skipping incompatible /opt/EmbedSky/4.3.3/bin/../lib/gcc/arm-none-linux-gnueabi/4.3.3/armv4t/libusb.a when searching for -lusb

求教。。。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 软件移植出现了问题
帖子发表于 : 2010-11-17 18:07 
头像

注册: 2009-07-07 19:52
帖子: 240
送出感谢: 0 次
接收感谢: 0 次
根据错误提示, libusb.so 和 libusb.a 这两个文件应该不是用你的交叉编译器编译出来的,所以不能识别。


_________________
阿呆 : 天下第一呆!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 软件移植出现了问题
帖子发表于 : 2010-11-18 10:14 

注册: 2010-03-15 13:19
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
那我应该怎么做呢?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 软件移植出现了问题
帖子发表于 : 2010-11-18 15:08 
头像

注册: 2009-07-07 19:52
帖子: 240
送出感谢: 0 次
接收感谢: 0 次
当然是找源码重新编译 libusb.so 和 libusb.a 这两个文件了。

如果你没源码,那就杯具了。


_________________
阿呆 : 天下第一呆!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译