当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 升级到10.10后其中几个dkms老是报错,不知道应该怎么做了?
帖子发表于 : 2011-03-24 19:18 

注册: 2007-12-29 14:36
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
nstallArchives() failed: (正在读取数据库 ...
(正在读取数据库 ... 5%
(正在读取数据库 ... 10%
(正在读取数据库 ... 15%
(正在读取数据库 ... 20%
(正在读取数据库 ... 25%
(正在读取数据库 ... 30%
(正在读取数据库 ... 35%
(正在读取数据库 ... 40%
(正在读取数据库 ... 45%
(正在读取数据库 ... 50%
(正在读取数据库 ... 55%
(正在读取数据库 ... 60%
(正在读取数据库 ... 65%
(正在读取数据库 ... 70%
(正在读取数据库 ... 75%
(正在读取数据库 ... 80%
(正在读取数据库 ... 85%
(正在读取数据库 ... 90%
(正在读取数据库 ... 95%
(正在读取数据库 ... 100%
(正在读取数据库 ... 系统当前共安装有 232790 个文件和目录。)
正预备替换 linux-headers-2.6.35-28 2.6.35-28.49 (使用 .../linux-headers-2.6.35-28_2.6.35-28.50_all.deb) ...
正在解压缩将用于更替的包文件 linux-headers-2.6.35-28 ...
正预备替换 linux-headers-2.6.35-28-generic 2.6.35-28.49 (使用 .../linux-headers-2.6.35-28-generic_2.6.35-28.50_i386.deb) ...
正在解压缩将用于更替的包文件 linux-headers-2.6.35-28-generic ...
正预备替换 google-chrome-beta 10.0.648.151-r78498 (使用 .../google-chrome-beta_11.0.696.16-r78799_i386.deb) ...
正在解压缩将用于更替的包文件 google-chrome-beta ...
正预备替换 linux-image-2.6.35-28-generic 2.6.35-28.49 (使用 .../linux-image-2.6.35-28-generic_2.6.35-28.50_i386.deb) ...
Done.
正在解压缩将用于更替的包文件 linux-image-2.6.35-28-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
正预备替换 adobe-flashplugin 10.2.152.27-0lucid1 (使用 .../adobe-flashplugin_10.2.153.1-0lucid1_i386.deb) ...
正在解压缩将用于更替的包文件 adobe-flashplugin ...
正预备替换 linux-libc-dev 2.6.35-1028.49 (使用 .../linux-libc-dev_2.6.35-1028.50_i386.deb) ...
正在解压缩将用于更替的包文件 linux-libc-dev ...
正在处理用于 man-db 的触发器...
正在处理用于 menu 的触发器...
正在处理用于 python-gmenu 的触发器...
Rebuilding /usr/share/applications/desktop.zh_CN.UTF8.cache...
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 python-support 的触发器...
正在设置 dahdi-dkms (1:2.2.1+dfsg-1ubuntu3) ...
Removing old dahdi-2.2.1+dfsg-1ubuntu3 DKMS files...

------------------------------
Deleting module version: 2.2.1+dfsg-1ubuntu3
completely from the DKMS tree.
------------------------------
Done.
Loading new dahdi-2.2.1+dfsg-1ubuntu3 DKMS files...
Building only for 2.6.37-12-generic
Building for architecture i686
Building initial module for 2.6.37-12-generic

Error! Bad return status for module build on kernel: 2.6.37-12-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu3/build/ for more information.
Traceback (most recent call last):
File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/dahdi-dkms.0.crash'
dpkg:处理 dahdi-dkms (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 10
No apport report written because MaxReports is reached already
正在设置 linux-headers-2.6.35-28 (2.6.35-28.50) ...
正在设置 linux-headers-2.6.35-28-generic (2.6.35-28.50) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
* dkms: running auto installation service for kernel 2.6.35-28-generic
* tp-smapi (0.40)...
[ OK ]
* open-vm-tools (2010.06.16)...
[ OK ]
* batmand-gateway (0.3.2)...
[ OK ]
* blcr (0.8.2)...
[fail]
* batman-adv (2010.0.0)...
[ OK ]
* openafs (1.4.14)...
[ OK ]
* dahdi (2.2.1+dfsg-1ubuntu3)...
[fail]
* sl-modem (2.9.11~20100718)...
[ OK ]
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
正在设置 sl-modem-source (2.9.11~20100718-2) ...
Removing old sl-modem-2.9.11~20100718 DKMS files...

-------- Uninstall Beginning --------
Module: sl-modem
Version: 2.9.11~20100718
Kernel: 2.6.35-28-generic (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

slamr.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


ungrab-winmodem.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


slusb.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall Completed.

------------------------------
Deleting module version: 2.9.11~20100718
completely from the DKMS tree.
------------------------------
Done.
Loading new sl-modem-2.9.11~20100718 DKMS files...
Building only for 2.6.37-12-generic
Building for architecture i686
Building initial module for 2.6.37-12-generic

Error! Build of slamr.ko failed for: 2.6.37-12-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/sl-modem/2.9.11~20100718/build/ for more information.
Traceback (most recent call last):
File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/sl-modem-source.0.crash'
dpkg:处理 sl-modem-source (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 7
No apport report written because MaxReports is reached already
正在设置 batman-adv-dkms (2010.0.0-1) ...
Removing old batman-adv-2010.0.0 DKMS files...

-------- Uninstall Beginning --------
Module: batman-adv
Version: 2010.0.0
Kernel: 2.6.35-28-generic (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

batman-adv.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall Completed.

------------------------------
Deleting module version: 2010.0.0
completely from the DKMS tree.
------------------------------
Done.
Loading new batman-adv-2010.0.0 DKMS files...
Building only for 2.6.37-12-generic
Building initial module for 2.6.37-12-generic

Error! Bad return status for module build on kernel: 2.6.37-12-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/batman-adv/2010.0.0/build/ for more information.
Traceback (most recent call last):
File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/batman-adv-dkms.0.crash'
dpkg:处理 batman-adv-dkms (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 10
No apport report written because MaxReports is reached already
正在设置 open-vm-dkms (2010.06.16-268169-3ubuntu1) ...
Removing old open-vm-tools-2010.06.16 DKMS files...

-------- Uninstall Beginning --------
Module: open-vm-tools
Version: 2010.06.16
Kernel: 2.6.35-28-generic (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vmblock.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vmci.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vmhgfs.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vmsync.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vmxnet.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vsock.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall Completed.

------------------------------
Deleting module version: 2010.06.16
completely from the DKMS tree.
------------------------------
Done.
Loading new open-vm-tools-2010.06.16 DKMS files...
Building only for 2.6.37-12-generic
Building for architecture i686
Building initial module for 2.6.37-12-generic

Error! Build of vmci.ko failed for: 2.6.37-12-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/open-vm-tools/2010.06.16/build/ for more information.
Traceback (most recent call last):
File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/open-vm-dkms.0.crash'
dpkg:处理 open-vm-dkms (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 7
No apport report written because MaxReports is reached already
正在设置 google-chrome-beta (11.0.696.16-r78799) ...
正在设置 linux-image-2.6.35-28-generic (2.6.35-28.50) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.35-28-generic
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.35-28.49 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.35-28.49 was configured last, according to dpkg)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
* dkms: running auto installation service for kernel 2.6.35-28-generic
* tp-smapi (0.40)...
[ OK ]
* open-vm-tools (2010.06.16)...
[ OK ]
* batmand-gateway (0.3.2)...
[ OK ]
* blcr (0.8.2)...
[fail]
* batman-adv (2010.0.0)...
[ OK ]
* openafs (1.4.14)...
[ OK ]
* dahdi (2.2.1+dfsg-1ubuntu3)...
[fail]
* sl-modem (2.9.11~20100718)...
[ OK ]
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.35-28-generic /boot/vmlinuz-2.6.35-28-generic
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.37-12-generic
Found initrd image: /boot/initrd.img-2.6.37-12-generic
Found linux image: /boot/vmlinuz-2.6.35-28-generic
Found initrd image: /boot/initrd.img-2.6.35-28-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
正在设置 adobe-flashplugin (10.2.153.1-0lucid1) ...
update-alternatives: 使用 /usr/lib/adobe-flashplugin/libflashplayer.so 来提供 /usr/lib/iceape/plugins/flashplugin-alternative.so (iceape-flashplugin),于 自动模式 中。
update-alternatives: 使用 /usr/lib/adobe-flashplugin/libflashplayer.so 来提供 /usr/lib/iceweasel/plugins/flashplugin-alternative.so (iceweasel-flashplugin),于 自动模式 中。
update-alternatives: 使用 /usr/lib/adobe-flashplugin/libflashplayer.so 来提供 /usr/lib/mozilla/plugins/flashplugin-alternative.so (mozilla-flashplugin),于 自动模式 中。
update-alternatives: 使用 /usr/lib/adobe-flashplugin/libflashplayer.so 来提供 /usr/lib/firefox/plugins/flashplugin-alternative.so (firefox-flashplugin),于 自动模式 中。
update-alternatives: 使用 /usr/lib/adobe-flashplugin/libflashplayer.so 来提供 /usr/lib/xulrunner/plugins/flashplugin-alternative.so (xulrunner-flashplugin),于 自动模式 中。
update-alternatives: 使用 /usr/lib/adobe-flashplugin/libflashplayer.so 来提供 /usr/lib/midbrowser/plugins/flashplugin-alternative.so (midbrowser-flashplugin),于 自动模式 中。
update-alternatives: 使用 /usr/lib/adobe-flashplugin/libflashplayer.so 来提供 /usr/lib/xulrunner-addons/plugins/flashplugin-alternative.so (xulrunner-addons-flashplugin),于 自动模式 中。
正在设置 linux-libc-dev (2.6.35-1028.50) ...
正在处理用于 menu 的触发器...
在处理时有错误发生:
dahdi-dkms
sl-modem-source
batman-adv-dkms
open-vm-dkms
正在设置 dahdi-dkms (1:2.2.1+dfsg-1ubuntu3) ...
Removing old dahdi-2.2.1+dfsg-1ubuntu3 DKMS files...

------------------------------
Deleting module version: 2.2.1+dfsg-1ubuntu3
completely from the DKMS tree.
------------------------------
Done.
Loading new dahdi-2.2.1+dfsg-1ubuntu3 DKMS files...
Building only for 2.6.37-12-generic
Building for architecture i686
Building initial module for 2.6.37-12-generic

Error! Bad return status for module build on kernel: 2.6.37-12-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu3/build/ for more information.
Traceback (most recent call last):
File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/dahdi-dkms.0.crash'
dpkg:处理 dahdi-dkms (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 10
正在设置 batman-adv-dkms (2010.0.0-1) ...
Removing old batman-adv-2010.0.0 DKMS files...

-------- Uninstall Beginning --------
Module: batman-adv
Version: 2010.0.0
Kernel: 2.6.35-28-generic (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

batman-adv.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall Completed.

------------------------------
Deleting module version: 2010.0.0
completely from the DKMS tree.
------------------------------
Done.
Loading new batman-adv-2010.0.0 DKMS files...
Building only for 2.6.37-12-generic
Building initial module for 2.6.37-12-generic

Error! Bad return status for module build on kernel: 2.6.37-12-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/batman-adv/2010.0.0/build/ for more information.
Traceback (most recent call last):
File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/batman-adv-dkms.0.crash'
dpkg:处理 batman-adv-dkms (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 10
正在设置 sl-modem-source (2.9.11~20100718-2) ...
Removing old sl-modem-2.9.11~20100718 DKMS files...

-------- Uninstall Beginning --------
Module: sl-modem
Version: 2.9.11~20100718
Kernel: 2.6.35-28-generic (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

slamr.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


ungrab-winmodem.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


slusb.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall Completed.

------------------------------
Deleting module version: 2.9.11~20100718
completely from the DKMS tree.
------------------------------
Done.
Loading new sl-modem-2.9.11~20100718 DKMS files...
Building only for 2.6.37-12-generic
Building for architecture i686
Building initial module for 2.6.37-12-generic

Error! Build of slamr.ko failed for: 2.6.37-12-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/sl-modem/2.9.11~20100718/build/ for more information.
Traceback (most recent call last):
File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/sl-modem-source.0.crash'
dpkg:处理 sl-modem-source (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 7
正在设置 open-vm-dkms (2010.06.16-268169-3ubuntu1) ...
Removing old open-vm-tools-2010.06.16 DKMS files...

-------- Uninstall Beginning --------
Module: open-vm-tools
Version: 2010.06.16
Kernel: 2.6.35-28-generic (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vmblock.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vmci.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vmhgfs.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vmsync.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vmxnet.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vsock.ko:
- Uninstallation
- Deleting from: /lib/modules/2.6.35-28-generic/updates/dkms/
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall Completed.

------------------------------
Deleting module version: 2010.06.16
completely from the DKMS tree.
------------------------------
Done.
Loading new open-vm-tools-2010.06.16 DKMS files...
Building only for 2.6.37-12-generic
Building for architecture i686
Building initial module for 2.6.37-12-generic

Error! Build of vmci.ko failed for: 2.6.37-12-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/open-vm-tools/2010.06.16/build/ for more information.
Traceback (most recent call last):
File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/open-vm-dkms.0.crash'
dpkg:处理 open-vm-dkms (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 7


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级到10.10后其中几个dkms老是报错,不知道应该怎么做了?
帖子发表于 : 2011-03-25 14:44 
头像

注册: 2009-11-16 0:30
帖子: 328
地址: sh
送出感谢: 0 次
接收感谢: 0 次
不知道你的问题是怎么发生的


_________________
只有历经,才能懂得!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译