当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 10.10 下编译安装2.6.20.7内核启动出错(求救)
帖子发表于 : 2011-04-12 18:25 

注册: 2011-04-10 11:16
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
刚安装了ubuntu10.10(kernel 2.6.35),然后自己下了2.6.20.7的内核,编译安装后,启动时出现错误,系统直接挂死,显示

pciehp:can not get control of hotplug hardware for pci 0000.00.1C.0
mount: mounting none on /dev failed: No such device
udevd[962] : error getting socket : Invalid argument
error initializing netlink socket
udevd[962]: error initializing netlink socket
libudev: udev_monitor_newfrom_netlink:error getting socket: Invalid argument
Segmentation fault
Gave up waitting for root device . Common problems :
-Boot args (cat /proc/cmdline)
- Check rootdelay= (did the system wait long enough?)
-Check root= (did the system wait for the right device?)
-Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/.................................. (一长串字符不写了,uuid没错,和系统自带的内核一样) does not exit . Dropping to a shell!

向大神求救!多谢了
现在只能进35的内核,自己编译的内核没法启动,猜测是make menuconfig的问题,然后cp了系统的config文件,还是不行,同样的问题


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 10.10 下编译安装2.6.20.7内核启动出错(求救)
帖子发表于 : 2011-04-12 19:35 
头像

注册: 2009-01-19 15:09
帖子: 1982
送出感谢: 4
接收感谢: 8
为什么要编译那么老的内核?


_________________
坚守在linux的天堂!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 10.10 下编译安装2.6.20.7内核启动出错(求救)
帖子发表于 : 2011-04-12 19:39 

注册: 2011-04-10 11:16
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
rapistor 写道:
为什么要编译那么老的内核?


额,接手了一个老的程序,是在20内核下写的,在35下不能编译,所以。。。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu 10.10 下编译安装2.6.20.7内核启动出错(求救)
帖子发表于 : 2011-11-17 17:05 

注册: 2011-11-17 17:02
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
楼主解决没?我也出现了这个问题,找了两天,还没找到解决方法。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu 10.10 下编译安装2.6.20.7内核启动出错(求救)
帖子发表于 : 2011-11-29 12:46 
头像

注册: 2008-12-13 15:03
帖子: 395
送出感谢: 0 次
接收感谢: 1
引用:
mount: mounting none on /dev failed: No such device


devfs没选上吧,

然后,作为和内核关系最紧密的udev,使用低版本的内核必须使用配套的udev。


_________________
一条狗的马甲!
对不起,我承认我是一只穿着马甲的狗!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu 10.10 下编译安装2.6.20.7内核启动出错(求救)
帖子发表于 : 2011-12-06 16:58 

注册: 2011-12-06 14:56
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
poweroff 写道:
引用:
mount: mounting none on /dev failed: No such device


devfs没选上吧,

然后,作为和内核关系最紧密的udev,使用低版本的内核必须使用配套的udev。

这个是什么意思?我也遇到了同样的问题。。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu 10.10 下编译安装2.6.20.7内核启动出错(求救)
帖子发表于 : 2011-12-13 15:52 

注册: 2011-06-19 15:42
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
我认为是你的内核太旧了,10.10的内核版本至少是2.6.32以后的吧。你是不是用了当前内核的.config文件进行配置的?如果是的话,那肯定是配置选项没弄好


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译