ubuntu10.04下安装arm-elf-tools-20030314.sh报错

内核编译和嵌入式产品的设计与开发
回复
RosemaryYL
帖子: 3
注册时间: 2010-11-05 19:01
送出感谢: 0
接收感谢: 0

ubuntu10.04下安装arm-elf-tools-20030314.sh报错

#1

帖子 RosemaryYL » 2011-05-02 16:07

tail: cannot open `+43' for reading: No such file or directory

gzip: stdin: not in gzip format
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
我按照一般的加上-n和最后一行加上空行以后,依然会有问题

安装到最后的时候提示
./usr/local/bin/genromfs
./usr/local/bin/elf2flt
./usr/local/bin/flthdr

gzip: stdin: invalid compressed data--length error

是我加空行的方法有问题么?
我是按大写G到最后一行然后end,按i,敲回车,再保存。

如果用下面的方式的话,完全没有用还是会报错
tail -n +43 arm-elf-tools-20030314.sh | gunzip | tar xvf -

tail: n: invalid number of lines

gzip: stdin: unexpected end of file
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
头像
linjiework
帖子: 240
注册时间: 2009-07-07 19:52
送出感谢: 0
接收感谢: 0

Re: ubuntu10.04下安装arm-elf-tools-20030314.sh报错

#2

帖子 linjiework » 2011-05-05 14:56

请确认你完整的把这个文件下载下来了。

理论上你不需要做任何修改就能运行,如果不能运行,一般是文件没有下载全。
阿呆 : 天下第一呆!
回复

回到 “内核及嵌入式开发”