rtai的安装

内核编译和嵌入式产品的设计与开发
回复
zhangjing711
帖子: 20
注册时间: 2011-06-02 10:04
送出感谢: 0
接收感谢: 0

rtai的安装

#1

帖子 zhangjing711 » 2011-06-15 15:35

大家好,我用的是ubuntu9.10版本的内核,打的是rtai-3.8的补丁,但是测试环节出现如下错误
insmod: error inserting '/usr/realtime/modules/rtai_hal.ko': -1 Operation not permitted,不知道是什么问题
于是,我做了以下尝试
我输入gcc -v显示的是target: i486-linux-gnu,我的gcc版本是4.4.1(ubuntu 4.4.1-4ubuntu9)
紧接着输入的是cat /proc/version,显示的是linux version 2.6.31-14-generic (buildd@rothera) (gcc version 4.4..1)(ubuntu 4.4.1-4ubuntu8)
貌似现有的gcc版本不兼容,那么我是不是应该将gcc版本降为ubuntu8的?改装ubuntu8.04?还有其它的办法吗,谢谢~~
回复

回到 “内核及嵌入式开发”