当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 有谁在ubuntu成功安装过minigui啊!说出来分享一下阿
帖子发表于 : 2007-01-26 13:02 

注册: 2006-11-25 0:13
帖子: 24
送出感谢: 1
接收感谢: 0 次
如何在ubuntu中安装minigui阿


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-26 14:27 

注册: 2006-11-29 22:39
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
按照minigui的操作说明就可以完成了阿


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-26 14:31 

注册: 2006-11-25 0:13
帖子: 24
送出感谢: 1
接收感谢: 0 次
我试过拉,没有成功阿


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-26 15:03 

注册: 2006-11-25 0:13
帖子: 24
送出感谢: 1
接收感谢: 0 次
我是这样装的,从http://www.minigui.com/cgi-bin/nclogin.cgi?service=download&number=1&srvname=/minigui/minigui-dev-1.6.9-linux.tar.gz
下载到桌面,然后
tar -zxvf minigui-dev-1.6.9-linux.tar.gz
cd MiniGUI-dev-1.6.9-linux

发现里面是minigui-dev-1.6.9-linux.i386.rpm文件于是我跟注论坛里面

(1)装个将rpm包转换为deb包的小工具alien
apt-get install alien
(2)进入rpm所在的目录,输入命令
alien minigui-dev-1.6.9-linux.i386.rpm(转换为deb包的rpm文件)
这样就生成Ubuntu支持的minigui-dev_1.6.9-1_i386.deb

接下来
sudo dpkg -i minigui-dev_1.6.9-1_i386.deb
(正在读取数据库 ... 系统当前总共安装有 115711 个文件和目录。)
正预备替换 minigui-dev 1.6.9-1 (使用 minigui-dev_1.6.9-1_i386.deb) ...
正在解压缩将用于更替的包文件 minigui-dev ...
正在设置 minigui-dev (1.6.9-1) ...

就结束拉,不知道有没有装好


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-26 15:07 

注册: 2006-11-25 0:13
帖子: 24
送出感谢: 1
接收感谢: 0 次
后来我安装例子包,出现错误,我无语拉,毕竟我的linux太菜拉


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-31 22:54 

注册: 2007-01-28 10:04
帖子: 107
地址: 湖北武汉
送出感谢: 0 次
接收感谢: 0 次
建议楼主装个这个qt3-dev-tools-embedded,可能是你没有启动qvfb,要有这个才能显示的。我今天也在装minigui,可以显示。但是可能是我下的1.6.9的版本,这个是免费试用的。在运行程序的时候qvfb总提示说这个是免费试用版,让我使用增值版。很烦啊。

命令:sudo apt-get install qt3-dev-tools-embedded


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-02-05 19:36 

注册: 2006-11-25 0:13
帖子: 24
送出感谢: 1
接收感谢: 0 次
能不能把你的安装经验贴出来阿,能附图最好拉


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-02-05 20:05 

注册: 2006-11-25 0:13
帖子: 24
送出感谢: 1
接收感谢: 0 次
刚才又试了下,编译例子包的时候有出现问题,没有成功阿


页首
 用户资料  
 
9 楼 
 文章标题 : 我也出错
帖子发表于 : 2007-03-08 9:45 

注册: 2007-01-28 10:04
帖子: 107
地址: 湖北武汉
送出感谢: 0 次
接收感谢: 0 次
我的也是,用的minigui的版本是1.6.2-str,mg-samples包编译有问题。不知楼上的问题出在哪里。我的主要是和那个helloworld.c文件有关,但是按照网上的一些参考方法修改后还是有问题。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-03-09 16:30 

注册: 2007-01-28 10:04
帖子: 107
地址: 湖北武汉
送出感谢: 0 次
接收感谢: 0 次
今天又重新编译了一下mg-samples-str-1.6.2 包,按照minigui论坛上一高手的说法“删除 MiniGUI 源代码中调用'pthread_kill_other_threads_np'这个函数的语句。应该在 src/kernel/init.c 文件中,也可以运行 grep 找一下这个函数。”编译通过。在修改helloworld.c和init.c文件后,需要重新编译安装libminigui-str-1.6.2。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-06-17 8:34 

注册: 2006-05-16 12:36
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
10楼的,
我一开始也有这个问题,后来把gcc 4. 换成gcc 3 的就好了。 你不妨试试。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-06-20 23:25 

注册: 2007-06-20 23:21
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
leo198336 写道:
今天又重新编译了一下mg-samples-str-1.6.2 包,按照minigui论坛上一高手的说法“删除 MiniGUI 源代码中调用'pthread_kill_other_threads_np'这个函数的语句。应该在 src/kernel/init.c 文件中,也可以运行 grep 找一下这个函数。”编译通过。在修改helloworld.c和init.c文件后,需要重新编译安装libminigui-str-1.6.2。


把那行代码直接删了就行。没什么用。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-07-01 20:28 

注册: 2007-07-01 20:19
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我的编译可以通过,但是一执行,报错
error while loading shared libraries: libminigui-1.6.so.2: cannot open shared object file: No such file or directory
但是我明明在/usr/local/lib 下看到了libminigui-1.6.so.2 这个文件,这是怎么回事阿


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 有谁在ubuntu成功安装过minigui啊!说出来分享一下阿
帖子发表于 : 2011-04-08 12:55 

注册: 2011-04-08 12:22
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
collect2: ld returned 1 exit status
make[2]: *** [mgpoint] 错误 1
make[2]:正在离开目录 `/home/hw/ni/samples-1.6.10/mgpoint-1.0'
make[1]: *** [install-recursive] 错误 1
make[1]:正在离开目录 `/home/hw/ni/samples-1.6.10/mgpoint-1.0'
make: *** [install-recursive] 错误
安装samples 的时候出现的错误,请高手指教,我的是ubuntu10.10


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译