求教 交叉编译工具链与qmake不匹配问题

内核编译和嵌入式产品的设计与开发
回复
hugewave
帖子: 44
注册时间: 2008-09-28 10:56
送出感谢: 0
接收感谢: 0

求教 交叉编译工具链与qmake不匹配问题

#1

帖子 hugewave » 2015-06-16 11:00

交叉编译工具链用的是FriendlyArm编译好了的,版本4.5.1
ubuntu系统就的版本是14.04为64位
现在的错误提示是,gcc交叉编译工具是32位,qt装了两qt4 qt5都是64位
就是想要让QT在目标板(Tiny6410)上运行,我应该怎么做,急
万分感谢! :em01
---------------------------------------------------
另arm-linux-gcc -v可运行
安装过的包:
sudo apt-get install lsb-core
sudo apt-get install gcc-arm-linux-gnueabi
头像
GoodLuckyBoy
帖子: 50
注册时间: 2010-04-23 17:11
送出感谢: 0
接收感谢: 0

Re: 求教 交叉编译工具链与qmake不匹配问题

#2

帖子 GoodLuckyBoy » 2015-06-19 14:44

64 位系统运行 32 位的程序要装一个支持库,那个库装了没?

代码: 全选

sudo apt-get install libc6:i386
qt4 或 qt5 有没有使用 gcc 交叉编译工具编译过?
你说“qt装了两qt4 qt5都是64位”,那应该是 PC 上运行的 Qt 吧...
想要在开发板上运行 Qt 必须要交叉编译 Qt 应用程序
每夜唱不停,为了心中那点未了情
回复

回到 “内核及嵌入式开发”