当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 7.10的未必好,做嵌入式慎重选择
帖子发表于 : 2007-11-28 16:38 

注册: 2007-10-05 13:33
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
以前用的是redhat,编译很多程序都可以成功,前几天心血来潮,换了ubuntu7.10,可是噩梦也就从那时开始了

以前再redhat平台上都成功编译的skyeye,uclinux内核包都无法成功,没有了模拟器,我只要换备用的xcopilot,可这个也不成功,报很多错,这些错以前再redhat上从来没有过的

估计是新版的gcc编译器的规则更严了,以前再gcc3下面编译成功的再gcc4下面很多都过不去

真觉得那些开发gcc的人太不厚道了,别人都向上兼容,你咋就不能兼容一下呢

郁闷中。。。。

顺便贴下我再编译xcopilot的出错代码:

memory.c: 在函数 ‘verify_entrypoint’ 中:
memory.c:382: 错误: 自增运算中的左值无效
memory.c: 在函数 ‘load_rom’ 中:
memory.c:499: 错误: 赋值运算中的左值无效
make[2]: *** [memory.o] 错误 1
make[2]: Leaving directory `/home/wolf/embeded/xcopilot-0.6.6-uc0/mc68k'
make[1]: *** [all-recursive] 错误 1
make[1]: Leaving directory `/home/wolf/embeded/xcopilot-0.6.6-uc0'
make: *** [all-recursive-am] 错误 2
有哪位知道解决方法的给指条道,感激不尽


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-28 16:48 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
编译的,还是用践兔吧。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-28 17:15 
头像

注册: 2005-06-01 21:32
帖子: 191
送出感谢: 0 次
接收感谢: 0 次
好奇怪的想法~~ gcc4 编译不了, 那就装上gcc 3啊~ gcc3.x gcc2.95一起装上都不冲突啊~ 只是要设定一个默认的gcc就行了。 需要特定的gcc可以在Makefile里控制啊~~
并且,做嵌入式和你pc上的台式机没多少关系~~ 有用win做的,有用rh9.0做的。有用ubuntu做的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-28 18:36 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
.....看提示明显是非常严重的错误。。竟然还怪编译器的维护者。。。。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-28 19:07 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
我已经从7.10退回7.04了 :roll:


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-28 22:42 

注册: 2007-10-05 13:33
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
windwiny 写道:
.....看提示明显是非常严重的错误。。竟然还怪编译器的维护者。。。。


源代码又不是我写的,谈何严重的错误,况且以前我再redhat下成功编译过的


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-09 13:41 

注册: 2007-06-05 21:40
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
8) 要想省事,就RH9吧,选择全部安装。

至于gcc,3楼说的很清楚了,做嵌入式要视你定制的内核选择相应的gcc,我机子上装了3个gcc版本 :lol:


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-14 10:17 

注册: 2007-11-04 22:56
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
怎样才能让系统退回 7。04 版本?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-24 14:09 
头像

注册: 2007-11-23 12:31
帖子: 192
送出感谢: 0 次
接收感谢: 0 次
重新安装撒!呵呵 !


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-02-25 21:56 

注册: 2007-01-03 13:10
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我用的很好啊,7.10
兼容性要自己考虑的 :lol:


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-03-21 13:23 

注册: 2007-05-15 9:08
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我的也是7.10,嘻嘻,做嵌入式感觉也挺不错


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-04-01 21:34 

注册: 2008-04-01 21:20
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
如果LZ碰到的是GCC兼容性的问题的话,那和Ubuntu还是RH无关吧,自己装一个没有问题的GCC不就行了?


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-04-02 13:31 
头像

注册: 2008-03-31 12:58
帖子: 5
地址: GZ
送出感谢: 0 次
接收感谢: 0 次
这根本和用什么Linux系统无关好不好。
Makefile用来干什么的?自己不会选择编译工具啊。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-04-02 13:33 
头像

注册: 2008-03-31 12:58
帖子: 5
地址: GZ
送出感谢: 0 次
接收感谢: 0 次
至于gcc向下不兼容问题我也是深恨痛绝的。
bootloader,如u-boot用2.95.3可以编译通过,用3.4就不行了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译