当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]Ubuntu7.10+ELDK4.1总提示找不到arm-linux-gcc
帖子发表于 : 2007-12-30 4:28 

注册: 2007-12-25 0:07
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我用VMware装的Ubuntu7.10
下了ELDK4.1,文件是:
ftp://ftp.denx.de/pub/eldk/4.1/arm-linu ... -01-21.iso

一切安装都正常,我装在了
/opt/eldk下。

最后添加了环境变量:export PATH=/opt/eldk/usr/bin:/opt/eldk/bin:$PATH
执行arm-linux-gcc -v
能显示目录和版本号,也是ELDK4.1的版本。
/opt/eldk/usr/bin目录下有arm-linux-gcc这个文件。
但是执行sudo arm-linux-gcc -o helloworld helloworld.c
却提示找不到arm-linux-gcc
编译U-boot也提示找不到arm-linux-gcc
很郁闷的事情。


最后由 mycent 编辑于 2008-01-03 11:43,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-30 4:48 

注册: 2007-12-25 0:07
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
补充一下如果执行
sudo /opt/eldk/usr/bin/arm-linux-gcc -o helloworld helloworld.c
却可以正常。
执行${CROSS_COMPILE}gcc
提示arm-linux-gcc:no input files.(看起来正常)
执行${CROSS_COMPILE}gcc -o helloworld helloworld.c
提示不能输出helloworld.o,权限不够。看起来也算正常。
最后执行sudo ${CROSS_COMPILE}gcc -o helloworld helloworld.c
就提示找不到arm-linux-gcc了。
哪位大哥救救我吧,这到底是怎么回事啊。

如果执行arm-linux-gcc -v
正常。
执行sudo arm-linux-gcc -v
就提示找不到arm-linux-gcc
感觉是这个sudo在作怪。但是ubuntu不加sudo又没有读写权限,也不能编译了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-03 11:42 

注册: 2007-12-25 0:07
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
上面的问题已经解决了。
是因为在解压u-boot-1.3.1.tar.gz的时候用的是下面的命令解压的。
sudo tar -jxvf u-boot-1.3.1.tar.gz
导致权限不对了。正确的应该是:
tar -jxvf u-boot-1.3.1.tar.gz
这样在u-boot目录下执行make才不用加sudo


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-18 17:48 

注册: 2008-04-18 8:43
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
你好,不好意思打扰你了,我现在正在自学在ubuntu6。10上安装ELDK,但是ELDK是RPM包,而UBUNTU好象只能使用DEB,请问你在安装的时候是怎么解决的,非常感谢,希望你赐教


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-18 17:53 
头像

注册: 2008-03-17 17:47
帖子: 271
送出感谢: 0 次
接收感谢: 0 次
taoshahai 写道:
你好,不好意思打扰你了,我现在正在自学在ubuntu6。10上安装ELDK,但是ELDK是RPM包,而UBUNTU好象只能使用DEB,请问你在安装的时候是怎么解决的,非常感谢,希望你赐教

安装 alien
sudo apt-get install alien

后面就可以这样安装rpm包了

sudo alien -i name.rpm


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [已解决]Ubuntu7.10+ELDK4.1总提示找不到arm-linux-gcc
帖子发表于 : 2008-10-04 16:41 

注册: 2007-11-05 21:58
帖子: 133
地址: CH
送出感谢: 0 次
接收感谢: 0 次
好似不用, ELDK用install就可以自动安装需要的rpm了。
你可以看看iso文件的README, 讲的比较明白了。
里面也有手动安装/删除RPM的方法。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译