[求助]重新发:pppoe(奇怪,什么都没动就可以了)

上网、浏览、聊天、下载等
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

[求助]重新发:pppoe(奇怪,什么都没动就可以了)

#1

帖子 eexpress » 2005-08-17 14:05

dpkg:依赖关系问题使得 cedega 的配置工作不能继续:
cedega 依赖于 libasound2 (>> 1.0.9);然而:
系统里的 libasound2 的版本是 1.0.8-1.
dpkg:处理 cedega (--install)时出错:
依赖关系问题 - 仍未被配置
yongyi已经帮忙找到了libc6新的包。

pppoeconf了,pon没用。Globespan adsl modem驱动eciadsl-usermode-0.11.deb已经好了(需要libc6>= 2.3.2.ds1-21)。
ifconfig出了一个tap0网络设备。不知道在那里看。
没转rp-pppoe,否则adsl-setup,adsl-start就可以了。以前显示bring up tap0就ok了。
pppoe的pon应该也可以。
上次由 eexpress 在 2005-08-21 23:08,总共编辑 3 次。
● 鸣学
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 yongyi » 2005-08-17 14:16

rp-pppoe:
http://www.ubuntu.org.cn/support/docume ... e/rp-pppoe

libasound2:
http://packages.debian.org/cgi-bin/sear ... lla-search

BTW:这样好累啊。你还是快点把网络连上吧。还有,既然能有条件上网,就可以自己搜索 deb 包了。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2005-08-17 15:05

还是yongyi好。
libasound2 testing才1.0.9-3。可靠不。

rp-pppoe好的,应该马上就可以。辛苦了。不过,这样才可以培养感情阿。 :lol: :lol:

http://packages.debian.org/的搜索不清晰。找不到
上次由 eexpress 在 2005-08-17 15:11,总共编辑 1 次。
● 鸣学
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2005-08-17 15:10

Package libasound2
Package libasound2-dev
Package libasound2-doc
Package libasound2-plugins
全部testing (libs): 1.0.9-3下了。 :lol:
● 鸣学
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#5

帖子 lyreopera » 2005-08-17 16:20

lz在下deb包?

用这个吧

http://packages.ubuntu.com/
……
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

pppoe不会用

#6

帖子 eexpress » 2005-08-17 20:14

调制解调器。。。。
# eciadsl-start
[EciAdsl 1/5] Setting up USB support...

Preliminary USB device filesystem is OK

[EciAdsl 2/5] Uploading firmware...

GlobeSpan GS7070 USB ADSL WAN Modem compatible modem found (in 2424ms)
eciadsl-firmware: success
firmware loaded successfully

[EciAdsl 3/5] Synchronization...

OK eciadsl-synch: success
Synchronization successful

[EciAdsl 4/5] Connecting to provider...

Connection successful

[EciAdsl 5/5] Setting up route table...

Waiting for tap0...
驱动完全正常。。。
# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:723 errors:0 dropped:0 overruns:0 frame:0
TX packets:723 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:64796 (63.2 KiB) TX bytes:64796 (63.2 KiB)

tap0 Link encap:Ethernet HWaddr 00:FF:41:E8:0D:C6
inet6 addr: fe80::2ff:41ff:fee8:dc6/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:378 (378.0 b)

# pppoeconf tap0
┌─────────────┤ DSL CONNECTION FOUND ├─────────┐
│ │
│ I found an Access Concentrator on tap0. Should I setup │
│ PPPOE for this connection? │
│ │
│ <是> <否> │
│ │
└──────────────────────────────────┘
│ If you continue with this program, the configuration file │
│ /etc/ppp/peers/dsl-provider will be modified. Please make sure│
│ that you have a backup copy before saying Yes. │
│ │
│ Continue with configuration? │
└───────────────────────────────────────┘
│ The DSL connection has been triggered. You can use the │
│ "plog" command to see the status or "ifconfig ppp0" │
│ for general interface info. │
└────────────────────────────────────┘
need setup /etc/resolv.conf 修改DNS

# pon dsl-provider
Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2
rp-pppoe.so 位于 /usr/lib/pppd/2.4.2,没有提示版本低了。
没有已经连接的提示。。。。

# plog
Aug 17 19:15:34 localhost pppd[10109]: Using interface ppp0
Aug 17 19:15:34 localhost pppd[10109]: Connect: ppp0 <--> tap0
Aug 17 19:15:34 localhost pppd[10109]: Couldn't increase MTU to 1500
Aug 17 19:15:34 localhost pppd[10109]: Couldn't increase MRU to 1500
Aug 17 19:15:34 localhost pppd[10109]: Couldn't increase MRU to 1500
Aug 17 19:15:34 localhost pppd[10109]: Remote message:

代码: 全选

: Unable to find user in database^J
Aug 17 19:15:34 localhost pppd[10109]: PAP authentication failed
Aug 17 19:15:34 localhost pppd[10109]: Couldn't increase MTU to 1500
Aug 17 19:15:34 localhost pppd[10109]: Couldn't increase MRU to 1500
Aug 17 19:15:34 localhost pppd[10109]: Connection terminated.
可能是MTU的问题????认证问题???但密码等应该没错。

below is file content of /etc/ppp/peers/dsl-provider
noipdefault
usepeerdns
defaultroute
hide-password
lcp-echo-interval 20
lcp-echo-failure 3
connect /bin/true
noauth
persist
mtu 1492
noaccomp
default-asyncmap
plugin rp-pppoe.so tap0
user "CSD1873424"
● 鸣学
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 yongyi » 2005-08-17 21:38

哇。怎么USB的modem要这么复杂的?!不懂。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2005-08-17 22:27

不复杂。最复杂的是modem的配置,已经轻松完成了,已经有个tap0了。用ppp0去连。
请说明pppoe怎么用。ppp0在哪里可以看到。ppp0应该可以看成一个modem设备了吧。
● 鸣学
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 yongyi » 2005-08-17 22:35

你是用RP-PPPoE吧?参看这个:
http://www.ubuntu.org.cn/support/docume ... term=pppoe

如果是原来的,就用sudo pppoeconf 配置一下就可以上网了。sudo pon 是链接上网,sudo poff 是断线下网。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#10

帖子 yonsan » 2005-08-17 22:44

:o 呵呵,希望楼主解决问题后整理一下你的经验贴出来,方便以后有遇到同样问题的朋支!!
I will be back!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#11

帖子 eexpress » 2005-08-18 9:43

yongyi 写了:你是用RP-PPPoE吧?参看这个:
http://www.ubuntu.org.cn/support/docume ... term=pppoe

如果是原来的,就用sudo pppoeconf 配置一下就可以上网了。sudo pon 是链接上网,sudo poff 是断线下网。
这些都试过了。是要用pppoe哦,dsl-provider是ppponconf指定配置的。pon dsl-provider不行。
rp-pppoe的哪个在以前其他的系统用的很好,ubuntu这里没反应。好像就是哪个go-gui和go执行了都一样。提示不记得了。就是没反应。
modem的配置倒是很熟悉了。以前曾经用2个版本rpm和tar的杂交配置出tap0,现在用最新版本的deb一次就成功了。
搞不好,就要买个eth0接口的modem了,那才是失败阿。要是搞好了,我就出个经验多好。以前好像Globespan的modem很多阿。
● 鸣学
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 yongyi » 2005-08-18 10:08

试试在终端运行:
sudo /opt/rp-pppoe-3.5/go-gui
/opt/rp-pppoe-3.5 换成你的目录
看有没信息可帮助一下。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#13

帖子 eexpress » 2005-08-18 10:10

好的,等我回家才知道。 :lol:
● 鸣学
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 yongyi » 2005-08-18 11:41

顺便把你的/etc/network/interfaces 贴出来看看
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 yongyi » 2005-08-18 11:43

找到个类似的:
poff dsl-provider
deactivate eth0 in networking gui
pon dsl-provider

my conncetion never get terminated any more.
to keep eth0 from coming up at boot edit your /etc/network/interfaces by commenting out the lines:


# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
#mapping hotplug
# script grep
# map eth0

# The primary network interface
#iface eth0 inet dhcp
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
回复

回到 “因特网相关软件”