vbox启动报错.

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
wqzds
帖子: 25
注册时间: 2016-10-03 20:08
系统: Ubuntu
送出感谢: 5 次
接收感谢: 0

vbox启动报错.

#1

帖子 wqzds » 2016-12-02 20:15

RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'/sbin/vboxconfig'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user.
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 995 次
联系:

Re: vbox启动报错.

#2

帖子 vickycq » 2016-12-02 20:22

1. 执行以下指令将结果全部复制贴上来

代码: 全选

dpkg -l | grep virtualbox
2. 尝试执行以下指令

代码: 全选

sudo apt-get install dkms
su root -c '/sbin/vboxconfig'
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
wqzds
帖子: 25
注册时间: 2016-10-03 20:08
系统: Ubuntu
送出感谢: 5 次
接收感谢: 0

Re: vbox启动报错.

#3

帖子 wqzds » 2016-12-02 20:30

vickycq,

代码: 全选

ii  unity-scope-virtualbox                     0.1+13.10.20130723-0ubuntu1                                 all          VirtualBox scope for Unity
ii  virtualbox-5.1                             5.1.10-112026~Ubuntu~xenial                                 amd64        Oracle VM VirtualBox
ii  virtualbox-dkms                            5.0.24-dfsg-0ubuntu1.16.04.1                                all          x86 virtualization solution - kernel module sources for dkms
rc  virtualbox-qt                              5.0.24-dfsg-0ubuntu1.16.04.1                                amd64        x86 virtualization solution - Qt based user interface
wqzds
帖子: 25
注册时间: 2016-10-03 20:08
系统: Ubuntu
送出感谢: 5 次
接收感谢: 0

Re: vbox启动报错.

#4

帖子 wqzds » 2016-12-03 13:41

vickycq, 尝试指令无效.
poloshiao
论坛版主
帖子: 18274
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: vbox启动报错.

#5

帖子 poloshiao » 2016-12-03 14:20

尝试指令无效.
只說無效 不容易幫你
最好把指令執行的回應文字
全部複製貼上來
头像
TeliuTe
论坛版主
帖子: 7451
注册时间: 2007-11-25 13:29
系统: 14/16/18/Fedroa22/w7
来自: 新疆博乐
送出感谢: 30 次
接收感谢: 102 次
联系:

Re: vbox启动报错.

#6

帖子 TeliuTe » 2016-12-03 14:26

重新编译下vbox内核:
安装dkms
运行 sudo /etc/init.d/vboxdrv setup
wqzds
帖子: 25
注册时间: 2016-10-03 20:08
系统: Ubuntu
送出感谢: 5 次
接收感谢: 0

Re: vbox启动报错.

#7

帖子 wqzds » 2016-12-03 14:26

vickycq,
sudo apt-get install dkms

代码: 全选

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
dkms 已经是最新版 (2.2.0.3-2ubuntu11.3)。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 62 个软件包未被升级。
有 13 个软件包没有被完全安装或卸载。
解压缩后会消耗 0 B 的额外空间。
您希望继续执行吗? [Y/n] 
正在设置 python-beautifulsoup (3.2.1-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-beautifulsoup (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
正在设置 python-cairo (1.8.8-2) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-cairo (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
正在设置 python-dbus (1.2.0-3) ...
Remove stale byte-compiled files...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-dbus (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
正在设置 python-feedparser (5.1.3-3build1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-feedparser (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-gi (3.20.0-0ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-gi (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-gobject-2 (2.28.6-12ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-gobject-2 (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-libxml2 (2.9.3+dfsg1-1ubuntu0.1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-libxml2 (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-numpy (1:1.11.0-1ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-numpy (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-pkg-resources (20.7.0-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-pkg-resources (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-six (1.10.0-3) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-six (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-utidylib (0.2-9build1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-utidylib (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-xdg (0.25-4) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-xdg (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在设置 python-tz (2014.10~dfsg1-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: 处理软件包 python-tz (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回错误状态 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                    正在处理用于 libc-bin (2.23-0ubuntu4) 的触发器 ...
在处理时有错误发生:
 python-beautifulsoup
 python-cairo
 python-dbus
 python-feedparser
 python-gi
 python-gobject-2
 python-libxml2
 python-numpy
 python-pkg-resources
 python-six
 python-utidylib
 python-xdg
 python-tz
E: Sub-process /usr/bin/dpkg returned an error code (1)
su root -c '/sbin/vboxconfig'

代码: 全选

vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: Starting VirtualBox services.
wqzds
帖子: 25
注册时间: 2016-10-03 20:08
系统: Ubuntu
送出感谢: 5 次
接收感谢: 0

Re: vbox启动报错.

#8

帖子 wqzds » 2016-12-03 14:28

TeliuTe,

代码: 全选

sudo: /etc/init.d/vboxdrv:找不到命令
头像
TeliuTe
论坛版主
帖子: 7451
注册时间: 2007-11-25 13:29
系统: 14/16/18/Fedroa22/w7
来自: 新疆博乐
送出感谢: 30 次
接收感谢: 102 次
联系:

Re: vbox启动报错.

#9

帖子 TeliuTe » 2016-12-03 21:31

安装的vbox是源里的还是官网下载的?参考下这一贴: viewtopic.php?t=463154
poloshiao
论坛版主
帖子: 18274
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: vbox启动报错.

#10

帖子 poloshiao » 2016-12-03 22:36

运行 sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv:找不到命令
安装的vbox是源里的还是官网下载的?参考下这一贴: viewtopic.php?t=463154
1. 試試

代码: 全选

sudo /usr/lib/virtualbox/vboxdrv.sh setup
1-1. 以下是 virtualbox-5.1
5.1.10-112026~Ubuntu~xenial
1-2. sudo dpkg -L virtualbox-5.1 | grep vboxdrv.sh
/usr/lib/virtualbox/vboxdrv.sh
已經沒有 /etc/init.d/vboxdrv
1-3. vboxdrv.sh 是可執行檔
sudo ls -al /usr/lib/virtualbox/vboxdrv.sh
-rwxr-xr-x 1 root root 17031 11月 22 01:50 /usr/lib/virtualbox/vboxdrv.sh
1-4. vboxdrv.sh 是 script file
sudo cat /usr/lib/virtualbox/vboxdrv.sh

2. virtualbox-5.1 安裝方法
https://www.virtualbox.org/wiki/Linux_Downloads
Debian-based Linux distributions
manami5
帖子: 116
注册时间: 2016-06-21 13:16
送出感谢: 0
接收感谢: 3 次

Re: vbox启动报错.

#11

帖子 manami5 » 2016-12-10 3:38

如果是VirtualBox官网下载的 那么请卸载其他名字带有virtualbox的包,只保留virtualbox一个
jjwkl
帖子: 1
注册时间: 2018-01-17 9:13
系统: ubuntu 16.04 LTS
送出感谢: 0
接收感谢: 0

Re: vbox启动报错.

#12

帖子 jjwkl » 2018-01-17 9:15

把这些全卸载了,然后重新装一遍
unity-scope-virtualbox
virtualbox-5.1
virtualbox-dkms
virtualbox-qt

卸载:
sudo apt-get remove virtualbox-qt
卸载不掉的用下面的这个命令:
sudo apt autoremove virtualbox-5.1
回复

回到 “虚拟机和虚拟化”