新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

系统安装、升级讨论
用户名错误
帖子: 14
注册时间: 2018-07-07 15:06
系统: windows7
送出感谢: 1 次
接收感谢: 0

新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#1

帖子 用户名错误 » 2018-07-07 15:27

刚下载个32位Ubuntu的iso,往VIrtualbox里安装的时候总是出现严重错误,根本装不上,求助怎么解决好顺利安装上。
错误日志在附件
VBoxlog.txt
(293.18 KiB) 下载 14 次
头像
astolia
论坛版主
帖子: 3282
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 550 次

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#2

帖子 astolia » 2018-07-07 21:22

你下载的ubuntu-16.04.4-desktop-i386.iso,检查过完整性没有?它的md5应该是 bc10544792ffef5bfe5b2bb87b5a5cbf,你找个md5校验工具测一下
用户名错误
帖子: 14
注册时间: 2018-07-07 15:06
系统: windows7
送出感谢: 1 次
接收感谢: 0

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#3

帖子 用户名错误 » 2018-07-08 0:32

校验了
文件: K:\VirtualBox VMs\Linux\Ubuntu\ubuntu-16.04.4-desktop-i386.iso
大小: 1640955904 字节
修改时间: 2018年7月6日, 22:51:05
MD5: BC10544792FFEF5BFE5B2BB87B5A5CBF
SHA1: 0BDDDF2C2ADF43337CAAC40AC5FD65317F08EB2A
CRC32: 0CEBE4D5
头像
Ping-Wu
帖子: 906
注册时间: 2012-11-14 9:34
系统: Ubuntu 18.04.1
送出感谢: 2 次
接收感谢: 45 次

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#4

帖子 Ping-Wu » 2018-07-08 3:28

用户名错误 写了:
2018-07-07 15:27
刚下载个32位Ubuntu的iso,往VIrtualbox里安装的时候总是出现严重错误,根本装不上,求助怎么解决好顺利安装上。
错误日志在附件VBoxlog.txt
装虚拟机时是否选择32-bit?
头像
astolia
论坛版主
帖子: 3282
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 550 次

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#5

帖子 astolia » 2018-07-08 11:14

你的日志中有这么一句

代码: 全选

00:00:04.461313 HM: HMR3Init: Falling back to raw-mode: VT-x is not available
而你的CPU是 Intel Xeon X5482,虽然老,但还是支持VT-x的 https://ark.intel.com/products/33088/In ... 00-MHz-FSB
你看一下是不是BIOS里把VT-x的功能禁用了。
如果没有禁用,那么你换5.0或5.1版的Virtualbox试一下,新版对硬件的要求要高一些
这些用户感谢了作者 astolia 于这个帖子:
用户名错误 (2018-07-08 12:36)
评价: 3.7%
用户名错误
帖子: 14
注册时间: 2018-07-07 15:06
系统: windows7
送出感谢: 1 次
接收感谢: 0

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#6

帖子 用户名错误 » 2018-07-08 12:43

astolia 写了:
2018-07-08 11:14
你的日志中有这么一句

代码: 全选

00:00:04.461313 HM: HMR3Init: Falling back to raw-mode: VT-x is not available
而你的CPU是 Intel Xeon X5482,虽然老,但还是支持VT-x的 https://ark.intel.com/products/33088/In ... 00-MHz-FSB
你看一下是不是BIOS里把VT-x的功能禁用了。
如果没有禁用,那么你换5.0或5.1版的Virtualbox试一下,新版对硬件的要求要高一些
感谢大神,我电脑的CPU是5200,就不支持VT-x,看来想在旧机器上折腾Ubuntu是不行了。是不是Ubuntu必须使用VT-X还是某个版本需要?如果必须的话只能换到新机器上折腾了,十分感谢。
头像
astolia
论坛版主
帖子: 3282
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 550 次

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#7

帖子 astolia » 2018-07-08 15:42

intel的vt-x或amd的amd-v都是硬件辅助虚拟化技术,用了之后跑虚拟系统的性能会有提升。ubuntu本身不需要vt-x。virtualbox 5.2新版对它的依赖比较重,CPU不支持的话可能会出问题。所以我建议你用旧版5.0或5.1的virtualbox来试试。
另外一方面,ubuntu 16.04.4桌面版对系统的最小内存需求是2G,你分配给虚拟机的内存只有1G,也可能是出问题的原因之一。
用户名错误
帖子: 14
注册时间: 2018-07-07 15:06
系统: windows7
送出感谢: 1 次
接收感谢: 0

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#8

帖子 用户名错误 » 2018-07-08 16:56

astolia 写了:
2018-07-08 15:42
intel的vt-x或amd的amd-v都是硬件辅助虚拟化技术,用了之后跑虚拟系统的性能会有提升。ubuntu本身不需要vt-x。virtualbox 5.2新版对它的依赖比较重,CPU不支持的话可能会出问题。所以我建议你用旧版5.0或5.1的virtualbox来试试。
另外一方面,ubuntu 16.04.4桌面版对系统的最小内存需求是2G,你分配给虚拟机的内存只有1G,也可能是出问题的原因之一。
我刚安装了vbox5.0,最小内存调到了大于2048,还是严重错误,错误日志在附件,请不吝赐教
附件
VBoxlog1.txt
(275.07 KiB) 下载 12 次
头像
astolia
论坛版主
帖子: 3282
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 550 次

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#9

帖子 astolia » 2018-07-08 21:00

你调整一下虚拟机系统的设置呢?比如关掉IO APIC,禁掉PAE,换一下虚拟主板的芯片组等等。
如果还不行的话,那么没必要再在vbox上耗下去了,换其他家的虚拟机,比如vmware player。若vmware player也有问题的话,只有放弃你那台老机器上跑虚拟机的想法了。换新机器,或者备份好数据,直接实机安装
头像
速腾1994
论坛版主
帖子: 17366
注册时间: 2008-11-01 20:43
系统: Arch+gnome
送出感谢: 23 次
接收感谢: 8 次

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#10

帖子 速腾1994 » 2018-07-09 9:57

为什么是16.04,换18.04试试
用户名错误
帖子: 14
注册时间: 2018-07-07 15:06
系统: windows7
送出感谢: 1 次
接收感谢: 0

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#11

帖子 用户名错误 » 2018-07-09 23:02

astolia 写了:
2018-07-08 21:00
你调整一下虚拟机系统的设置呢?比如关掉IO APIC,禁掉PAE,换一下虚拟主板的芯片组等等。
如果还不行的话,那么没必要再在vbox上耗下去了,换其他家的虚拟机,比如vmware player。若vmware player也有问题的话,只有放弃你那台老机器上跑虚拟机的想法了。换新机器,或者备份好数据,直接实机安装
我今天又一次降级,降到ubuntu-14.04.5-desktop-i386,这次可以安装了,正在摸索Ubuntu的操作中,感谢。
用户名错误
帖子: 14
注册时间: 2018-07-07 15:06
系统: windows7
送出感谢: 1 次
接收感谢: 0

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#12

帖子 用户名错误 » 2018-07-09 23:08

速腾1994 写了:
2018-07-09 9:57
为什么是16.04,换18.04试试
18.04压根不支持32位,因为我是32位机,所以只能降级安装
poloshiao
论坛版主
帖子: 18273
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#13

帖子 poloshiao » 2018-07-10 11:43

18.04压根不支持32位,因为我是32位机,所以只能降级安装
1. 如果你要下載 18.04 的 iso 來全新安裝 沒有 i386 (32 bit) 只有 amd64 (64 bit) 可以下載
2. 如果你是從已安裝的 i386 (32 bit) 16.04.x Ubuntu 可以升級到 i386 (32 bit) 的 18.04.y
2-1. 但是 建議等 18.04.1 發行後 再升級 (七月底) 參閱
https://wiki.ubuntu.com/BionicBeaver/Re ... _16.04_LTS
2-2. 意思是 ubuntu 18.04 還是支援 i386 (32 bit) 只是不再提供全新安裝的 installer 或說 iso.
2-3. Ubuntu 移除 支援 i386 (32 bit) 是指日可待的事 所以建議 儘早 移到 amd64 (64 bit)
用户名错误
帖子: 14
注册时间: 2018-07-07 15:06
系统: windows7
送出感谢: 1 次
接收感谢: 0

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#14

帖子 用户名错误 » 2018-07-11 23:22

poloshiao 写了:
2018-07-10 11:43
18.04压根不支持32位,因为我是32位机,所以只能降级安装
1. 如果你要下載 18.04 的 iso 來全新安裝 沒有 i386 (32 bit) 只有 amd64 (64 bit) 可以下載
2. 如果你是從已安裝的 i386 (32 bit) 16.04.x Ubuntu 可以升級到 i386 (32 bit) 的 18.04.y
2-1. 但是 建議等 18.04.1 發行後 再升級 (七月底) 參閱
https://wiki.ubuntu.com/BionicBeaver/Re ... _16.04_LTS
2-2. 意思是 ubuntu 18.04 還是支援 i386 (32 bit) 只是不再提供全新安裝的 installer 或說 iso.
2-3. Ubuntu 移除 支援 i386 (32 bit) 是指日可待的事 所以建議 儘早 移到 amd64 (64 bit)
好的多谢指教,我安装ubuntu-14.04.5-desktop-i386成功,直装16.04不行,我看能不能从14.04升级到16.04,如果可以的话我就等升级到18.04.1,如果不行,那只有暂时持续使用14.04摸索摸索适应一下了,等用的差不多了再在新机器上装18.04.再次感谢。
用户名错误
帖子: 14
注册时间: 2018-07-07 15:06
系统: windows7
送出感谢: 1 次
接收感谢: 0

Re: 新人求助。windows7的VirtualBox5.2.14中安装Ubuntu16.04.4失败

#15

帖子 用户名错误 » 2018-07-11 23:26

poloshiao 写了:
2018-07-10 11:43
18.04压根不支持32位,因为我是32位机,所以只能降级安装
1. 如果你要下載 18.04 的 iso 來全新安裝 沒有 i386 (32 bit) 只有 amd64 (64 bit) 可以下載
2. 如果你是從已安裝的 i386 (32 bit) 16.04.x Ubuntu 可以升級到 i386 (32 bit) 的 18.04.y
2-1. 但是 建議等 18.04.1 發行後 再升級 (七月底) 參閱
https://wiki.ubuntu.com/BionicBeaver/Re ... _16.04_LTS
2-2. 意思是 ubuntu 18.04 還是支援 i386 (32 bit) 只是不再提供全新安裝的 installer 或說 iso.
2-3. Ubuntu 移除 支援 i386 (32 bit) 是指日可待的事 所以建議 儘早 移到 amd64 (64 bit)
另外Vbox5.x版启动虚拟机总是报错不能打开虚拟机,我按网上教程把Vbox也降到4.3.12了 :Cry
回复

回到 “系统安装和升级”