ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#1

帖子 Archer123 » 2014-08-02 11:21

我的是最近easybcd安装的ubuntu14.04 amd64位
安装详见我的 viewtopic.php?f=77&t=462272&p=3096125#p3096125

我的无线网卡rtl8723be安装是参照 http://www.linuxidc.com/Linux/2014-03/98321.htm
其实在执行make的时候 出现了点error没仔细看 就接着按这个指引 执行了git checkout 604aa9058fb9e5bb1cf571c99989d081f8fc8b9

再接着执行 make
sudo make install
sudo modprobe rtl8723be

重启系统 再进入系统就成功搜索到附近无线wifi了 可用了一周发现个问题 就是 每隔1h 50m 的时候就会断线 再手动用托盘图标去断开 再重连就死活重连不上了 只能重新启动系统才能又连接wifi正常。可还是每隔一定时间就掉线。

网上搜索资料 2天后 有端倪 发现了一些资料 (哎 搜索关键字是门学问 搜的好问题很快就找到)

http://blog.csdn.net/haoyyy/article/details/37939879
这个里边这样说
装完驱动后,发现过一段时间就会自动掉线,掉线后不能重连,相当的不稳定。

最终在网上找到了解决方法:

[plain] view plaincopy

sudo echo "options rtl8723be fwlps=0 swlps=0" > /etc/modprobe.d/rtl8723be.conf
sudo reboot


安装的ubuntu系统,相信其他系统应该也一样使用。
参考:

https://bugs.launchpad.net/ubuntu/+sour ... ug/1240940

35,38,41楼
#38

Currently, it's working fine on my Lenovo B5400 under Ubuntu 14.04 x86_64 (kernel 3.13.0-30) and configured in /etc/modprobe.d/rtl8723be.conf with parameters

options rtl8723be fwlps=0 swlps=0


看来这位也是 ubuntu14.04 和64位的系统 只是内核和我不一样我的是 3.13.0-24 不过看来影响不大 一会去试试这个方案。

继续找资料 最终在archlinux wiki 上找到了 rtl8723be的编译过程问题解决 和其他方案。这个方案是解决部分编译过程遇到的问题 如果按这个方案 可能也不需要 添加/etc/modprobe.d/rtl8723be.conf 和那些参数了。
https://wiki.archlinux.org/index.php/Wi ... #rtl8723be

截选:
rtl8723be
Tango-mail-mark-junk.png This article or section is poorly written.
Reason: This belongs to the AUR, then there can be only simple reference to install the package. (Discuss)
Tango-mail-mark-junk.png

The driver for this card is designated to be entered into the Linux kernel as a part of version 3.15. Until version 3.15 is released, the kernel module for the card can be downloaded from lwfinger's github. If git is not installed, please install it.

$ cd ~/temp
$ git clone https://github.com/lwfinger/rtl8723be.git
$ cd rtl8723be
$ make
# make install
# modprobe rtl8723be

When running make, some users may encounter a compile error based on the kernel version. If, and only if you encounter a compile error:

$ nano rtl8723be/trx.c

On line 621, change the line

if ((_ieee80211_is_robust_mgmt_frame(hdr)) &&

to

if ((ieee80211_is_robust_mgmt_frame(hdr)) &&

Save, then cd back to the main rtl8723be directory and continue from make install Additionally, some users may encounter errors with powersave on this card. This is shown with occasional disconnects that are not recognized by high level network managers (netctl, NetworkManager). This error can be confirmed by running $ dmesg -w or $ journalctl -f and looking for output related to powersave and the rtl8723be module. If you are having this issue, you need to add a kernel option:

# nano /etc/modprobe.d/rtl8723be.conf

Add this line to the new file:

#Prevents the WiFi card from automatically sleeping and halting connection
options rtl8723be fwlps=0

That should rectify any issues with firmware powersaving.

大家可以试下这个 安装时候就弄好。
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#2

帖子 Archer123 » 2014-08-02 11:43

继续研究 发现
这段话 When running make, some users may encounter a compile error based on the kernel version. If, and only if you encounter a compile error:

$ nano rtl8723be/trx.c

On line 621, change the line

if ((_ieee80211_is_robust_mgmt_frame(hdr)) &&

to

if ((ieee80211_is_robust_mgmt_frame(hdr)) &&


这应该是改 trx.c 文件 去掉了个_ 然后在执行make 那其实还是发布rtl8723be 的lwfinger 的驱动程序有问题

又看下边 options rtl8723be fwlps=0

fwlps 参数设置 那我去搜到了这个
https://github.com/lwfinger/rtl8723be/b ... 723be/sw.c

find lps 发现了这段
module_param_named(swenc, rtl8723be_mod_params.sw_crypto, bool, 0444);
module_param_named(ips, rtl8723be_mod_params.b_inactiveps, bool, 0444);
module_param_named(swlps, rtl8723be_mod_params.b_swctrl_lps, bool, 0444);
module_param_named(fwlps, rtl8723be_mod_params.b_fwctrl_lps, bool, 0444);
MODULE_PARM_DESC(swenc, "using hardware crypto (default 0 [hardware])\n");
MODULE_PARM_DESC(ips, "using no link power save (default 1 is open)\n");
MODULE_PARM_DESC(fwlps, "using linked fw control power save (default 1 is open)\n");


因为网上有些资料 说是 这么改
1 options rtl8723be fwlps=0 swlps=0
http://blog.csdn.net/haoyyy/article/details/37939879

2 #Prevents the WiFi card from automatically sleeping and halting connection
options rtl8723be fwlps=0
https://wiki.archlinux.org/index.php/Wi ... #rtl8723be

3 options rtl8723be ips=0 fwlps=0 swenc=1
viewtopic.php?t=460003

所以 我就好奇 ips fwlps swlps swenc 分别什么含义

大致英文里知道Prevents the WiFi card from automatically sleeping and halting connection
That should rectify any issues with firmware powersaving.

是 自动休眠和固件省电问题。


swenc, "using hardware crypto (default 0 [hardware]
硬件加密设置 默认是0

ips, "using no link power save (default 1 is open
不使用链接省电 默认是1 默认是开启 就是启用省电。


fwlps, "using linked fw control power save (default 1 is open
链接FW控制省电 默认是1 就是打开省电设置


综合以上 我们就知道了 options rtl8723be 是什么意思了。 就是关闭省电设置。
大家慢慢尝试吧 估计 给一个就可以了 fwlps=0 或者 两个 ips=0 fwlps=0
加密还是留着吧!
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#3

帖子 Archer123 » 2014-08-02 12:31

继续资料

I'm on Kernel 3.4.0-1-ARCH. Maybe it works for you.
After a lot of times trying get it working good finally I did.
This is what I did:
1. Check if rtl8192ce is loaded:
lsmod
2. Get some information about it:
modinfo rtl8192ce
and check the parameters info at the end.
3. Check how are configured those parameters:
systool -v -m rtl8192ce
I got under "Parameters:"
debug = "0"
fwlps = "Y"
ips = "Y"
swnc = "N"
swlps = "N"
If you already checked the command results at the end in step 2, you saw that some of this parameters are for power saving. So I decided disable.
4. Make a file in /etc/modprobe.d/rtl8192ce.conf and add this:
options rtl8192ce ips=0 fwlps=0
and save it and reboot.
(disable those you are enable)
5. Repeat step 3 to check if the parameters were disable.
6. Eso es todo! Disfruta!


还是这个靠谱 先执行下systool -v -m rtl8723be 看下自己的参数设置吧


modinfo -F parm rtl8192ce
swlps: (bool)
swenc:using hardware crypto (default 0 [hardware])
(bool)
ips:using no link power save (default 0 is off)
(bool)
fwlps:using no linked fw control power save (default 0 is off)
(bool)

纠正下 这个命令 应该是查看 可供传递的参数命令 不是差看已编译进去的参数
上次由 Archer123 在 2014-08-04 8:54,总共编辑 2 次。
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#4

帖子 Archer123 » 2014-08-03 11:01

missing wireless driver for Thinkpad T440s?

I think I'm desperately gonna need Dr. Chili's help with this one.

Your wireless-info report is one of the most interesting ones I've seen, partly because of the latest driver, and partly because of the settings and dmesg messages.

Suggestions however, are more or less the same, based on the following -
Quote Originally Posted by programmer-x View Post
Code:

wlan1 IEEE 802.11bgn ESSID:"Woody"
Mode:Managed Frequency:2.437 GHz Access Point: <MAC address removed>
Bit Rate=144.4 Mb/s AP20x-Power=20 dBm
....
....
rtl8192ee 139274 0
btcoexist 105039 1 rtl8192ee
....
....
*Woody: Infra, <MAC address removed>, Freq 2437 MHz, Rate 54 Mb/s, Strength 86 WPA WPA2
....
....
wlan1 Scan completed :
Cell 01 - Address: <MAC address removed>
Channel:6
....
....
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
....
IE: WPA Version 1
Group Cipher : CCMP
....
....
filename: /lib/modules/3.11.0-15-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ee/rtl8192ee.ko
firmware: rtlwifi/rtl8192eefw.bin
....
parm: swlps:bool
parm: swenc:using hardware crypto (default 0 [hardware])
(bool)
parm: ips:using no link power save (default 1 is open)
(bool)
parm: fwlps:using linked fw control power save (default 1 is open)
(bool)
....
....
[ 12.447146] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
....
[ 25.626798] rtlwifi-0:rtl_op_set_key():<0-0> Using hardware based encryption for keyidx: 0, mac: <MAC address removed>
[ 25.626801] rtlwifi-0:rtl_op_set_key():<0-0> alg:CCMP
[ 25.626802] rtlwifi-0:rtl_op_set_key():<0-0> set enable_hw_sec, key_type:4(OPEN:0 WEP40:1 TKIP:2 AES:4 WEP104:5)
....
[ 37.379555] rtlwifi-0:rtl_lps_set_psmode():<0-0> FW LPS enter ps_mode:3
....
[ 37.532256] rtlwifi-0:rtl_lps_set_psmode():<10000-1> FW LPS leave ps_mode:0
<then continuously fluctuating between ps_mode 3 and 0 throught the dmesg>
<some of the interesting parts later might have been ignored>
...

1) Unless your router is buggy, disabling N-channel (in other words, setting it to b/g mode only) shouldn't bring the whole network down, it should only reduce the speed from 150+Mb/s to 54 Mb/s. So... did you reboot the router after saving the change? Could you access its web interface from any system afterwards? Did it show b/g-only mode? Reboot the connected system(s) too after saving the changes, just to be extra sure.

2) Apart from trying the b/g-only mode again, simultaneously also change its encryption type to pure WPA2-only with AES (CCMP). Currently you are using WPA/WPA2 mixed mode, which, according to my limited knowledge (which may have become rusty) depends upon TKIP for the WPA part. As such, these kind of routers surprise me when they allow AES (CCMP) only with the WPA/WPA2 mixed mode. Keep this setting to pure WPA2-AES even if it doesn't seem to help.

3) Another change you *should* (not necessary, but sometimes does the miracle) try is to change from channel 6 to channel 1 (or 11).

Make all of three changes above simultaneously > Save > reboot both the router and the system. If the network seems to go down again (to me, it would certify it a buggy router), revert the first change only, or the 3rd one also if seems to make things worse (otherwise keep it to channel 1 or 11). Keep the encryption to pure WPA2-AES as suggested.

Apart from the above changes in the router, try the following in Ubuntu -

4) To try switching from "Hardware based Encryption" to Software based encryption -
Code:

sudo modprobe -rv rtl8192ee
sudo modprobe -v rtl8192ee swenc=1

5) If the above doesn't help, then to try disabling the firmware control power-save mode -
Code:

sudo modprobe -rv rtl8192ee
sudo modprobe -v rtl8192ee fwlps=0

6) And to also disable "No-Link" power save mode -
Code:

sudo modprobe -rv rtl8192ee
sudo modprobe -v rtl8192ee fwlps=0 ips=0

7) If the above don't help, then try all three parameters simultaneously (to disable all power save modes, and use software based encryption)-
Code:

sudo modprobe -rv rtl8192ee
sudo modprobe -v rtl8192ee swenc=1 fwlps=0 ips=0

These will be temporary changes that would be lost at next boot. So try using the connection without rebooting after above parameter changes. If any of them seems to help, we can make it permanent.

And lastly, if none of the suggestions above could help, please post a fresh report of wireless_script with the recommended settings applied (the N-channel may be reverted if necessary). With that, please also post the output of the following separately -
Code:

modinfo btcoexist

(hmm.. never expected that 'Feature' could come as an independent driver, hmm..)

EDIT: Oh, and did you also try Completely disabling IPv6 as per the post I linked to? Perhaps not much significant here, but just to eliminate the usual suspects..

这个资料叶不错 modprobe的时候 可以直接传递编译参数
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#5

帖子 Archer123 » 2014-08-03 11:48

一个执行方式

epikureer@epikureer:~$ echo "options rtl8192ce ips=0 fwlps=0 swenc=1" | sudo tee /etc/modprobe.d/rtl8192ce.conf
[sudo] password for epikureer:
options rtl8192ce ips=0 fwlps=0 swenc=1

epikureer@epikureer:~$ sudo service network-manager stop
network-manager stop/waiting
epikureer@epikureer:~$ sudo modprobe -rfv rtl8192ce #慎用f f自己去查下什么含义
rmmod rtl8192ce
rmmod rtlwifi
rmmod mac80211
rmmod cfg80211
epikureer@epikureer:~$ sudo modprobe -v rtl8192ce
insmod /lib/modules/3.13.0-24-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/3.13.0-24-generic/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
insmod /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko ips=0 fwlps=0 ips=0 fwlps=0 swenc=1
epikureer@epikureer:~$ sudo service network-manager start
network-manager start/running, process 3724
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#6

帖子 Archer123 » 2014-08-04 9:35

最后
我的解决执行过程
先停止网路
$ sudo service network-manager stop
network-manager stop/waiting


删除卸载老的无线网卡驱动
$ sudo modprobe -rfv rtl8723be
rmmod rtl8723be
rmmod rtlwifi
rmmod mac80211
rmmod cfg80211
rmmod btcoexist


进入当初git clone 下rtl8723be的目录去执行 make
~/MyDownload/rtl8723be$ sudo make
make -C /lib/modules/3.13.0-24-generic/build M=/home/cmd/MyDownload/rtl8723be modules
make[1]: 正在进入目录 `/usr/src/linux-headers-3.13.0-24-generic'
CC [M] /home/cmd/MyDownload/rtl8723be/base.o
CC [M] /home/cmd/MyDownload/rtl8723be/rc.o
CC [M] /home/cmd/MyDownload/rtl8723be/debug.o
CC [M] /home/cmd/MyDownload/rtl8723be/regd.o
CC [M] /home/cmd/MyDownload/rtl8723be/efuse.o
CC [M] /home/cmd/MyDownload/rtl8723be/cam.o
CC [M] /home/cmd/MyDownload/rtl8723be/ps.o
CC [M] /home/cmd/MyDownload/rtl8723be/core.o
CC [M] /home/cmd/MyDownload/rtl8723be/stats.o
CC [M] /home/cmd/MyDownload/rtl8723be/pci.o
LD [M] /home/cmd/MyDownload/rtl8723be/rtlwifi.o
Building modules, stage 2.
MODPOST 1 modules
CC /home/cmd/MyDownload/rtl8723be/rtlwifi.mod.o
LD [M] /home/cmd/MyDownload/rtl8723be/rtlwifi.ko
make[1]:正在离开目录 `/usr/src/linux-headers-3.13.0-24-generic'
make[1]: 正在进入目录 `/home/cmd/MyDownload/rtl8723be/btcoexist'
make -C /lib/modules/3.13.0-24-generic/build M=/home/cmd/MyDownload/rtl8723be/btcoexist modules
make[2]: 正在进入目录 `/usr/src/linux-headers-3.13.0-24-generic'
CC [M] /home/cmd/MyDownload/rtl8723be/btcoexist/halbtc8723b2ant.o
CC [M] /home/cmd/MyDownload/rtl8723be/btcoexist/halbtcoutsrc.o
CC [M] /home/cmd/MyDownload/rtl8723be/btcoexist/rtl_btc.o
LD [M] /home/cmd/MyDownload/rtl8723be/btcoexist/btcoexist.o
Building modules, stage 2.
MODPOST 1 modules
CC /home/cmd/MyDownload/rtl8723be/btcoexist/btcoexist.mod.o
LD [M] /home/cmd/MyDownload/rtl8723be/btcoexist/btcoexist.ko
make[2]:正在离开目录 `/usr/src/linux-headers-3.13.0-24-generic'
make[1]:正在离开目录 `/home/cmd/MyDownload/rtl8723be/btcoexist'
make[1]: 正在进入目录 `/home/cmd/MyDownload/rtl8723be/rtl8723be'
make -C /lib/modules/3.13.0-24-generic/build M=/home/cmd/MyDownload/rtl8723be/rtl8723be modules
make[2]: 正在进入目录 `/usr/src/linux-headers-3.13.0-24-generic'
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/hw.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/table.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/sw.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/trx.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/led.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/fw.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/phy.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/rf.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/dm.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/pwrseq.o
CC [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/pwrseqcmd.o
LD [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/rtl8723be.o
Building modules, stage 2.
MODPOST 1 modules
CC /home/cmd/MyDownload/rtl8723be/rtl8723be/rtl8723be.mod.o
LD [M] /home/cmd/MyDownload/rtl8723be/rtl8723be/rtl8723be.ko
make[2]:正在离开目录 `/usr/src/linux-headers-3.13.0-24-generic'
make[1]:正在离开目录 `/home/cmd/MyDownload/rtl8723be/rtl8723be'
居然没报错?

执行安装 也没报错
~/MyDownload/rtl8723be$ sudo make install
make -C /lib/modules/3.13.0-24-generic/build M=/home/cmd/MyDownload/rtl8723be modules
make[1]: 正在进入目录 `/usr/src/linux-headers-3.13.0-24-generic'
Building modules, stage 2.
MODPOST 1 modules
make[1]:正在离开目录 `/usr/src/linux-headers-3.13.0-24-generic'
make[1]: 正在进入目录 `/home/cmd/MyDownload/rtl8723be/btcoexist'
make -C /lib/modules/3.13.0-24-generic/build M=/home/cmd/MyDownload/rtl8723be/btcoexist modules
make[2]: 正在进入目录 `/usr/src/linux-headers-3.13.0-24-generic'
Building modules, stage 2.
MODPOST 1 modules
make[2]:正在离开目录 `/usr/src/linux-headers-3.13.0-24-generic'
make[1]:正在离开目录 `/home/cmd/MyDownload/rtl8723be/btcoexist'
make[1]: 正在进入目录 `/home/cmd/MyDownload/rtl8723be/rtl8723be'
make -C /lib/modules/3.13.0-24-generic/build M=/home/cmd/MyDownload/rtl8723be/rtl8723be modules
make[2]: 正在进入目录 `/usr/src/linux-headers-3.13.0-24-generic'
Building modules, stage 2.
MODPOST 1 modules
make[2]:正在离开目录 `/usr/src/linux-headers-3.13.0-24-generic'
make[1]:正在离开目录 `/home/cmd/MyDownload/rtl8723be/rtl8723be'
find /lib/modules/3.13.0-24-generic -name "btcoexist_*.ko" -exec rm {} \;
find /lib/modules/3.13.0-24-generic -name "r8723be_*.ko" -exec rm {} \;


传递进fwlps=0 ips=0 之前执行过systool 老的make的驱动是打开了 fwips ips为Y
~$ sudo modprobe -v rtl8723be fwlps=0 ips=0
insmod /lib/modules/3.13.0-24-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/3.13.0-24-generic/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
insmod /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/rtlwifi/btcoexist/btcoexist.ko
insmod /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko fwlps=0 ips=0

重启
cmd@TR:~$reboot


重启后查看 发现 发现还是 打开了 fwips 和 ips
~$ systool -v -m rtl8723be
Module = "rtl8723be"

Attributes:
coresize = "130544"
initsize = "0"
initstate = "live"
refcnt = "0"
srcversion = "EB08EA82D0846E3925AFAB6"
taint = "OF"
uevent = <store method only>

Parameters:
fwlps = "Y"
ips = "Y"
swenc = "N"
swlps = "N"

Sections:
.bss = "0x0000000000000000"
.data = "0x0000000000000000"
.data.unlikely = "0x0000000000000000"
.exit.text = "0x0000000000000000"
.gnu.linkonce.this_module= "0x0000000000000000"
.init.text = "0x0000000000000000"
.note.gnu.build-id = "0x0000000000000000"
.rodata = "0x0000000000000000"
.rodata.str1.1 = "0x0000000000000000"
.rodata.str1.8 = "0x0000000000000000"
.strtab = "0x0000000000000000"
.symtab = "0x0000000000000000"
.text = "0x0000000000000000"
__mcount_loc = "0x0000000000000000"
__param = "0x0000000000000000"


那么既然无法把ips 和 fwips直接modprobe进去 只能编辑rtl8723be.conf了

echo "options rtl8723be ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf


sudo service network-manager stop
sudo modprbe -rfv rtl8723be
sudo modprobe -v rtl8723be
再重启 重启的时候好像 在黑屏那里报了两行错 闪的太快没看清但正常启动了系统 再执行systool -v -m rtl8723be 发现都变N了

发来贺电 已经6h17m了 仍未掉线
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#7

帖子 Archer123 » 2014-08-06 12:17

鼓捣下 menuconfig

看下内核里关于无线驱动的支持 发现原生3.13.0.24 刚安装完的内核里是不支持rtl8723be驱动的 下一步看看如何将已经安装的rtl8723be 动态加载 加M到内核中。

另有一个问题 第一次执行menuconfig 生成的 .config 里边的描述为什么是 3.13.9 图中出来的也是3.13.9 谁知道为什么? 我的/boot/config-3.13.0-24-generic 里的是正常的

#
# Automatically generated file; DO NOT EDIT.
# Linux/x86_64 3.13.0-24-generic Kernel Configuration
#


这个生成的是这样的
#
# Automatically generated file; DO NOT EDIT.
# Linux/x86 3.13.9 Kernel Configuration
#

why?
3.13.0.24 menuconfig.png
bujingyun23
帖子: 3
注册时间: 2014-09-05 10:23
系统: ubuntu14
送出感谢: 1 次
接收感谢: 0

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#8

帖子 bujingyun23 » 2014-09-05 15:35

很牛啊!
yyaicy
帖子: 12
注册时间: 2014-10-10 14:00
系统: ubuntu14.04
送出感谢: 0
接收感谢: 0

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#9

帖子 yyaicy » 2014-10-13 14:59

mark,无线网和软件安装时新手最大的问题,我装了后无线网不稳定,和楼主一样经常断,还有就是安装软件,14.04自带的软件没有解码器,应用中心的又不可以下载(包依赖问题)。对于一个新手来说,上手好难。
yyaicy
帖子: 12
注册时间: 2014-10-10 14:00
系统: ubuntu14.04
送出感谢: 0
接收感谢: 0

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#10

帖子 yyaicy » 2014-10-13 14:59

mark,无线网和软件安装时新手最大的问题,我装了后无线网不稳定,和楼主一样经常断,还有就是安装软件,14.04自带的软件没有解码器,应用中心的又不可以下载(包依赖问题)。对于一个新手来说,上手好难。
srainbow
帖子: 1
注册时间: 2013-10-17 10:57
系统: ubuntu 12.04.3
送出感谢: 0
接收感谢: 0

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#11

帖子 srainbow » 2014-10-16 9:52

rtl8723be wifi驱动的代码了,现在的git地址也换了,
http://github.com/lwfinger/rtlwifi_new.git,最新代码已经支持3.13.0-37,
测试编译并安装通过。
各位升级kernel后,可以试试新的代码,默认的参数仍然是fwlps=1 ips=1,这个参数会不会导致断开连接,有兴趣的童鞋可以试试。

modprobe 加参数OK,我直接用这个这个参数,sudo modprobe -v rtl8723be fwfps=0 ips=0
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#12

帖子 Archer123 » 2014-11-12 11:34

srainbow 写了:rtl8723be wifi驱动的代码了,现在的git地址也换了,
http://github.com/lwfinger/rtlwifi_new.git,最新代码已经支持3.13.0-37,
测试编译并安装通过。
各位升级kernel后,可以试试新的代码,默认的参数仍然是fwlps=1 ips=1,这个参数会不会导致断开连接,有兴趣的童鞋可以试试。

modprobe 加参数OK,我直接用这个这个参数,sudo modprobe -v rtl8723be fwfps=0 ips=0







有最新的了 :em11
头像
Archer123
帖子: 146
注册时间: 2008-05-18 10:16
送出感谢: 2 次
接收感谢: 6 次

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#13

帖子 Archer123 » 2014-11-12 17:04

试了下最新的 已经用上了 挺好的 没啥问题。

1 先安装好需要编译的东西
sudo apt-get install linux-headers-generic build-essential git

2 cd切换到需要放rtlwifi_new 到目录下 ,再执行
git clone http://github.com/lwfinger/rtlwifi_new.git

3 先停止网路
sudo service network-manager stop

4 cd 到 rtlwifi_new 目录下
sudo make
sudo make install
sudo modprobe -v rtl8723be fwlps=0 ips=0

5 sudo reboot 重启

6 确认是否关闭 fwlps=N ips=N
systool -v -m rtl8723be


这样首次安装rtl8723be 驱动 就完成了。


如果不是首次 在第3步 后执行 删除卸载老的无线网卡驱动
$ sudo modprobe -rfv rtl8723be

如果查看 fwlps=Y ips=Y 的话,就 echo "options rtl8723be ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf
这些用户感谢了作者 Archer123 于这个帖子:
mtllyb (2015-11-25 13:22)
评价: 3.7%
sqdchina
帖子: 1
注册时间: 2016-04-06 17:09
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#14

帖子 sqdchina » 2016-04-06 17:13

第二步地址头 加个s
http -> https
git clone https://github.com/lwfinger/rtlwifi_new.git
C咖咖
帖子: 3
注册时间: 2016-04-06 17:32
系统: ubuntu14.04
送出感谢: 0
接收感谢: 0

Re: ubuntu14.04 amd64 无线网卡rtl8723be安装与问题资料整理

#15

帖子 C咖咖 » 2016-04-06 17:34

Archer123, sudo echo "options rtl8723be fwlps=0 swlps=0" > /etc/modprobe.d/rtl8723be.conf 大哥,这句提示权限不够。。怎么解决啊,拜托了
回复

回到 “网卡问题以及网络和拨号”