求助18.04.1LTS 安装wine 问题

Bionic Beaver
回复
菜菜很菜
帖子: 3
注册时间: 2018-09-13 14:55
系统: ubuntu18.04
送出感谢: 0
接收感谢: 0

求助18.04.1LTS 安装wine 问题

#1

帖子 菜菜很菜 » 2018-09-13 15:15

系统 18.04.1LTS 安装wine 是按照 https://wiki.winehq.org/Ubuntu_zhcn 上面操作的
执行到 $ sudo apt-get install --install-recommends winehq-stable (稳定分支) 时提示 winehq-stable : 依赖: wine-stable (= 3.0.2~bionic),尝试安装wine-stable 时又提示 wine-stable : 依赖: wine-stable-i386,继续尝试安装 wine-stable-i386 ,提示依赖很多。。。一脸蒙蔽的我百度了很多解决方案发现最后还是会出现这个问题,纯小白,求大神解救。
菜菜很菜
帖子: 3
注册时间: 2018-09-13 14:55
系统: ubuntu18.04
送出感谢: 0
接收感谢: 0

Re: 求助18.04.1LTS 安装wine 问题

#2

帖子 菜菜很菜 » 2018-09-13 16:08

前天装的系统,本来想装双系统结果只有单系统,崩溃ing。。目前只能浏览一下网页别的什么都做不了,这是用ubuntu的第二天
poloshiao
论坛版主
帖子: 18275
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: 求助18.04.1LTS 安装wine 问题

#3

帖子 poloshiao » 2018-09-13 16:36

1. https://wiki.winehq.org/Ubuntu_zhcn
如果您之前安装过来自其他仓库的 Wine 安装包,请在尝试安装 WineHQ 安装包之前删除它及依赖它的所有安装包(如:wine-mono、wine-gecko、winetricks),否则可能导致依赖冲突。

2. 養成習慣 安裝/升級 任何套件以前 先執行
sudo apt-get update
sudo apt-get upgrade
再開始依照
https://wiki.winehq.org/Ubuntu_zhcn
一個步驟一個步驟安裝 不要跳過任何步驟

3. 提醒 如果你不是在 Linux Mint 安裝
要跳過 Linux Mint 17.x / Linux Mint 18.x 這兩段
这些用户感谢了作者 poloshiao 于这个帖子:
aerowolf (2018-09-13 17:39)
评价: 3.7%
头像
百草谷居士
帖子: 3023
注册时间: 2006-02-10 16:36
系统: ubuntu18.04/Win10
送出感谢: 19 次
接收感谢: 32 次
联系:

Re: 求助18.04.1LTS 安装wine 问题

#4

帖子 百草谷居士 » 2018-09-14 13:19

菜菜很菜 写了:
2018-09-13 15:15
系统 18.04.1LTS 安装wine 是按照 https://wiki.winehq.org/Ubuntu_zhcn 上面操作的
执行到 $ sudo apt-get install --install-recommends winehq-stable (稳定分支) 时提示 winehq-stable : 依赖: wine-stable (= 3.0.2~bionic),尝试安装wine-stable 时又提示 wine-stable : 依赖: wine-stable-i386,继续尝试安装 wine-stable-i386 ,提示依赖很多。。。一脸蒙蔽的我百度了很多解决方案发现最后还是会出现这个问题,纯小白,求大神解救。
wine依赖确实很多,因为wine使用的是i386库,也就是32位系统。现在的ubuntu默认都是64位系统,所以需要安装一大堆32位运行库。
就算你安装了一大堆东西,最后,能够成功wine成功的windows软件并不多。

所以,不建议使用wine,尽快熟悉linux下对应的应用程序才是正道。如果确实需要使用windows下的软件,最好使用虚拟机来实现。
友帮拓,真难听。有没有接触官方的老大?给改了吧!
一直想找一个在linux下的Visual FoxPro/access桌面数据库。MUIBase还算是最相近的。
xenomorph0525
帖子: 337
注册时间: 2009-11-21 20:29
送出感谢: 5 次
接收感谢: 9 次

Re: 求助18.04.1LTS 安装wine 问题

#5

帖子 xenomorph0525 » 2018-09-14 13:31

代码: 全选

sudo apt install winetricks
就解決了。
回复

回到 “Ubuntu 18.04 LTS”