vmware怎么样开启3d加速啊!

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
fengzheng081212
帖子: 189
注册时间: 2012-01-08 11:27
送出感谢: 6 次
接收感谢: 0

vmware怎么样开启3d加速啊!

#1

帖子 fengzheng081212 » 2018-12-26 8:02

安装了vmware tools,可是是显卡跑分这么低?
附件
2018-12-26 07-41-20 的屏幕截图.png
头像
astolia
论坛版主
帖子: 3489
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 581 次

Re: vmware怎么样开启3d加速啊!

#2

帖子 astolia » 2018-12-26 10:25

正常。
普通的家用显卡并不是为跑虚拟化系统设计的,所以你虚拟机中的虚拟显卡实际上是由宿主机的CPU模拟的,仅仅是为了提供一些基础的3D功能,性能就别指望了。
要想在虚拟环境中获得高性能,要么去买支持虚拟化的高端服务器显卡,比如nvidia家支持grid技术的tesla系显卡,要么将另外一个显卡通过passthrough的方式交给虚拟机使用
fengzheng081212
帖子: 189
注册时间: 2012-01-08 11:27
送出感谢: 6 次
接收感谢: 0

Re: vmware怎么样开启3d加速啊!

#3

帖子 fengzheng081212 » 2018-12-26 19:16

astolia 写了:
2018-12-26 10:25
正常。
普通的家用显卡并不是为跑虚拟化系统设计的,所以你虚拟机中的虚拟显卡实际上是由宿主机的CPU模拟的,仅仅是为了提供一些基础的3D功能,性能就别指望了。
要想在虚拟环境中获得高性能,要么去买支持虚拟化的高端服务器显卡,比如nvidia家支持grid技术的tesla系显卡,要么将另外一个显卡通过passthrough的方式交给虚拟机使用
双系统,回到win10打开这个虚拟机,重新安装vmtools,重新跑分,完全不一样啊!竟然跑到2万多分,达到实体机显卡性能的百分之五十左右了,难道Linux系统就是真的这么差啊!然后我有重新启动回到Ubuntu,打开虚拟机还是那个虚拟文件,跑分又不行了,感觉就是没有开启3d性能,打开的时候也有提示,3d性能没有开启来!也不知道什么原因,难道是显卡驱动闭源和开源的区别吗?
附件
2018-12-26 19-19-33 的屏幕截图.png
批注 2018-12-26 104350.jpg
头像
astolia
论坛版主
帖子: 3489
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 581 次

Re: vmware怎么样开启3d加速啊!

#4

帖子 astolia » 2018-12-26 21:50

vmware默认会选择性地在某些显卡驱动上禁用3d加速功能,你可以强制启用。方法是编辑~/.vmware/preferences,确保里面要有这么一行

代码: 全选

mks.gl.allowBlacklistedDrivers = "TRUE"
或者你加到你虚拟机配置文件.vmx里也行,但只会对那一个虚拟机生效。

另外如果你用的是N卡,开源驱动对比闭源驱动性能上确实差距挺大的,你可以安装闭源驱动试试。
最后,两个系统的3d接口是不一样的,一个是directx,一个是opengl,所以中间有个翻译过程,又会损失一些性能
fengzheng081212
帖子: 189
注册时间: 2012-01-08 11:27
送出感谢: 6 次
接收感谢: 0

Re: vmware怎么样开启3d加速啊!

#5

帖子 fengzheng081212 » 2018-12-27 13:41

谢谢版主,问题解决了!版主威武! :Haha
头像
bzimage
帖子: 681
注册时间: 2006-03-14 10:25
送出感谢: 1 次
接收感谢: 5 次

Re: vmware怎么样开启3d加速啊!

#6

帖子 bzimage » 2018-12-27 20:03

mark
回复

回到 “虚拟机和虚拟化”