centos自己手动编译的r8168网卡驱动,如何使其开机后自动加载

包含网卡/无线网的网络问题和ADSL/校园网/宽带拨号支持及代理/共享等网络使用问题
回复
s1978256
帖子: 40
注册时间: 2015-08-24 22:17
系统: ubuntu14.04
送出感谢: 15 次
接收感谢: 0

centos自己手动编译的r8168网卡驱动,如何使其开机后自动加载

#1

帖子 s1978256 » 2021-05-31 18:42

自已家用的samba服务器(centos)集成了RTL8111/8168/8411网卡,开机后发现采用系统自带的r8169驱动,有一段时间老掉线。自己上网下载了一份r8168-8.044源码,经过几小时不断的上网排错,终于成功编译安装上了。重开机后发现不自动载入r8168,载入的还是r8169,手动modprobe卸载r8169,重新手动载入r8168,正常使用。重开机后,还是不能自动加载r8168。上网搜寻不能成功,请大家给指点下,最好能给点这方面的资料,谢谢
头像
astolia
论坛版主
帖子: 5208
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 880 次

Re: centos自己手动编译的r8168网卡驱动,如何使其开机后自动加载

#2

帖子 astolia » 2021-06-01 9:53

把r8169加入黑名单不让它自动加载就行。root权限下执行

代码: 全选

echo blacklist r8169 > /etc/modprobe.d/blacklist-r8169.conf
一般而言,这样就可以换去加载r8168驱动了。如果万一没有自动加载,可以通过配置强制加载。如果你是用以systemd为init的centos,root权限下运行

代码: 全选

echo r8168 > /etc/modules-load.d/r8168.conf
这些用户感谢了作者 astolia 于这个帖子:
s1978256 (2021-06-01 11:00)
评价: 3.7%
s1978256
帖子: 40
注册时间: 2015-08-24 22:17
系统: ubuntu14.04
送出感谢: 15 次
接收感谢: 0

Re: centos自己手动编译的r8168网卡驱动,如何使其开机后自动加载

#3

帖子 s1978256 » 2021-06-01 10:59

多谢版主,可是不行呀!系统为centos7,先禁用r8169 再强制加载r8168,还是不行。我发现系统自带的r8169.ko是xz压缩的,把r8168.ko也进行了xz压缩(/usr/lib/modules/3.10.0-1160.25.1.el7.x86_64/kernel/drivers/net/ethernet/realtek/r8168.ko.xz)。开机重启还是不行,难道要把系统自带的r8169.ko删除?
头像
astolia
论坛版主
帖子: 5208
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 880 次

Re: centos自己手动编译的r8168网卡驱动,如何使其开机后自动加载

#4

帖子 astolia » 2021-06-01 11:29

如果你正确地执行了上面把r8169加入黑名单的操作,重启后lsmod输出里还有r8169,那你看一下输出中是不是有其他的模块依赖了r8169。如果是的话,还需要加上一行

代码: 全选

echo install r8169 /bin/false >> /etc/modprobe.d/blacklist-r8169.conf
直接把r8169模块删掉也是一个办法,但只针对当前内核,升级后还会回来,不算一劳永逸
funicorn
帖子: 1254
注册时间: 2005-09-13 4:56
系统: Ubuntu QQ
送出感谢: 0
接收感谢: 61 次

Re: centos自己手动编译的r8168网卡驱动,如何使其开机后自动加载

#5

帖子 funicorn » 2021-06-02 9:52

/etc/modprobe.d/r8168-dkms.conf

# settings for r8168-dkms

# map the specific PCI IDs instead of blacklisting the whole r8169 module
alias pci:v00001186d00004300sv00001186sd00004B10bc*sc*i* r8168
alias pci:v000010ECd00008168sv*sd*bc*sc*i* r8168

# if the aliases above do not work, uncomment the following line
# to blacklist the whole r8169 module
#blacklist r8169
回复

回到 “网络相关问题”