nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

新手涉及到的教学或入门贴,推荐新手必看,版主维护
回复
gs-linux
帖子: 134
注册时间: 2008-06-07 20:40
送出感谢: 2 次
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#16

帖子 gs-linux » 2010-04-22 18:30

晕 我刚刚发现我的10.04beta2中没有

代码: 全选

linux-restricted-modules-common
这个文件!!!
头像
robin2103
帖子: 27
注册时间: 2008-11-13 11:27
送出感谢: 0
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#17

帖子 robin2103 » 2010-04-23 9:03

gs-linux 写了:晕 我刚刚发现我的10.04beta2中没有

代码: 全选

linux-restricted-modules-common
这个文件!!!
同学,我Ubuntu9.10中也没有这个文件。
我觉得配置文件名称的更改对使用者还是很不好的。我倒是怀念起Ubuntu 8.04 LTS了。
Linux的个性化又让我不想轻易换回8.04,一换又得重新捣鼓了
头像
robin2103
帖子: 27
注册时间: 2008-11-13 11:27
送出感谢: 0
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#18

帖子 robin2103 » 2010-04-23 9:09

syrano 写了:
robin2103 写了:
syrano 写了:
水波纹是什么?
楼主,就是显示器闪动,像风吹过水面一样的
说得形象点,平时拿摄相机拍显示屏的时候不是会超闪吗?
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#19

帖子 syrano » 2010-04-23 9:16

robin2103 写了:
syrano 写了:
robin2103 写了:
syrano 写了:
水波纹是什么?
楼主,就是显示器闪动,像风吹过水面一样的
说得形象点,平时拿摄相机拍显示屏的时候不是会超闪吗?
你是CRT还是液晶.
是不是刷新率不够?
E=m c^2
头像
robin2103
帖子: 27
注册时间: 2008-11-13 11:27
送出感谢: 0
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#20

帖子 robin2103 » 2010-04-23 9:54

syrano 写了:
你是CRT还是液晶.
是不是刷新率不够?
我的是液晶,MAYA NFS-7S,理论分辨率是可以达到1280x1024
但我在Ubuntu下只能设置到1024x768_75
以下是我xorg.conf文件的内容,帖出来,帮帮瞧瞧

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Fri Mar 12 01:42:27 PST 2010

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1024x768"
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200 TurboCache(TM)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1024x768_85 +0+0; 1024x768 +0+0"
Option "NoLogo" "False"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "640x400"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#21

帖子 syrano » 2010-04-23 10:57

robin2103 写了:
syrano 写了:
你是CRT还是液晶.
是不是刷新率不够?
我的是液晶,MAYA NFS-7S,理论分辨率是可以达到1280x1024
但我在Ubuntu下只能设置到1024x768_75
以下是我xorg.conf文件的内容,帖出来,帮帮瞧瞧

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Fri Mar 12 01:42:27 PST 2010

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1024x768"
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200 TurboCache(TM)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1024x768_85 +0+0; 1024x768 +0+0"
Option "NoLogo" "False"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "640x400"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
建议改成1280x1024, 因为液晶和CRT不一样. 液晶的点阵是固定的, 如果改了分辨率, 显示就会变得模糊.
E=m c^2
头像
robin2103
帖子: 27
注册时间: 2008-11-13 11:27
送出感谢: 0
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#22

帖子 robin2103 » 2010-04-23 12:58

改成了1280x1024,仍然不够理想。
可能是我这个老旧的显示器的问题吧。
我显示器参数如下:
MAYA NFS-7S ,17寸、水平扫描频率:30-80KHz:垂直扫描频率:55-75Hz/带宽:135MHz ,分辨率 1280x1024
之前网上有看到说,Linux 对某些品牌,某些型号显示器支持不太好,
不会偶就是其中的一员吧? :em06
这是偶上班用的电脑,要不我就换显示器了。
gs-linux
帖子: 134
注册时间: 2008-06-07 20:40
送出感谢: 2 次
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#23

帖子 gs-linux » 2010-04-23 13:09

robin2103 写了:
gs-linux 写了:晕 我刚刚发现我的10.04beta2中没有

代码: 全选

linux-restricted-modules-common
这个文件!!!
同学,我Ubuntu9.10中也没有这个文件。
我觉得配置文件名称的更改对使用者还是很不好的。我倒是怀念起Ubuntu 8.04 LTS了。
Linux的个性化又让我不想轻易换回8.04,一换又得重新捣鼓了
可是我的9.10是有这个文件的呀?
头像
robin2103
帖子: 27
注册时间: 2008-11-13 11:27
送出感谢: 0
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#24

帖子 robin2103 » 2010-04-23 13:34

楼上同学
我的还真没有
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#25

帖子 syrano » 2010-04-23 13:35

robin2103 写了:改成了1280x1024,仍然不够理想。
可能是我这个老旧的显示器的问题吧。
我显示器参数如下:
MAYA NFS-7S ,17寸、水平扫描频率:30-80KHz:垂直扫描频率:55-75Hz/带宽:135MHz ,分辨率 1280x1024
之前网上有看到说,Linux 对某些品牌,某些型号显示器支持不太好,
不会偶就是其中的一员吧? :em06
这是偶上班用的电脑,要不我就换显示器了。
可能你需要把刷新率改称80Hz.
记得以前有个同学就是液晶刷新率小了, 有水波纹.
E=m c^2
头像
adsl
帖子: 61
注册时间: 2010-04-05 16:43
来自: 山东临沂
送出感谢: 0
接收感谢: 0
联系:

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#26

帖子 adsl » 2010-04-23 17:01

今天刚出了这个事,升级完了,没有标题栏了,正好用上,谢谢楼主…… :em11 :em11 :em11
http://shop100148913.taobao.com/ 欢迎光临偶滴小店
头像
robin2103
帖子: 27
注册时间: 2008-11-13 11:27
送出感谢: 0
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#27

帖子 robin2103 » 2010-04-24 9:13

syrano 写了: 可能你需要把刷新率改称80Hz.
记得以前有个同学就是液晶刷新率小了, 有水波纹.
改80HZ后,闪得更厉害了。
并且一开机的时候提示“输入超出范围”,并且,现在每次开机,显示屏分辨率和刷新率都为“auto",每次都要自己去更改。 :em06

附上配置文件:
“# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Fri Mar 12 01:42:27 PST 2010

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
HorizSync 30.0 - 85.0
VertRefresh 55.0 - 80.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200 TurboCache(TM)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1280x1024_80 +0+0; 1280x1024 +0+0"
Option "NoLogo" "False"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "640x480" "640x400"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection”
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#28

帖子 syrano » 2010-04-24 9:22

robin2103 写了:
syrano 写了: 可能你需要把刷新率改称80Hz.
记得以前有个同学就是液晶刷新率小了, 有水波纹.
改80HZ后,闪得更厉害了。
并且一开机的时候提示“输入超出范围”,并且,现在每次开机,显示屏分辨率和刷新率都为“auto",每次都要自己去更改。 :em06

附上配置文件:
“# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Fri Mar 12 01:42:27 PST 2010

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
HorizSync 30.0 - 85.0
VertRefresh 55.0 - 80.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200 TurboCache(TM)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1280x1024_80 +0+0; 1280x1024 +0+0"
Option "NoLogo" "False"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "640x480" "640x400"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection”
其他版本的ubuntu有这个问题吗?

另外可以改成开源驱动试一下.
E=m c^2
头像
robin2103
帖子: 27
注册时间: 2008-11-13 11:27
送出感谢: 0
接收感谢: 0

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#29

帖子 robin2103 » 2010-04-24 10:29

syrano 写了: 其他版本的ubuntu有这个问题吗?

另外可以改成开源驱动试一下.
改开源驱动后,再次直接进入tty1
错误提示为,“nouveau"载入失败
好像开源驱动在自己装Nvidia的驱动时已经删除了吧?
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

Re: nvidia驱动从安装到配置(解决刷新率, 无标题栏和使用开源驱动等问题)

#30

帖子 syrano » 2010-04-24 10:44

robin2103 写了:
syrano 写了: 其他版本的ubuntu有这个问题吗?

另外可以改成开源驱动试一下.
改开源驱动后,再次直接进入tty1
错误提示为,“nouveau"载入失败
好像开源驱动在自己装Nvidia的驱动时已经删除了吧?

要重新安装nouveau
应该nouveau 依赖的libgl和nvidia驱动冲突
E=m c^2
回复

回到 “教学和常见问答”