求助!现在ubuntu装不了.deb软件了!

其它类软件,非上述版软件
回复
dhl
帖子: 7
注册时间: 2012-09-18 21:53
系统: ubuntu 12.04
送出感谢: 0
接收感谢: 0

求助!现在ubuntu装不了.deb软件了!

#1

帖子 dhl » 2012-09-22 21:00

大家好:
现在我的ubuntu12.04出了个大毛病:无论是双击.deb文件,用软件中心打开;还是在命令行里用apt-get install来安装软件都失败了。貌似是tar出了问题,下面附上错误信息,请大家多多帮忙哈!


命令行失败信息如下:
tar:无法识别的选项“--warning=no-timestamp”
请用“tar --help”或“tar --usage”获得更多信息。
dpkg-deb: error: 子进程 tar 返回了错误号 64
dpkg:处理 /var/cache/apt/archives/vim-common_2%3a7.3.429-2ubuntu2_i386.deb (--unpack)时出错:
子进程 dpkg-deb --control 返回了错误号 2
tar:无法识别的选项“--warning=no-timestamp”
请用“tar --help”或“tar --usage”获得更多信息。
dpkg-deb: error: 子进程 tar 返回了错误号 64
dpkg:处理 /var/cache/apt/archives/vim-runtime_2%3a7.3.429-2ubuntu2_all.deb (--unpack)时出错:
子进程 dpkg-deb --control 返回了错误号 2
tar:无法识别的选项“--warning=no-timestamp”
请用“tar --help”或“tar --usage”获得更多信息。
dpkg-deb: error: 子进程 tar 返回了错误号 64
dpkg:处理 /var/cache/apt/archives/vim_2%3a7.3.429-2ubuntu2_i386.deb (--unpack)时出错:
子进程 dpkg-deb --control 返回了错误号 2
在处理时有错误发生:
/var/cache/apt/archives/vim-common_2%3a7.3.429-2ubuntu2_i386.deb
/var/cache/apt/archives/vim-runtime_2%3a7.3.429-2ubuntu2_all.deb
/var/cache/apt/archives/vim_2%3a7.3.429-2ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


ubuntu软件中心失败信息如下:
tar--warning=no-timestamp
tar --helptar --usage
dpkg-deb (subprocess): data: internal gzip write error: Broken pipe
dpkg-deb: error: subprocess tar returned error exit status 64
dpkg: error processing /var/cache/apt/archives/vim-runtime_2%3a7.3.429-2ubuntu2_all.deb (--install):
subprocess dpkg-deb --control returned error exit status 2
Dohw0Doh
帖子: 80
注册时间: 2012-08-23 19:37
送出感谢: 0
接收感谢: 3 次

Re: 求助!现在ubuntu装不了.deb软件了!

#2

帖子 Dohw0Doh » 2012-09-22 21:32

先把那几个缓存的DEB清除了再试试:

代码: 全选

$ sudo rm /var/cache/apt/archieves/vim*
dhl
帖子: 7
注册时间: 2012-09-18 21:53
系统: ubuntu 12.04
送出感谢: 0
接收感谢: 0

Re: 求助!现在ubuntu装不了.deb软件了!

#3

帖子 dhl » 2012-09-23 11:45

谢谢你的回答。我试了一下你说的方法,很遗憾还是不行。现在关键是不仅命令行下的apt-get安装不了程序,就连ubuntu软件中心也不行的。我把错误信息在google上查了一下,貌似是tar包的一个bug,似乎已经解决了,不过我没看懂他们写的:bug修改网站太随意了。
kai1248
帖子: 1
注册时间: 2012-09-22 14:54
系统: ubuntu12.04
送出感谢: 0
接收感谢: 0

Re: 求助!现在ubuntu装不了.deb软件了!

#4

帖子 kai1248 » 2012-09-23 23:59

sudo apt-get install gdebi #安装 Gdebi
Dill
帖子: 24
注册时间: 2007-10-04 9:25
送出感谢: 0
接收感谢: 0
联系:

Re: 求助!现在ubuntu装不了.deb软件了!

#5

帖子 Dill » 2012-11-21 17:26

楼上正解。。
yang_young
帖子: 1
注册时间: 2019-04-15 11:18
系统: 18.04.2LTS
送出感谢: 0
接收感谢: 0

Re: 求助!现在ubuntu装不了.deb软件了!

#6

帖子 yang_young » 2019-04-15 11:19

我也遇到了,请问这个问题你解决了吗?
熊猫帮帮主
帖子: 4
注册时间: 2019-04-30 8:14
系统: Ubnutu
送出感谢: 0
接收感谢: 0

Re: 求助!现在ubuntu装不了.deb软件了!

#7

帖子 熊猫帮帮主 » 2019-05-07 6:57

yang_young 写了:
2019-04-15 11:19
我也遇到了,请问这个问题你解决了吗?
原帖太久远了,把错误信息贴出来吧
回复

回到 “其它类软件”