Ubuntu14.04 apt-get安装NFS客户端报 libgssapi-krb5-2 依赖问题

其它类软件,非上述版软件
回复
wantdrink
帖子: 1
注册时间: 2014-11-27 9:44
系统: win7
送出感谢: 0
接收感谢: 0

Ubuntu14.04 apt-get安装NFS客户端报 libgssapi-krb5-2 依赖问题

#1

帖子 wantdrink » 2014-11-27 10:33

大家好,

系统是14.04 trusty, 在试着用apt-get装nfs客户端的时候,碰到libgssapi-krb5-2依赖问题,不知道大家有没有遇到过:

代码: 全选

[email protected]:~# apt-get install nfs-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libgssapi-krb5-2 : Depends: libkrb5-3 (= 1.12.1+dfsg-15) but 1.12+dfsg-2ubuntu4 is to be installed
 nfs-common : Depends: libgssglue1 but it is not going to be installed
              Depends: libnfsidmap2 but it is not going to be installed
              Depends: libtirpc1 but it is not going to be installed
              Depends: rpcbind (>= 0.2.0-6ubuntu1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
于是做完apt-get update后apt-get upgrade,发现还是这个包

代码: 全选

[email protected]:~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libgssapi-krb5-2 : Depends: libkrb5-3 (= 1.12.1+dfsg-15) but 1.12+dfsg-2ubuntu4 is installed
E: Unmet dependencies. Try using -f.
没辙试着强制安装libkrb5-3, 问题依旧:

代码: 全选

[email protected]:~# apt-get install -f libkrb5-3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libgssapi-krb5-2 : Depends: libkrb5-3 (= 1.12.1+dfsg-15) but 1.12+dfsg-2ubuntu4.2 is to be installed
 libkrb5-3 : Depends: libkrb5support0 (= 1.12+dfsg-2ubuntu4.2) but 1.12+dfsg-2ubuntu4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
查看/etc/apt/sources.list,源没有改动过,都是类似于:

代码: 全选

deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
请问这种情况手动下载libkrb5-3 (1.12.1+dfsg-15)的deb包安装可以吗?找了一下只看到source,没有deb可以下载。
多谢各位。
回复

回到 “其它类软件”