分页: 8 / 9

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-05-24 16:10
lilydjwg
supercatexpert 写了:
lilydjwg 写了:
supercatexpert 写了:RhythmCat2 新版本已发布,版本1.9.3,欢迎大家测试使用。
喵呜~
PIA一个先。百合子又出来卖萌了。
人家每次看到你那头像都忍不住了嘛,喵呜 :-(

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-05-24 16:57
supercatexpert
peteryeh64 写了::em11 ...感謝分享...辛苦了...

測試環境ubuntu12.04 LTS amd64...

代码: 全选

[email protected]:~/Documents/rhythmcat2_amd64$ sudo dpkg -i *
[sudo] password for peteryeh64: 
Selecting previously unselected package librhythmcat2.
(正在讀取資料庫 ... 203682 files and directories currently installed.)
正在解開 librhythmcat2 (從 librhythmcat2_1.9.3-1_amd64.deb)...
Selecting previously unselected package rhythmcat2.
正在解開 rhythmcat2 (從 rhythmcat2_1.9.3-1_amd64.deb)...
Selecting previously unselected package rhythmcat2-plugins-base.
正在解開 rhythmcat2-plugins-base (從 rhythmcat2-plugins-base_1.9.3-1_amd64.deb)...
Selecting previously unselected package rhythmcat2-plugins-extra.
正在解開 rhythmcat2-plugins-extra (從 rhythmcat2-plugins-extra_1.9.3-1_amd64.deb)...
正在設定 librhythmcat2 (1.9.3-1) ...
dpkg:因相依問題,不能設定 rhythmcat2:
 rhythmcat2 相依於 libffi5 (>= 3.0.4)﹔然而:
  未曾安裝套件 `libffi5'。
dpkg:在處理 rhythmcat2 (--install) 時發生錯誤:
 相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 rhythmcat2-plugins-base:
 rhythmcat2-plugins-base 相依於 libffi5 (>= 3.0.4)﹔然而:
  未曾安裝套件 `libffi5'。
 rhythmcat2-plugins-base 相依於 rhythmcat2 (>= 1.9.3)﹔然而:
  rhythmcat2 套件尚未設定。
dpkg:在處理 rhythmcat2-plugins-base (--install) 時發生錯誤:
 相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 rhythmcat2-plugins-extra:
 rhythmcat2-plugins-extra 相依於 libffi5 (>= 3.0.4)﹔然而:
  未曾安裝套件 `libffi5'。
 rhythmcat2-plugins-extra 相依於 rhythmcat2 (>= 1.9.3)﹔然而:
  rhythmcat2 套件尚未設定。
dpkg:在處理 rhythmcat2-plugins-extra (--install) 時發生錯誤:
 相依問題 - 保留為未設定
正在進行 desktop-file-utils 的觸發程式 ...
正在進行 bamfdaemon 的觸發程式 ...
Rebuilding /usr/share/applications/bamf.index...
正在進行 gnome-menus 的觸發程式 ...
正在進行 man-db 的觸發程式 ...
正在進行 libc-bin 的觸發程式 ...
ldconfig deferred processing now taking place
在處理時有錯誤發生:
 rhythmcat2
 rhythmcat2-plugins-base
 rhythmcat2-plugins-extra
[email protected]:~/Documents/rhythmcat2_amd64$ sudo apt-get install libffi5
正在讀取套件清單... 完成
正在重建相依關係          
正在讀取狀態資料... 完成
無法取得套件 libffi5,但它卻被其它的套件引用了。
這意味著這個套件可能已經消失了、被廢棄了,或是只能由其他的來源取得

E: 「libffi5」套件無可安裝版本
[email protected]:~/Documents/rhythmcat2_amd64$ sudo apt-get install -f
正在讀取套件清單... 完成
正在重建相依關係          
正在讀取狀態資料... 完成
正在修正相依關係... 完成
以下套件為自動安裝,並且已經無用:
  language-pack-kde-zh-hans-base language-pack-kde-en kde-l10n-engb language-pack-kde-zh-hant-base kde-l10n-zhcn
  language-pack-kde-zh-hans language-pack-kde-zh-hant kde-l10n-zhtw language-pack-kde-en-base
使用 'apt-get autoremove' 來將其移除。
下列套件將會被【移除】:
  rhythmcat2 rhythmcat2-plugins-base rhythmcat2-plugins-extra
升級 0 個,新安裝 0 個,移除 3 個,有 0 個未被升級。
3 個沒有完整得安裝或移除。
此操作完成之後,會空出 6,989 kB 的磁碟空間。
是否繼續進行 [Y/n]?y
(正在讀取資料庫 ... 203739 files and directories currently installed.)
正在移除 rhythmcat2-plugins-base ...
正在移除 rhythmcat2-plugins-extra ...
正在移除 rhythmcat2 ...
正在進行 libc-bin 的觸發程式 ...
ldconfig deferred processing now taking place
正在進行 man-db 的觸發程式 ...
正在進行 desktop-file-utils 的觸發程式 ...
正在進行 bamfdaemon 的觸發程式 ...
Rebuilding /usr/share/applications/bamf.index...
正在進行 gnome-menus 的觸發程式 ...
[email protected]:~/Documents/rhythmcat2_amd64$ 
因依賴關係未能裝上...

代码: 全选

[email protected]:~/Documents/rhythmcat2_amd64$ sudo apt-get install libffi6
正在讀取套件清單... 完成
正在重建相依關係          
正在讀取狀態資料... 完成
libffi6 已經是最新版本了。
以下套件為自動安裝,並且已經無用:
  language-pack-kde-zh-hans-base language-pack-kde-en kde-l10n-engb language-pack-kde-zh-hant-base kde-l10n-zhcn
  language-pack-kde-zh-hans language-pack-kde-zh-hant kde-l10n-zhtw language-pack-kde-en-base
使用 'apt-get autoremove' 來將其移除。
升級 0 個,新安裝 0 個,移除 0 個,有 0 個未被升級。
[email protected]:~/Documents/rhythmcat2_amd64$ sudo apt-get install libffi5
正在讀取套件清單... 完成
正在重建相依關係          
正在讀取狀態資料... 完成
無法取得套件 libffi5,但它卻被其它的套件引用了。
這意味著這個套件可能已經消失了、被廢棄了,或是只能由其他的來源取得

E: 「libffi5」套件無可安裝版本
[email protected]:~/Documents/rhythmcat2_amd64$ ^C
通过检查,发现是因为Debian和Ubuntu的libffi命名差异导致的错误。需要重新给Ubuntu 12.04打包才可以。

临时解决办法:
下载老版本的libffi5安装包:

32位版: http://mirrors.163.com/ubuntu//pool/mai ... 1_i386.deb
64位版: http://mirrors.163.com/ubuntu//pool/mai ... _amd64.deb

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-05-24 17:44
peteryeh64
:em11 ...感謝LZ...成功了...

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-05-25 18:53
凉拌茶叶
话说播放某些文件时挂掉怎么解决??我如何向您返回错误信息?

好软件,支持! :em11

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-05-25 19:15
lilydjwg
凉拌茶叶 写了:话说播放某些文件时挂掉怎么解决??我如何向您返回错误信息?

好软件,支持! :em11
来群里找老猫啦 [email protected]

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-05-25 20:56
supercatexpert
凉拌茶叶 写了:话说播放某些文件时挂掉怎么解决??我如何向您返回错误信息?

好软件,支持! :em11
………………百合子说的那个是一个办法,还有一个办法是在Github的Issue页面上去反馈(记得带上终端信息哦)。或是在俺的Blog上去留言也可。

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-05-26 22:12
fuhaoyun
这个播放器很棒,我天天用。新版的马上下载来试试

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-06-08 21:47
a14331990
请问桌面歌词能用不?在我这里用不了fedora 17 x86_64
好像没RhythmCat稳定呀。
谢谢!

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-06-12 22:49
supercatexpert
桌面歌词需要窗口管理器开启了混合特效才可使用,稳定性问题因放出的为测试版本,需要得到大家的测试结果以进行修正。

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-06-13 10:21
a14331990
supercatexpert 写了:桌面歌词需要窗口管理器开启了混合特效才可使用,稳定性问题因放出的为测试版本,需要得到大家的测试结果以进行修正。
请问“混合特效”是什么,fedora 17已经不支持compiz了。谢谢!

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-06-20 20:26
supercatexpert
a14331990 写了:
supercatexpert 写了:桌面歌词需要窗口管理器开启了混合特效才可使用,稳定性问题因放出的为测试版本,需要得到大家的测试结果以进行修正。
请问“混合特效”是什么,fedora 17已经不支持compiz了。谢谢!
混合特效并非Compiz才有的,包括GNOME-Shell和KWM、Xfce4的WM在内的很多WM都支持该特效。该特效允许窗口设置为透明。

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-06-20 21:06
a14331990
supercatexpert 写了:
a14331990 写了:
supercatexpert 写了:桌面歌词需要窗口管理器开启了混合特效才可使用,稳定性问题因放出的为测试版本,需要得到大家的测试结果以进行修正。
请问“混合特效”是什么,fedora 17已经不支持compiz了。谢谢!
混合特效并非Compiz才有的,包括GNOME-Shell和KWM、Xfce4的WM在内的很多WM都支持该特效。该特效允许窗口设置为透明。
我设置了
gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true
还是没作用,请详细指点下,谢谢!

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-06-21 18:14
supercatexpert
a14331990 写了:
supercatexpert 写了:
a14331990 写了:
supercatexpert 写了:桌面歌词需要窗口管理器开启了混合特效才可使用,稳定性问题因放出的为测试版本,需要得到大家的测试结果以进行修正。
请问“混合特效”是什么,fedora 17已经不支持compiz了。谢谢!
混合特效并非Compiz才有的,包括GNOME-Shell和KWM、Xfce4的WM在内的很多WM都支持该特效。该特效允许窗口设置为透明。
我设置了
gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true
还是没作用,请详细指点下,谢谢!
Fedora 17的话,如果乃能开启GNOME-Shell(即非Fallback模式),那么混合特效一定是支持的。可以的话请在终端中运行本程序,然后将终端记录发上来。

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-06-21 20:02
a14331990
命令行运行报错
(RhythmCat2:8170): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the data stream to the loader before dropping the last reference.
能看到桌面歌词的透明长方形和显示歌词的长方形 每个长方形有两个大写字母Y 不显示歌词 我用lyric-crawler插件下了歌词到.RhythmCat2/Lyrics的

Re: RhythmCat2 音乐播放器 1.9.3-1-----(2012.05.24更新)

发表于 : 2012-06-22 13:24
supercatexpert
估计是歌词编码设置错误了吧。在配置界面里面去掉自动识别编码,并且把歌词编码设定为GB18030,ID3编码为GB18030:UTF-8试试看。