安装ubuntu 16.04后,禁用Secure Boot 后反而无法正常启动,望大神解惑

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
ThSquirrel
帖子: 7
注册时间: 2018-03-22 16:20
系统: ubuntu Kylin 16.04
送出感谢: 1 次
接收感谢: 0

安装ubuntu 16.04后,禁用Secure Boot 后反而无法正常启动,望大神解惑

#1

帖子 ThSquirrel » 2018-03-22 16:38

本人电脑是 ThinkPad x1 carbon 6th,无线网卡是Intel 的AC 8265.
电脑预装Win10系统。昨天通过U盘引导安装了Ubuntu Kylin 16.04.
关于安装时的分区是分出了一个200M的/boot,一个70G的/ 和一个8G的swap。
在安装的时候没有注意到secure boot,但是U盘引导后仍然正常安装并且能够启动ubuntu。
启动之后因为wifi搜索不到任何信号,所以查阅了许多资料,其中有一条就提到可能需要关闭secure boot,因此将改设置置为disable,结果fa[发现我选择ubuntu引导之后,选择了Ubuntu启动之后一直停在选择界面,
之后我尝试在关闭secure boot的情况下用U盘引导再次安装Ubuntu,却发现选择install之后也无法进入到安装程序。
再次打开secure后,系统和安装程序均恢复正常。
查了许多资料的情况都和我目前的情况相反,不知道有没有大神知道这是怎么回事?
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1960 次

Re: 安装ubuntu 16.04后,禁用Secure Boot 后反而无法正常启动,望大神解惑

#2

帖子 poloshiao » 2018-03-22 18:37

https://ubuntuforums.org/showthread.php ... st12404098
in addition to switching Secure Boot in the BIOS to 'Disabled', in the Restart/Load Setup Defaults menu, the item 'OS Optimise Defaults' needs to be set to 'Disabled' too.

補充
Secure Boot 每個廠牌的 firmware 存在差異
最好向原廠技術客服咨詢
ThSquirrel
帖子: 7
注册时间: 2018-03-22 16:20
系统: ubuntu Kylin 16.04
送出感谢: 1 次
接收感谢: 0

Re: 安装ubuntu 16.04后,禁用Secure Boot 后反而无法正常启动,望大神解惑

#3

帖子 ThSquirrel » 2018-03-22 21:52

poloshiao 写了:https://ubuntuforums.org/showthread.php ... st12404098
in addition to switching Secure Boot in the BIOS to 'Disabled', in the Restart/Load Setup Defaults menu, the item 'OS Optimise Defaults' needs to be set to 'Disabled' too.

補充
Secure Boot 每個廠牌的 firmware 存在差異
最好向原廠技術客服咨詢

谢谢提醒,我尝试了你提供的方法,还是没能够解决问题,
ThSquirrel
帖子: 7
注册时间: 2018-03-22 16:20
系统: ubuntu Kylin 16.04
送出感谢: 1 次
接收感谢: 0

Re: 安装ubuntu 16.04后,禁用Secure Boot 后反而无法正常启动,望大神解惑

#4

帖子 ThSquirrel » 2018-03-23 0:59

因为没有找到原因,所以我尝试重新安装了系统,我注意到在安装过程中,我勾选了自动更新应用,在这一菜单的最后一个选项是让我设置密码,通过这段密码以便于协助我关闭Secure boot,之后在我安装好ubuntu后点击重启,进入到了一个蓝色的页面(MOX management),其中有一个选项“change boot state”,选中后该程序让我验证了刚才设置的密码后帮我disable了Secure boot,我猜测这就是为什么我在bios中使能Secure后仍然能够进入ubuntu的原因。但是很遗憾,我仍然没能解决我搜索不到wifi以及没有声音的问题。 :Hehe :Hehe :Hehe
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1960 次

Re: 安装ubuntu 16.04后,禁用Secure Boot 后反而无法正常启动,望大神解惑

#5

帖子 poloshiao » 2018-03-23 11:02

我注意到在安装过程中,我勾选了自动更新应用
建議 新手 安裝 Ubuntu
1. 暫時不要勾選 一面安裝一面下載更新
2. 看看 能否直接進 UEFI BIOS 把 Secure Boot 直接勾選 Disabled 再開始安裝
這樣 碰到的問題 可能比較少
2-1. 等你使用 UEFI 有經驗了 再來嘗試 Secure Boot 設定為 enabled 的情況

3. 進一步參閱
3-1. https://help.ubuntu.com/community/UEFI
3-2. https://askubuntu.com/questions/221835/ ... -with-uefi
这些用户感谢了作者 poloshiao 于这个帖子:
ThSquirrel (2018-03-24 1:48)
评价: 3.7%
ThSquirrel
帖子: 7
注册时间: 2018-03-22 16:20
系统: ubuntu Kylin 16.04
送出感谢: 1 次
接收感谢: 0

Re: 安装ubuntu 16.04后,禁用Secure Boot 后反而无法正常启动,望大神解惑

#6

帖子 ThSquirrel » 2018-03-23 22:27

poloshiao 写了:
我注意到在安装过程中,我勾选了自动更新应用
建議 新手 安裝 Ubuntu
1. 暫時不要句選 一面安裝一面下載更新
2. 看看 能否直接進 UEFI BIOS 把 Secure Boot 直接勾選 Disabled 再開始安裝
這樣 碰到的問題 可能比較少
2-1. 等你使用 UEFI 有經驗了 再來嘗試 Secure Boot 設定為 enabled 的情況

3. 進一步參閱
3-1. https://help.ubuntu.com/community/UEFI
3-2. https://askubuntu.com/questions/221835/ ... -with-uefi

非常感谢,现在已经解决了,同时该更换了17.10,新版本的内核也自带了相应的驱动和固件。
yingdeshidai
帖子: 1
注册时间: 2022-05-13 21:17
系统: ubuntu18.04
送出感谢: 0
接收感谢: 0

Re: 安装ubuntu 16.04后,禁用Secure Boot 后反而无法正常启动,望大神解惑

#7

帖子 yingdeshidai » 2022-05-13 21:20

我装的ubuntu18.04,我把secure boot关了后,ubuntu无法启动了。请问你是怎么解决禁用后无法启动的,谢谢。被这个卡住很多天了,谢谢您
回复