Arch如何清理无用包?

jtshs256
论坛版主
帖子: 22322
注册时间: 2010-07-19 21:41
系统: OS X
送出感谢: 2 次
接收感谢: 27 次

Re: Arch如何清理无用包?

#16

帖子 jtshs256 » 2011-04-20 18:46

tenzu 写了:一群强迫症 :em05
NO DO NO DIE
http://a/%%30%30
头像
thomasxie
帖子: 317
注册时间: 2009-11-22 15:29
送出感谢: 1 次
接收感谢: 0
联系:

Re: Arch如何清理无用包?

#17

帖子 thomasxie » 2013-11-03 9:21

:em06

yaourt -Qdt
extra/apache-ant 1.9.2-3
extra/audiofile 0.3.6-2
extra/autoconf2.13 2.13-2
extra/boo 0.9.4.9-3
extra/clang 3.3-1
extra/cmake 2.8.12-1
extra/dbus-sharp-glib 0.5.0-4
extra/fastjar 0.98-2
extra/fontforge 20120731_b-6
extra/gconf-sharp 2.24.2-3
extra/gdata-sharp 1.7.0.1-2
extra/gkeyfile-sharp 0.1-2
extra/gnome-common 3.10.0-1
local/gnustep-make-clang-svn 37269-1 (gnustep-clang-svn)
extra/gperf 3.0.4-4
extra/gst-plugins-base 1.2.0-1
extra/gst-plugins-good 1.2.0-1
extra/gudev-sharp 0.1-2
local/hal 0.5.14-17
extra/imake 1.0.6-1
extra/json-glib 0.16.2-1
extra/lesstif 0.95.2-6
multilib/lib32-alsa-plugins 1.0.27-1
multilib/lib32-lcms 1.19-4
extra/libgpod 0.8.2-7
extra/libquvi 0.9.3-1
extra/mercurial 2.7.2-1
extra/mono-upnp 0.1.2-1
extra/mono-zeroconf 0.9.0-3
extra/nasm 2.10.09-1
community/perl-xml-libxml 2.0106-1
community/polkit-gnome 0.105-2
extra/python-gobject 3.10.1-1
extra/python-pyopenssl 0.13.1-1
community/python2-distutils-extra 2.37-1
extra/python2-gnomekeyring 2.32.0-14
extra/python2-gobject 3.10.1-1
community/python2-greenlet 0.4.1-1
extra/python2-notify 0.1.1-12
community/python2-pexpect 2.4-2
extra/python2-pycurl 7.19.0.2-1
extra/pywebkitgtk 1.1.8-3
extra/qt5-graphicaleffects 5.1.1-5 (qt qt5)
extra/qt5-imageformats 5.1.1-5 (qt qt5)
extra/qt5-multimedia 5.1.1-5 (qt qt5)
extra/qt5-quick1 5.1.1-5 (qt qt5)
extra/qt5-quickcontrols 5.1.1-5 (qt qt5)
extra/qt5-serialport 5.1.1-5 (qt qt5)
extra/qt5-svg 5.1.1-5 (qt qt5)
extra/qt5-tools 5.1.1-5 (qt qt5)
extra/qt5-x11extras 5.1.1-5 (qt qt5)
extra/rpmextract 1.0-5
extra/subversion 1.8.3-1
extra/totem-plparser 3.10.0-2
extra/vala 0.22.0-1
extra/xmlto 0.0.25-2
extra/yasm 1.2.0-3
==> Do you want to remove these packages (with -Rcs options) ? [y/N]
==> ---------------------------------------------------------------
==>
正在检查依赖关系...
:: audacious-plugins可选依赖wavpack: WavPack input
:: avahi可选依赖mono: mono bindings
:: cronie可选依赖pm-utils: defer anacron on battery power
:: exitmenu可选依赖pm-utils: to sleep or hibernate
:: gimp可选依赖webkitgtk2: for the help browser
:: git可选依赖subversion: git svn
:: graphviz可选依赖mono: sharp bindings
:: gsmartcontrol可选依赖polkit-gnome: to run gsmartcontrol directly from menu
:: libpulse可选依赖alsa-plugins: ALSA support
:: libreoffice-common可选依赖unixodbc: adds ODBC database support
:: moc可选依赖wavpack: for using the wavpack plugin
:: qt3可选依赖unixodbc: ODBC driver
:: qt4可选依赖unixodbc: ODBC driver
:: qt5-base可选依赖unixodbc: ODBC driver
:: swt可选依赖webkitgtk2
:: thunar可选依赖polkit-gnome: for mounting internal partitions (needs root password)
:: vlc可选依赖libavc1394: for devices using the 1394ta AV/C
:: wicd-gtk可选依赖python2-notify: needed if you want notifications
:: wine可选依赖lib32-lcms
:: wine可选依赖alsa-plugins
:: wine可选依赖lib32-alsa-plugins
:: xmms2可选依赖wavpack: WavPack support
:: zim可选依赖mercurial: Version Control plugin

软件包 (96): alsa-plugins-1.0.27-2 apr-1.4.8-2 apr-util-1.5.2-3
dbus-sharp-0.7.0-4 dmidecode-2.12-2 gmime-2.6.18-1
gtk-sharp-2-2.12.22-1 hal-info-0.20091130-2
intltool-0.50.2-1 libavc1394-0.5.4-2
libgdiplus-2.10.9-2 libiec61883-1.2.0-3
libquvi-scripts-0.9.20131012-1 libxkbui-1.0.2-5
libxp-1.0.2-1 llvm-3.3-1 lua51-bitop-1.0.2-2
lua51-expat-1.2.0-4 lua51-socket-3.0rc1-3
mono-3.2.3-1 mono-addins-0.6.2-3 mutagen-1.22-1
perl-test-pod-1.48-1
perl-xml-namespacesupport-1.11-2 perl-xml-sax-0.99-3
perl-xml-sax-base-1.08-2 perl-yaml-syck-1.27-1
pm-quirks-0.20100619-3 pm-utils-1.4.1-6
printproto-1.0.5-2 pygobject-devel-3.10.1-1
python-cairo-1.10.0-3 qt5-script-5.1.1-5
qt5-translations-5.1.1-5 serf-1.3.1-2
taglib-sharp-2.1.0.0-1 unixodbc-2.3.2-1
wavpack-4.70.0-2 webkitgtk2-1.10.2-8
apache-ant-1.9.2-3 audiofile-0.3.6-2
autoconf2.13-2.13-2 boo-0.9.4.9-3 clang-3.3-1
cmake-2.8.12-1 dbus-sharp-glib-0.5.0-4
fastjar-0.98-2 fontforge-20120731_b-6
gconf-sharp-2.24.2-3 gdata-sharp-1.7.0.1-2
gkeyfile-sharp-0.1-2 gnome-common-3.10.0-1
gnustep-make-clang-svn-37269-1 gperf-3.0.4-4
gst-plugins-base-1.2.0-1 gst-plugins-good-1.2.0-1
gudev-sharp-0.1-2 hal-0.5.14-17 imake-1.0.6-1
json-glib-0.16.2-1 lesstif-0.95.2-6
lib32-alsa-plugins-1.0.27-1 lib32-lcms-1.19-4
libgpod-0.8.2-7 libquvi-0.9.3-1 mercurial-2.7.2-1
mono-upnp-0.1.2-1 mono-zeroconf-0.9.0-3
nasm-2.10.09-1 perl-xml-libxml-2.0106-1
polkit-gnome-0.105-2 python-gobject-3.10.1-1
python-pyopenssl-0.13.1-1
python2-distutils-extra-2.37-1
python2-gnomekeyring-2.32.0-14
python2-gobject-3.10.1-1 python2-greenlet-0.4.1-1
python2-notify-0.1.1-12 python2-pexpect-2.4-2
python2-pycurl-7.19.0.2-1 pywebkitgtk-1.1.8-3
qt5-graphicaleffects-5.1.1-5
qt5-imageformats-5.1.1-5 qt5-multimedia-5.1.1-5
qt5-quick1-5.1.1-5 qt5-quickcontrols-5.1.1-5
qt5-serialport-5.1.1-5 qt5-svg-5.1.1-5
qt5-tools-5.1.1-5 qt5-x11extras-5.1.1-5
rpmextract-1.0-5 subversion-1.8.3-1
totem-plparser-3.10.0-2 vala-0.22.0-1
xmlto-0.0.25-2 yasm-1.2.0-3

全部移去体积: 593.96 MiB

:: 打算删除这些软件包吗? [Y/n]
( 1/96) 正在删除 yasm [#########] 100%
( 2/96) 正在删除 xmlto [#########] 100%
( 3/96) 正在删除 vala [#########] 100%
( 4/96) 正在删除 totem-plparser [#########] 100%
( 5/96) 正在删除 subversion [#########] 100%
( 6/96) 正在删除 rpmextract [#########] 100%
( 7/96) 正在删除 qt5-x11extras [#########] 100%
( 8/96) 正在删除 qt5-tools [#########] 100%
( 9/96) 正在删除 qt5-svg [#########] 100%
(10/96) 正在删除 qt5-serialport [#########] 100%
(11/96) 正在删除 qt5-quickcontrols [#########] 100%
(12/96) 正在删除 qt5-quick1 [#########] 100%
(13/96) 正在删除 qt5-multimedia [#########] 100%
(14/96) 正在删除 qt5-imageformats [#########] 100%
(15/96) 正在删除 qt5-graphicaleffects [#########] 100%
(16/96) 正在删除 pywebkitgtk [#########] 100%
(17/96) 正在删除 python2-pycurl [#########] 100%
(18/96) 正在删除 python2-pexpect [#########] 100%
(19/96) 正在删除 python2-notify [#########] 100%
(20/96) 正在删除 python2-greenlet [#########] 100%
(21/96) 正在删除 python2-gobject [#########] 100%
(22/96) 正在删除 python2-gnomekeyring [#########] 100%
(23/96) 正在删除 python2-distutils-extra [#########] 100%
(24/96) 正在删除 python-pyopenssl [#########] 100%
(25/96) 正在删除 python-gobject [#########] 100%
(26/96) 正在删除 polkit-gnome [#########] 100%
(27/96) 正在删除 perl-xml-libxml [#########] 100%
(28/96) 正在删除 nasm [#########] 100%
(29/96) 正在删除 mono-zeroconf [#########] 100%
(30/96) 正在删除 mono-upnp [#########] 100%
(31/96) 正在删除 mercurial [#########] 100%
(32/96) 正在删除 libquvi [#########] 100%
(33/96) 正在删除 libgpod [#########] 100%
(34/96) 正在删除 lib32-lcms [#########] 100%
(35/96) 正在删除 lib32-alsa-plugins [#########] 100%
(36/96) 正在删除 lesstif [#########] 100%
(37/96) 正在删除 json-glib [#########] 100%
(38/96) 正在删除 imake [#########] 100%
(39/96) 正在删除 hal [#########] 100%
(40/96) 正在删除 gudev-sharp [#########] 100%
(41/96) 正在删除 gst-plugins-good [#########] 100%
(42/96) 正在删除 gst-plugins-base [#########] 100%
(43/96) 正在删除 gperf [#########] 100%
(44/96) 正在删除 gnustep-make-clang-svn [#########] 100%
(45/96) 正在删除 gnome-common [#########] 100%
(46/96) 正在删除 gkeyfile-sharp [#########] 100%
(47/96) 正在删除 gdata-sharp [#########] 100%
(48/96) 正在删除 gconf-sharp [#########] 100%
(49/96) 正在删除 fontforge [#########] 100%
(50/96) 正在删除 fastjar [#########] 100%
(51/96) 正在删除 dbus-sharp-glib [#########] 100%
(52/96) 正在删除 cmake [#########] 100%
(53/96) 正在删除 clang [#########] 100%
(54/96) 正在删除 boo [#########] 100%
(55/96) 正在删除 autoconf2.13 [#########] 100%
(56/96) 正在删除 audiofile [#########] 100%
(57/96) 正在删除 apache-ant [#########] 100%
(58/96) 正在删除 perl-test-pod [#########] 100%
(59/96) 正在删除 perl-yaml-syck [#########] 100%
(60/96) 正在删除 gmime [#########] 100%
(61/96) 正在删除 serf [#########] 100%
(62/96) 正在删除 qt5-translations [#########] 100%
(63/96) 正在删除 qt5-script [#########] 100%
(64/96) 正在删除 webkitgtk2 [#########] 100%
(65/96) 正在删除 pygobject-devel [#########] 100%
(66/96) 正在删除 intltool [#########] 100%
(67/96) 正在删除 python-cairo [#########] 100%
(68/96) 正在删除 perl-xml-sax [#########] 100%
(69/96) 正在删除 mono-addins [#########] 100%
(70/96) 正在删除 taglib-sharp [#########] 100%
(71/96) 正在删除 libquvi-scripts [#########] 100%
(72/96) 正在删除 mutagen [#########] 100%
(73/96) 正在删除 alsa-plugins [#########] 100%
(74/96) 正在删除 libxp [#########] 100%
(75/96) 正在删除 dmidecode [#########] 100%
(76/96) 正在删除 hal-info [#########] 100%
(77/96) 正在删除 pm-utils [#########] 100%
(78/96) 正在删除 gtk-sharp-2 [#########] 100%
(79/96) 正在删除 libavc1394 [#########] 100%
(80/96) 正在删除 libiec61883 [#########] 100%
(81/96) 正在删除 wavpack [#########] 100%
(82/96) 正在删除 llvm [#########] 100%
(83/96) 正在删除 libxkbui [#########] 100%
(84/96) 正在删除 dbus-sharp [#########] 100%
(85/96) 正在删除 mono [#########] 100%
(86/96) 正在删除 apr-util [#########] 100%
(87/96) 正在删除 perl-xml-namespacesupport [#########] 100%
(88/96) 正在删除 perl-xml-sax-base [#########] 100%
(89/96) 正在删除 lua51-bitop [#########] 100%
(90/96) 正在删除 lua51-expat [#########] 100%
(91/96) 正在删除 lua51-socket [#########] 100%
(92/96) 正在删除 printproto [#########] 100%
(93/96) 正在删除 pm-quirks [#########] 100%
(94/96) 正在删除 libgdiplus [#########] 100%
(95/96) 正在删除 apr [#########] 100%
(96/96) 正在删除 unixodbc
时间就像一张网,你撒在那里,你的收获就在那里。
头像
intetnet
帖子: 49
注册时间: 2009-05-21 16:53
送出感谢: 0
接收感谢: 0

Re: Arch如何清理无用包?

#18

帖子 intetnet » 2014-05-22 12:23

mark
flylinux
帖子: 1
注册时间: 2014-06-15 15:58
系统: archlinux
送出感谢: 0
接收感谢: 0

Re: Arch如何清理无用包?

#19

帖子 flylinux » 2014-06-15 16:01

arch的理念就是自己装的每个包都清楚是干嘛用的,即使强制删除了,如果还记得就可以装回去
回复

回到 “Arch发行版”