分页: 1 / 1

archlinux更新依赖问题

发表于 : 2018-10-07 11:19
jinjiachen
系统更新时出现如下依赖问题, 官网和网上都无找到解决方式,特来此寻找帮助,谢谢,感谢是个死循环呢
:: 正在进行全面系统更新...
:: 替换 ca-certificates-cacert 吗 (使用 core/ca-certificates )? [Y/n] y
:: 替换 compositeproto 吗 (使用 extra/xorgproto )? [Y/n] y
:: 替换 damageproto 吗 (使用 extra/xorgproto )? [Y/n] y
:: 替换 dmxproto 吗 (使用 extra/xorgproto )? [Y/n] y
:: 替换 dri2proto 吗 (使用 extra/xorgproto )? [Y/n] y
:: 替换 dri3proto 吗 (使用 extra/xorgproto )? [Y/n] y
y:: 替换 fixesproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 fontsproto 吗 (使用 extra/xorgproto )? [Y/n] y
:: 替换 glproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 gnome-themes-standard 吗 (使用 extra/gnome-themes-extra )? [Y/n]
:: 替换 inputproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 kbproto 吗 (使用 extra/xorgproto )? [Y/n]

:: 替换 libx264 吗 (使用 extra/x264 )? [Y/n]
:: 替换 libx264-all 吗 (使用 extra/x264 )? [Y/n]
:: 替换 pkg-config 吗 (使用 core/pkgconf )? [Y/n]
:: 替换 presentproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 python-crypto 吗 (使用 community/python-pycryptodome )? [Y/n]
:: 替换 randrproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 recordproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 renderproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 resourceproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 scrnsaverproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 videoproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 xextproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 xf86dgaproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 xf86driproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 xf86vidmodeproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 xineramaproto 吗 (使用 extra/xorgproto )? [Y/n]
:: 替换 xproto 吗 (使用 extra/xorgproto )? [Y/n]
正在解决依赖关系...
正在查找软件包冲突...
错误:无法准备事务处理 (无法满足依赖关系)
:: libxfont:移除 fontsproto 将破坏依赖关系 'fontsproto>=2.1.3'

Re: archlinux更新依赖问题

发表于 : 2018-10-07 13:59
qiang_liu8183
太久没更新了吧?全选Y就是了

Re: archlinux更新依赖问题

发表于 : 2018-10-07 20:20
jinjiachen
qiang_liu8183 写了:
2018-10-07 13:59
太久没更新了吧?全选Y就是了
以上运行就是默认选y后出现的依赖错误,无法更新

Re: archlinux更新依赖问题

发表于 : 2018-10-07 20:43
qiang_liu8183
用的什么源?先确定源没问题,软件包数据库同步了没有?没有就先pacman -Sy同步一下再更新
还不行就更新时加-d或-dd参数跳过依赖关系版本检查
libxfont这个包早就没了,现在是libxfont2,多久没更新了老实交待

Re: archlinux更新依赖问题

发表于 : 2018-10-11 20:42
jinjiachen
qiang_liu8183 写了:
2018-10-07 20:43
用的什么源?先确定源没问题,软件包数据库同步了没有?没有就先pacman -Sy同步一下再更新
还不行就更新时加-d或-dd参数跳过依赖关系版本检查
libxfont这个包早就没了,现在是libxfont2,多久没更新了老实交待
是有一段时间了,大概半年,源是好的,官方的,我刚刚试了下,去掉extra和community,更新是好的,开了extra又出错了。

Re: archlinux更新依赖问题

发表于 : 2018-10-12 10:53
poloshiao
去掉extra和community,更新是好的,开了extra又出错了。
https://wiki.archlinux.org/index.php/of ... background
Historical background

請使用 extra 或 community 關鍵字 搜尋