debian10中systemd-udevd cpu100%?

最大的社区版本,Ubuntu的发源地
回复
handyw
帖子: 242
注册时间: 2007-06-11 13:06
送出感谢: 9 次
接收感谢: 0

debian10中systemd-udevd cpu100%?

#1

帖子 handyw » 2019-07-13 18:15

空闲是发现硬盘灯闪,进入系统时特慢,常看htop systemd-udevd 占用cpu100%杀不死,该怎么解决?
我只用关电脑了
关电脑时发现/sbin/init cpu占用80%多,升级到Debian10就感觉风扇快了,硬盘灯狂闪,请高手解决谢谢
头像
astolia
论坛版主
帖子: 4178
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 697 次

Re: debian10中systemd-udevd cpu100%?

#2

帖子 astolia » 2019-07-13 20:02

代码: 全选

udevadm monitor

代码: 全选

journalctl
看一下系统事件
handyw
帖子: 242
注册时间: 2007-06-11 13:06
送出感谢: 9 次
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#3

帖子 handyw » 2019-07-13 20:19

电脑关了
handyw
帖子: 242
注册时间: 2007-06-11 13:06
送出感谢: 9 次
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#4

帖子 handyw » 2019-07-15 8:28

astolia 写了:
2019-07-13 20:02

代码: 全选

udevadm monitor

代码: 全选

journalctl
看一下系统事件
udevadm monitor 无法完成,ctrl+c
journalctl用的是4.9内核
附件
journalctl.txt
(219.68 KiB) 下载 18 次
handyw
帖子: 242
注册时间: 2007-06-11 13:06
送出感谢: 9 次
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#5

帖子 handyw » 2019-07-15 8:54

昨天上班查了可能是蓝牙导致的问题,在bios里关闭蓝牙,现在好像好了
/lib/udev/rules.d/97-hid2hci.rules重命名了
还有搜索bluez卸载居然要把gnome卸载了,吓的我取消了
还有可能是nvidia驱动问题,但是我没装,查了下
/lib/udev/rules.d/71-nvidia.rules没有就没动了
handyw
帖子: 242
注册时间: 2007-06-11 13:06
送出感谢: 9 次
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#6

帖子 handyw » 2019-07-15 9:45

现在在firefox里告诫自己只能新开一个网页,要不然系统就慢了或者像上次那样很久才有反应
有时自己就忘了这一原则,真是不应该呀

还有我决定以后不升级了,不管有什么新功能,我这旧电脑需求就是能上网,听歌,看视频都不要求了,呵呵呵
头像
astolia
论坛版主
帖子: 4178
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 697 次

Re: debian10中systemd-udevd cpu100%?

#7

帖子 astolia » 2019-07-15 16:12

handyw 写了:
2019-07-15 8:28
udevadm monitor 无法完成,ctrl+c
journalctl用的是4.9内核
udevadm是让你在systemd-udevd出现高占用的时候看是什么udev消息导致的,平常看自然什么都没有
journalctl也是同样的
handyw
帖子: 242
注册时间: 2007-06-11 13:06
送出感谢: 9 次
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#8

帖子 handyw » 2019-07-15 19:02

astolia 写了:
2019-07-15 16:12
handyw 写了:
2019-07-15 8:28
udevadm monitor 无法完成,ctrl+c
journalctl用的是4.9内核
udevadm是让你在systemd-udevd出现高占用的时候看是什么udev消息导致的,平常看自然什么都没有
journalctl也是同样的
好像是kernel这一步卡在这没有输出
wulisong
帖子: 15
注册时间: 2009-02-16 21:23
送出感谢: 0
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#9

帖子 wulisong » 2019-07-21 20:14

会不会是新版系统配旧内核的问题?用4.19内核看看会不会出现这个问题。
handyw
帖子: 242
注册时间: 2007-06-11 13:06
送出感谢: 9 次
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#10

帖子 handyw » 2019-10-20 10:28

10是新内核,应该跟内核无关
pang15975386
帖子: 86
注册时间: 2011-05-16 18:00
送出感谢: 1 次
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#11

帖子 pang15975386 » 2019-11-14 14:30

我的是perl狂飙(debian10),cpu 100% ,然后手动杀死perl,在debian9倒是没这个问题
handyw
帖子: 242
注册时间: 2007-06-11 13:06
送出感谢: 9 次
接收感谢: 0

Re: debian10中systemd-udevd cpu100%?

#12

帖子 handyw » 2019-11-15 15:34

感觉debian10问题不少
回复

回到 “Debian发行版”