ubuntu 18.04更新后lighttpd不能开启https

编译打包和其他
回复
凌风
帖子: 39
注册时间: 2007-11-17 23:34
送出感谢: 0
接收感谢: 3 次

ubuntu 18.04更新后lighttpd不能开启https

#1

帖子 凌风 » 2019-06-22 9:06

Ubuntu 18.04.2 lts升级的时候把openssl从1.1.0g升级到了1.1.1,而lighttpd却无法支持新版的libssl1.1.so,导致chrome和firefox浏览器都没有办法访问,chrome直接报错ERR_EMPTY_RESPONSE
头像
astolia
论坛版主
帖子: 5699
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 981 次

Re: ubuntu 18.04更新后lighttpd不能开启https

#2

帖子 astolia » 2019-06-22 19:41

https://bugs.launchpad.net/ubuntu/+sour ... ug/1832295
要么把openssl降级回去,要么自己去从源码编译1.4.51之后版本的lighttpd
凌风
帖子: 39
注册时间: 2007-11-17 23:34
送出感谢: 0
接收感谢: 3 次

Re: ubuntu 18.04更新后lighttpd不能开启https

#3

帖子 凌风 » 2019-06-23 9:00

ubuntu官方仓库就不能升级下lighttpd到1.4.51吗,我们批量部署的,不方便自己编译一下
凌风
帖子: 39
注册时间: 2007-11-17 23:34
送出感谢: 0
接收感谢: 3 次

Re: ubuntu 18.04更新后lighttpd不能开启https

#4

帖子 凌风 » 2019-06-23 9:01

现在采用的办法是降级,但是降级后再安装任何东西都是提示要 apt-get install -f
凌风
帖子: 39
注册时间: 2007-11-17 23:34
送出感谢: 0
接收感谢: 3 次

Re: ubuntu 18.04更新后lighttpd不能开启https

#5

帖子 凌风 » 2019-06-25 15:04

真是坑啊,把ubuntu 19.04的lighttpd源码下出来在18.04上安装算是搞定了,主要是习惯了ubuntu给整理好的lighttpd的使用方式
回复