12.04系统ati显卡安装成功了。。。。。

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
freddong353
帖子: 2
注册时间: 2012-02-21 14:20
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#31

帖子 freddong353 » 2012-05-31 17:08

xyuzu3 写了:照着楼主的方法安装了
过程没有提示错误
但重启后 执行 fglrxinfo
怎么还是未装显卡驱动的样子 而且unity 3d也进去不去
root@# fglrxinfo
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 139 (ATIFGLEXTENSION)
Minor opcode of failed request: 66 ()
Serial number of failed request: 13
Current serial number in output stream: 13

求解决了
3870也是如此。。。。
cancrazy
帖子: 40
注册时间: 2009-10-05 9:15
送出感谢: 0
接收感谢: 1 次

Re: 12.04系统ati显卡安装成功了。。。。。

#32

帖子 cancrazy » 2012-06-02 9:23

更楼主用的方法一样,都成功了
wjjs
帖子: 145
注册时间: 2007-07-08 19:21
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#33

帖子 wjjs » 2012-06-05 14:32

罗传龙 写了:重装或要卸载:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

安装闭源前准备的库:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases linux-headers-generic


如果你安装的是64位的ubuntu,请安装32位库:
sudo apt-get install ia32-libs

64位 驱动内核模块:
sudo apt-get install dkms

下面是在http://ubuntuforums.org/showthread.php?t=1969827看的方法
sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot
cd ~/; mkdir catalyst12.4; cd catalyst12.4/
wget http://www2.ati.com/drivers/linux/amd-d ... x86_64.run
chmod +x amd-driver-installer-12-4-x86.x86_64.run
./amd-driver-installer-12-4-x86.x86_64.run --extract driver
cd driver/common/lib/modules/fglrx/build_mod/
wget -O fglrx.patch http://ubuntuone.com/5gNgEmVfzs3ytD5QZ2YGCi
patch -p1 < fglrx.patch
cd ~/catalyst12.4/driver/
./ati-installer.sh 8.961 --buildpkg Ubuntu/precise
cd ../


安装生成的包:
sudo dpkg -i fglrx*.deb

生成配置文件:
sudo aticonfig --initial -f

防止配置未生效:
sudo aticonfig --input=/etc/X11/xorg.conf --tls=1

重启。

检查是否成功:

fglrxinfo
我干才成功了,分享一下。
谢谢!备用
weiminnihao9
帖子: 37
注册时间: 2012-04-23 19:57
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#34

帖子 weiminnihao9 » 2012-06-11 10:47

感谢楼主,我的deepin12.06照此方法安装成功。
头像
rapistor
帖子: 1982
注册时间: 2009-01-19 15:09
送出感谢: 4 次
接收感谢: 8 次

Re: 12.04系统ati显卡安装成功了。。。。。

#35

帖子 rapistor » 2012-06-11 12:48

你们这么辛苦安装闭源驱动,比开源驱动性能大概提高多少?
我APU用开源驱动,感觉用得很爽了。
跑TORCS能到100fps左右,我觉得已经很够用了。
因为四核U,性能严重过剩,根本不用考虑什么硬解。
请问哪位对比过开源和闭源的性能没?
坚守在linux的天堂!
头像
Alog_W
帖子: 63
注册时间: 2008-03-11 10:14
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#36

帖子 Alog_W » 2012-06-15 1:04

rapistor 写了:你们这么辛苦安装闭源驱动,比开源驱动性能大概提高多少?
我APU用开源驱动,感觉用得很爽了。
跑TORCS能到100fps左右,我觉得已经很够用了。
因为四核U,性能严重过剩,根本不用考虑什么硬解。
请问哪位对比过开源和闭源的性能没?
不一样,至少温度上差非常多!
我用的amd12.4,把intel的关了,就可以安装上。其他版本基本上安装不上。
hlsq
帖子: 94
注册时间: 2008-09-16 3:03
系统: Windowns7ubuuntu
送出感谢: 12 次
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#37

帖子 hlsq » 2012-06-21 13:20

lyricorpse 写了:
surmise 写了:有啥好激动的。都是按照同一份文档作为参考安装的。
为什么6470M的显卡按照这个步骤走的时候会出警告,然后重启过后进入low-graphic mode,然后只能退回命令行界面,把fglrx卸载后才能用集成显卡进入2D桌面
我的6470M也警告,能进桌面,但是花屏还有图标显示不出来。
头像
abbcbbdd
帖子: 55
注册时间: 2011-08-23 18:47
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#38

帖子 abbcbbdd » 2012-07-19 8:29

lyric@ThinkPad-E420:~/catalyst12.4$ sudo dpkg -i *.deb
(正在读取数据库 ... 系统当前共安装有 217802 个文件和目录。)
正预备替换 fglrx 2:8.961-0ubuntu1 (使用 fglrx_8.961-0ubuntu1_i386.deb) ...
Removing all DKMS Modules
Done.
正在解压缩将用于更替的包文件 fglrx ...
正预备替换 fglrx-amdcccle 2:8.961-0ubuntu1 (使用 fglrx-amdcccle_8.961-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 fglrx-amdcccle ...
正预备替换 fglrx-dev 2:8.961-0ubuntu1 (使用 fglrx-dev_8.961-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 fglrx-dev ...
正在设置 fglrx (2:8.961-0ubuntu1) ...
update-alternatives: 警告: 链接组 i386-linux-gnu_gl_conf 已损坏,故强制重新安装候选项 /usr/lib/fglrx/ld.so.confs
update-alternatives: 警告: 跳过创建 /etc/OpenCL/vendors/amdocl64.icd 因为所关联文件 /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalcl.so 因为所关联文件 /usr/lib32/fglrx/libaticalcl.so (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalrt.so 因为所关联文件 /usr/lib32/fglrx/libaticalrt.so (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 链接组 i386-linux-gnu_gl_conf 已损坏,故强制重新安装候选项 /usr/lib/fglrx/ld.so.confs
update-alternatives: 警告: 跳过创建 /etc/OpenCL/vendors/amdocl64.icd 因为所关联文件 /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalcl.so 因为所关联文件 /usr/lib32/fglrx/libaticalcl.so (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalrt.so 因为所关联文件 /usr/lib32/fglrx/libaticalrt.so (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-initramfs: deferring update (trigger activated)
Loading new fglrx-8.961 DKMS files...
Building only for 3.2.0-24-generic-pae
Building for architecture i686
Building initial module for 3.2.0-24-generic-pae
Done.

fglrx:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/3.2.0-24-generic-pae/updates/dkms/

depmod....

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
正在处理用于 ureadahead 的触发器...
正在处理用于 bamfdaemon 的触发器...
Rebuilding /usr/share/applications/bamf.index...
正在设置 fglrx-amdcccle (2:8.961-0ubuntu1) ...
正在设置 fglrx-dev (2:8.961-0ubuntu1) ...
正在处理用于 initramfs-tools 的触发器...
update-initramfs: Generating /boot/initrd.img-3.2.0-24-generic-pae
正在处理用于 libc-bin 的触发器...
ldconfig deferred processing now taking place


怎么解决,和28楼一样的问题,我安装的是12.6版本的
jiaoyilun
帖子: 8
注册时间: 2009-07-24 11:54
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#39

帖子 jiaoyilun » 2012-08-05 2:00

abbcbbdd 写了:lyric@ThinkPad-E420:~/catalyst12.4$ sudo dpkg -i *.deb
(正在读取数据库 ... 系统当前共安装有 217802 个文件和目录。)
正预备替换 fglrx 2:8.961-0ubuntu1 (使用 fglrx_8.961-0ubuntu1_i386.deb) ...
Removing all DKMS Modules
Done.
正在解压缩将用于更替的包文件 fglrx ...
正预备替换 fglrx-amdcccle 2:8.961-0ubuntu1 (使用 fglrx-amdcccle_8.961-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 fglrx-amdcccle ...
正预备替换 fglrx-dev 2:8.961-0ubuntu1 (使用 fglrx-dev_8.961-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 fglrx-dev ...
正在设置 fglrx (2:8.961-0ubuntu1) ...
update-alternatives: 警告: 链接组 i386-linux-gnu_gl_conf 已损坏,故强制重新安装候选项 /usr/lib/fglrx/ld.so.confs
update-alternatives: 警告: 跳过创建 /etc/OpenCL/vendors/amdocl64.icd 因为所关联文件 /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalcl.so 因为所关联文件 /usr/lib32/fglrx/libaticalcl.so (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalrt.so 因为所关联文件 /usr/lib32/fglrx/libaticalrt.so (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 链接组 i386-linux-gnu_gl_conf 已损坏,故强制重新安装候选项 /usr/lib/fglrx/ld.so.confs
update-alternatives: 警告: 跳过创建 /etc/OpenCL/vendors/amdocl64.icd 因为所关联文件 /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalcl.so 因为所关联文件 /usr/lib32/fglrx/libaticalcl.so (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalrt.so 因为所关联文件 /usr/lib32/fglrx/libaticalrt.so (位于链接组 i386-linux-gnu_gl_conf)不存在。
update-initramfs: deferring update (trigger activated)
Loading new fglrx-8.961 DKMS files...
Building only for 3.2.0-24-generic-pae
Building for architecture i686
Building initial module for 3.2.0-24-generic-pae
Done.

fglrx:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/3.2.0-24-generic-pae/updates/dkms/

depmod....

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
正在处理用于 ureadahead 的触发器...
正在处理用于 bamfdaemon 的触发器...
Rebuilding /usr/share/applications/bamf.index...
正在设置 fglrx-amdcccle (2:8.961-0ubuntu1) ...
正在设置 fglrx-dev (2:8.961-0ubuntu1) ...
正在处理用于 initramfs-tools 的触发器...
update-initramfs: Generating /boot/initrd.img-3.2.0-24-generic-pae
正在处理用于 libc-bin 的触发器...
ldconfig deferred processing now taking place


怎么解决,和28楼一样的问题,我安装的是12.6版本的

Y460A,遇到相同问题,求救
头像
shanpo
帖子: 33
注册时间: 2012-08-15 22:46
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#40

帖子 shanpo » 2012-08-29 0:50

感谢 :em38

先前用系统设置-附加驱动安装了开源版本的驱动,后来安装软件过程中莫名就无法登陆了,干脆重装了一遍系统,安装闭源驱动。

按楼主的方法加上23楼提示安装libc6-i386 和 lib32gcc1这两个包,过程十分顺利,ubuntu 12.04.1 64位版本,我的显卡型号是4830。
头像
hawkIdeality
帖子: 411
注册时间: 2012-05-14 18:39
送出感谢: 5 次
接收感谢: 8 次

Re: 12.04系统ati显卡安装成功了。。。。。

#41

帖子 hawkIdeality » 2012-08-29 1:03

双显卡啊!太赞了。改天我也要实践一下!!
崩溃是不可抗拒滴
攒钱买(第?台)macbook,然后装ubuntu
那些说unity找不到应用程序的人拜托按一下win+A好吗?
Novelty, Novelty, Give Me Novelty
发表Linux、Win、OS X的对比帖时,建议您确认一下您真的用过Linux&&Win&&OS X,而不是用过Linux||Win||OS X。
吾乃古剑奇谭NC粉!
头像
hawkIdeality
帖子: 411
注册时间: 2012-05-14 18:39
送出感谢: 5 次
接收感谢: 8 次

Re: 12.04系统ati显卡安装成功了。。。。。

#42

帖子 hawkIdeality » 2012-08-29 1:11

哦。不过我想问问,这个驱动安装完以后,是不是集成显卡会自动关闭?还是两个显卡依然同时打开?
崩溃是不可抗拒滴
攒钱买(第?台)macbook,然后装ubuntu
那些说unity找不到应用程序的人拜托按一下win+A好吗?
Novelty, Novelty, Give Me Novelty
发表Linux、Win、OS X的对比帖时,建议您确认一下您真的用过Linux&&Win&&OS X,而不是用过Linux||Win||OS X。
吾乃古剑奇谭NC粉!
头像
hawkIdeality
帖子: 411
注册时间: 2012-05-14 18:39
送出感谢: 5 次
接收感谢: 8 次

Re: 12.04系统ati显卡安装成功了。。。。。

#43

帖子 hawkIdeality » 2012-08-30 0:41

:em20 :em20 :em20 :em20

试过了,惨败啊,重启后只能进入low-graphic mode了...
崩溃是不可抗拒滴
攒钱买(第?台)macbook,然后装ubuntu
那些说unity找不到应用程序的人拜托按一下win+A好吗?
Novelty, Novelty, Give Me Novelty
发表Linux、Win、OS X的对比帖时,建议您确认一下您真的用过Linux&&Win&&OS X,而不是用过Linux||Win||OS X。
吾乃古剑奇谭NC粉!
b2u8q2
帖子: 9
注册时间: 2010-01-04 13:06
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#44

帖子 b2u8q2 » 2012-08-30 16:06

64位安装ATI驱动是否需要安装补丁?
wget -O fglrx.patch http://ubuntuone.com/5gNgEmVfzs3ytD5QZ2YGCi
patch -p1 < fglrx.patch
kk47
帖子: 1
注册时间: 2012-01-27 11:50
送出感谢: 0
接收感谢: 0

Re: 12.04系统ati显卡安装成功了。。。。。

#45

帖子 kk47 » 2012-10-17 1:16

ubuntu 12.04.1 64位系统
按照楼主的方法,集显ATI HD 3200 安装成功! :em05
回复

回到 “常用硬件支持”