Pip running goes wrong

Python/PHP/Perl 开发与设计
回复
悬崖勒马2011
帖子: 91
注册时间: 2013-01-23 14:27
系统: ubuntu 12.04
送出感谢: 0
接收感谢: 0

Pip running goes wrong

#1

帖子 悬崖勒马2011 » 2018-05-23 1:20

I use ubuntu 14.04, and when I run pip, it always show

AttributeError: 'module' object has no attribute 'SSL_ST_INIT'

I checked pip version, it shows

"python-pip is already the newest version."

I tried: "pip install --upgrade pyOpenSSL", it returns same problem.
When I run: sudo apt-get install python-openssl, it says: python-openssl is already the newest version.

How can I solve this?

Thanks!
头像
九天星
帖子: 1411
注册时间: 2007-07-14 20:45
送出感谢: 69 次
接收感谢: 41 次

Re: Pip running goes wrong

#2

帖子 九天星 » 2018-05-23 8:59

代码: 全选

sudo easy_install --upgrade pip
悬崖勒马2011
帖子: 91
注册时间: 2013-01-23 14:27
系统: ubuntu 12.04
送出感谢: 0
接收感谢: 0

Re: Pip running goes wrong

#3

帖子 悬崖勒马2011 » 2018-05-24 0:37

九天星 写了:

代码: 全选

sudo easy_install --upgrade pip
It worked! Thanks!
回复

回到 “Python/Php/Perl”