arm V7中运行ubuntu arm版文件系统 在安装图形系统中出错?

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
cez1230
帖子: 2
注册时间: 2015-08-18 23:47
送出感谢: 0
接收感谢: 0

arm V7中运行ubuntu arm版文件系统 在安装图形系统中出错?

#1

帖子 cez1230 » 2015-08-19 1:36

我是想 在qemu 中用armv7的 系统运行 这个ubuntu 文件系统 ,而且像带有图形界面
现在文件系统可以正常启动运行,但是在安装图形系统的时候 一直 出错。

哪位有空 能不能帮看看???



代码: 全选

sudo apt-get update
sudo apt-get install qemu-user-static
sudo qemu-debootstrap --arch armhf lucid ubuntu_arm  
sudo chroot ubuntu_arm 

apt-get update  
----------------好了 下面就是开始出错了------------

代码: 全选

apt-get install xinit  
apt-get install xdm
apt-get install xubuntu-desktop  
++++++++++++++下面是 qemu端 中出现的问题++++++++
------------------- apt-get install xinit 中出现的问题 ---------------------
dpkg :error :PATH is not set.
E:Sub-process /usr/bin/dpkg returned an error code






++++++++++++++下面是 ubuntu 电脑端 chroot中出现的问题++++++++
------------------- apt-get install xinit 中出现的问题 ---------------------


[email protected]:/# apt-get install xinit
Reading package lists... Done
Building dependency tree
Reading state information... Done
xorg is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
22 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "zh_CN:en",
LC_ALL = (unset),
LC_PAPER = "zh_CN.UTF-8",
LC_NUMERIC = "zh_CN.UTF-8",
LC_IDENTIFICATION = "zh_CN.UTF-8",
LC_MEASUREMENT = "zh_CN.UTF-8",
LC_NAME = "zh_CN.UTF-8",
LC_TELEPHONE = "zh_CN.UTF-8",
LC_ADDRESS = "zh_CN.UTF-8",
LC_MONETARY = "zh_CN.UTF-8",
LC_TIME = "zh_CN.UTF-8",
LANG = "zh_CN.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Can not write log, openpty() failed (/dev/pts not mounted?)
Setting up policykit-1 (0.96-2) ...
/sbin/start-stop-daemon: nothing in /proc - not mounted?
dpkg: error processing policykit-1 (--configure):
subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of policykit-1-gnome:
policykit-1-gnome depends on policykit-1; however:
Package policykit-1 is not configured yet.
dpkg: error processing policykit-1-gnome (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gvfs:
gvfs depends on policykit-1-gnome; however:
Package policykit-1-gnome is not configured yet.
dpkg: error processing gvfs (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome2-0:
libgnome2-0 depends on gvfs; however:
Package gvfs is not configured yet.
dpkg: error processing libgnome2-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libbonoboui2-0:
libbonoboui2-0 depends on libgnome2-0 (>= 2.17.3); however:
Package libgnome2-0 is not configured yet.
No apport report written because the error message indicates its a followup error from a previous failure.dpkg: error processing libbonoboui2-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpanel-applet2-0:
libpanel-applet2-0 depends on libbonoboui2-0 (>= 2.15.1); however:
Package libbonoboui2-0 is not configured yet.
dpkg: error processing libpanel-applet2-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus:
nautilus depends on gvfs (>= 1.3.2); however:
Package gvfs is not configured yet.

No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached alreadydpkg: error processing nautilus (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-session-bin:
gnome-session-bin depends on policykit-1-gnome; however:
Package policykit-1-gnome is not configured yet.

No apport report written because MaxReports is reached already
dpkg: error processing gnome-session-bin (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ubuntu-system-service:
ubuntu-system-service depends on policykit-1; however:
Package policykit-1 is not configured yet.
No apport report written because MaxReports is reached already
dpkg: error processing ubuntu-system-service (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-control-center:
gnome-control-center depends on ubuntu-system-service (>= 0.1.10); however:
Package ubuntu-system-service is not configured yet.
No apport report written because MaxReports is reached already
dpkg: error processing gnome-control-center (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomeui-0:
libgnomeui-0 depends on libbonoboui2-0 (>= 2.15.1); however:
Package libbonoboui2-0 is not configured yet.
libgnomeui-0 depends on libgnome2-0 (>= 2.17.3); however:
Package libgnome2-0 is not configured yet.
No apport report written because MaxReports is reached already
dpkg: error processing libgnomeui-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gnome2:
python-gnome2 depends on libbonoboui2-0 (>= 2.15.1); however:
Package libbonoboui2-0 is not configured yet.
python-gnome2 depends on libgnome2-0 (>= 2.17.3); however:
Package libgnome2-0 is not configured yet.
python-gnome2 depends on libgnomeui-0 (>= 2.22.0); however:
Package libgnomeui-0 is not configured yet.
No apport report written because MaxReports is reached already
dpkg: error processing python-gnome2 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of gnome-about:
gnome-about depends on python-gnome2; however:
Package python-gnome2 is not configured yet.
dpkg: error processing gnome-about (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of gnome-panel:
gnome-panel depends on libbonoboui2-0 (>= 2.15.1); however:
Package libbonoboui2-0 is not configured yet.
gnome-panel depends on libpanel-applet2-0 (>= 2.26.0); however:
Package libpanel-applet2-0 is not configured yet.
gnome-panel depends on gnome-control-center (>= 1:2.8.2-3); however:
Package gnome-control-center is not configured yet.
gnome-panel depends on gnome-about (>= 2.10.0-1); however:
Package gnome-about is not configured yet.
dpkg: error processing gnome-panel (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of gnome-session:
gnome-session depends on gnome-panel; however:
Package gnome-panel is not configured yet.
gnome-session depends on nautilus; however:
Package nautilus is not configured yet.
gnome-session depends on gnome-session-bin (>= 2.30); however:
Package gnome-session-bin is not configured yet.
gnome-session depends on gnome-session-bin (<< 2.31); however:
Package gnome-session-bin is not configured yet.
dpkg: error processing gnome-session (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of gnome-applets:
gnome-applets depends on libbonoboui2-0 (>= 2.15.1); however:
Package libbonoboui2-0 is not configured yet.
gnome-applets depends on libpanel-applet2-0 (>= 2.26.0); however:
Package libpanel-applet2-0 is not configured yet.
gnome-applets depends on gnome-panel (>= 2.13.4); however:
Package gnome-panel is not configured yet.
gnome-applets depends on gvfs; however:
Package gvfs is not configured yet.
dpkg: error processing gnome-applets (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of gdm:
gdm depends on libbonoboui2-0 (>= 2.15.1); however:
Package libbonoboui2-0 is not configured yet.
gdm depends on libgnome2-0 (>= 2.17.3); however:
Package libgnome2-0 is not configured yet.
gdm depends on libpanel-applet2-0 (>= 2.26.0); however:
Package libpanel-applet2-0 is not configured yet.
gdm depends on gnome-session-bin; however:
Package gnome-session-bin is not configured yet.
dpkg: error processing gdm (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of gvfs-backends:
gvfs-backends depends on gvfs (= 1.6.0+git20100414-0ubuntu1); however:
Package gvfs is not configured yet.
dpkg: error processing gvfs-backends (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of indicator-applet:
indicator-applet depends on libpanel-applet2-0 (>= 2.26.0); however:
Package libpanel-applet2-0 is not configured yet.
indicator-applet depends on gnome-panel; however:
Package gnome-panel is not configured yet.
dpkg: error processing indicator-applet (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of mousetweaks:
mousetweaks depends on libbonoboui2-0 (>= 2.15.1); however:
Package libbonoboui2-0 is not configured yet.
mousetweaks depends on libgnome2-0 (>= 2.17.3); however:
Package libgnome2-0 is not configured yet.
mousetweaks depends on libpanel-applet2-0 (>= 2.26.0); however:
Package libpanel-applet2-0 is not configured yet.
dpkg: error processing mousetweaks (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python-gnomeapplet:
python-gnomeapplet depends on libbonoboui2-0 (>= 2.15.1); however:
Package libbonoboui2-0 is not configured yet.
python-gnomeapplet depends on libgnome2-0 (>= 2.17.3); however:
Package libgnome2-0 is not configured yet.
python-gnomeapplet depends on libgnomeui-0 (>= 2.22.0); however:
Package libgnomeui-0 is not configured yet.
python-gnomeapplet depends on libpanel-applet2-0 (>= 2.26.0); however:
Package libpanel-applet2-0 is not configured yet.
dpkg: error processing python-gnomeapplet (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of screen-resolution-extra:
screen-resolution-extra depends on policykit-1; however:
Package policykit-1 is not configured yet.
dpkg: error processing screen-resolution-extra (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Errors were encountered while processing:
policykit-1
policykit-1-gnome
gvfs
libgnome2-0
libbonoboui2-0
libpanel-applet2-0
nautilus
gnome-session-bin
ubuntu-system-service
gnome-control-center
libgnomeui-0
python-gnome2
gnome-about
gnome-panel
gnome-session
gnome-applets
gdm
gvfs-backends
indicator-applet
mousetweaks
python-gnomeapplet
screen-resolution-extra
E: Sub-process /usr/bin/dpkg returned an error code (1)
回复

回到 “虚拟机和虚拟化”