第一次用VirtualBox,无缝模式和我想像的有点不一样

Kvm、VMware、Virtualbox、Xen、Qemu 等
回复
头像
kashu
帖子: 451
注册时间: 2014-02-07 17:31
系统: Xubuntu 14.04.5 64位
送出感谢: 37 次
接收感谢: 26 次

第一次用VirtualBox,无缝模式和我想像的有点不一样

#1

帖子 kashu » 2016-03-29 6:52

如果不是把Guest系统的分辨率改成和Host的一样的话,切换到无缝模式时很难看。

当我把虚拟机和物理机的分辨率改成一样时,上面会有一条杠,底下会有任务条(虽然可以设置为自动隐藏任务条,但隐藏后任务条就调不出来了,上面的杠依然存在)
还有个很严重的问题,分辨率改成和物理系统一样时,Super + L 退出无缝模式时,一输入密码登陆虚拟机时,又返回到无缝模式了,也就是无法从无缝模式切换回正常模式了。

还有个更怪异的现象:为了摆脱无缝模式并返回到正常模式,我不得不重启虚拟机,但当我重新启动虚拟机并进入虚拟系统后,Virtualbox又自动切换到无缝模式了。基本就没法用了。

Virtualbox版本:
kashu:~$ dpkg -s virtualbox-5.0 | grep Version
Version: 5.0.16-105871~Ubuntu~trusty

物理机:Xubuntu 14.04.4 LTS 64-bit

虚拟机:Win 8.1 Enterprise

图片

你们用的时候,也是这样的吗?
有没有更好一点玩法/技巧?
上次由 kashu 在 2016-03-29 7:38,总共编辑 1 次。


OS: Xubuntu 14.04.5 LTS 64-bit
CPU: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
RAM: 12GB DDR3 1333MHz
128GB SSD + 2TB HDD
神舟优雅A480B-I5B 购于 2012.08

YouTube频道:https://www.youtube.com/channel/UCGSPXZ ... DuDYX8L6Qg
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1955 次

Re: 第一次用VirtualBox,无缝模式和我想像的有点不一样

#2

帖子 poloshiao » 2016-03-29 7:30

切换到无缝模式
如果不是把Guest系统的分辨率改成和Host的一样的话,切换到无缝模式时很难看。
当我把虚拟机和物理机的分辨率改成一样时
先理解 无缝模式 的設計與用途
http://www.virtualbox.org/manual/ch04.h ... esswindows
Seamless windows

With the "seamless windows" feature of VirtualBox, you can have the windows that are displayed within a virtual machine appear side by side next to the windows of your host.

After seamless windows are enabled (see below), VirtualBox suppresses the display of the Desktop background of your guest, allowing you to run the windows of your guest operating system seamlessly next to the windows of your host:

不是用來放在上面一層
这些用户感谢了作者 poloshiao 于这个帖子:
kashu (2016-03-29 7:36)
评价: 3.7%
头像
kashu
帖子: 451
注册时间: 2014-02-07 17:31
系统: Xubuntu 14.04.5 64位
送出感谢: 37 次
接收感谢: 26 次

Re: 第一次用VirtualBox,无缝模式和我想像的有点不一样

#3

帖子 kashu » 2016-03-29 7:34

poloshiao 写了: With the "seamless windows" feature of VirtualBox, you can have the windows that are displayed within a virtual machine appear side by side next to the windows of your host.

After seamless windows are enabled (see below), VirtualBox suppresses the display of the Desktop background of your guest, allowing you to run the windows of your guest operating system seamlessly next to the windows of your host:

不是用來放在上面一層

哦,谢谢,明白了

但,那个无缝模式很难退出(或取消)的问题,还是困扰着我。
我现在是通过切换到Full mode,然后再退出full mode,这样我才能真的退出seamless mode。

是我哪里操作有问题吗?或者有什么更好的方法?

刚刚试了下,seamless mode的最佳使用效果:还是把虚拟机的分辨率改成和物理机的一样,用起来挺好的
这样用起来的感觉,真的非常像是Xubuntu和Win 8.1完全融合在了一起,这感觉好gelivable(开启双向粘贴板、文件拖拽……)。
图片
:Haha


OS: Xubuntu 14.04.5 LTS 64-bit
CPU: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
RAM: 12GB DDR3 1333MHz
128GB SSD + 2TB HDD
神舟优雅A480B-I5B 购于 2012.08

YouTube频道:https://www.youtube.com/channel/UCGSPXZ ... DuDYX8L6Qg
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1955 次

Re: 第一次用VirtualBox,无缝模式和我想像的有点不一样

#4

帖子 poloshiao » 2016-03-29 9:45

但,那个无缝模式很难退出(或取消)的问题,还是困扰着我。
我现在是通过切换到Full mode,然后再退出full mode,这样我才能真的退出seamless mode。
是我哪里操作有问题吗?或者有什么更好的方法?
方法一
右邊的 ctrl + L 鍵
方法二
click the View menu and select Switch to Seamless Mode
參見
http://www.howtogeek.com/171145/use-vir ... l-machine/
这些用户感谢了作者 poloshiao 于这个帖子:
kashu (2016-03-29 10:06)
评价: 3.7%
头像
kashu
帖子: 451
注册时间: 2014-02-07 17:31
系统: Xubuntu 14.04.5 64位
送出感谢: 37 次
接收感谢: 26 次

Re: 第一次用VirtualBox,无缝模式和我想像的有点不一样

#6

帖子 kashu » 2016-03-29 23:17

photor 写了::em09


看你发了这么多的表情……

图片


OS: Xubuntu 14.04.5 LTS 64-bit
CPU: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
RAM: 12GB DDR3 1333MHz
128GB SSD + 2TB HDD
神舟优雅A480B-I5B 购于 2012.08

YouTube频道:https://www.youtube.com/channel/UCGSPXZ ... DuDYX8L6Qg
头像
daf3707
论坛版主
帖子: 12678
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: 第一次用VirtualBox,无缝模式和我想像的有点不一样

#7

帖子 daf3707 » 2016-04-14 17:16

安装增强工具就可以自动调分辨率的吧。无缝模式时不好退出是因为此时焦点不在虚拟机上,点一下虚拟机里的任意窗口,再按快捷键就好了

通过我的 H30-U10 上的 Tapatalk发言
回复

回到 “虚拟机和虚拟化”