firefox中文缩进

上网、浏览、聊天、下载等
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#16

帖子 yongyi » 2005-07-21 14:32

哦。那是因为你用了simsun,并且没打开AA吧。
我没FF,所以不敢说我用FF显示也没问题。

并且我的字不是simsun,而是vera sans yuanti,我也没打开AA。

还有,LCD打开AA不是更好看些吗?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#17

帖子 zwz » 2005-07-21 14:50

补充一点,在zh_CN.UTF-8环境下,我也没有这个问题。在zh_CN.UTF-8环境下,除了字符不缺失外,四个“ ”字符的宽度也正好是两个汉字字符的宽度。
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#18

帖子 zwz » 2005-07-21 14:52

AA会使simsun字体难以接受的模糊。
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#19

帖子 yongyi » 2005-07-21 14:56

zwz 写了:AA会使simsun字体难以接受的模糊。
没那么模糊吧?
你用gnome的吧?去字体那里组合一下字体渲染罗。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#20

帖子 zwz » 2005-07-21 15:13

没那么模糊吧?
你用gnome的吧?去字体那里组合一下字体渲染罗。
比较一下,一看便知:

图片

图片
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#21

帖子 zwz » 2005-07-21 15:42

总结一下,这个firefox首行缩进导致首行字符缺失的问题在如下情况下可重现:

1. 只有在en_US.UTF-8环境下才会碰到这个问题;而在zh_CN.UTF-8环境下没有此问题。
2. 首行用几个" "字符缩进。
3. Ubuntu提供的firefox;Mozilla提供的安装包没有此问题。
4. 中文字符使用simsun.ttf(来自win2k)或simsun.ttc(来自winxp)。
5. 禁用对simsun的Anti-Aliasing。
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#22

帖子 zwz » 2005-07-21 15:59

在zh_CN.UTF-8下,同样有首行字符缺失的问题,只是我提供的test.html无法重现此问题。
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#23

帖子 zwz » 2005-07-21 16:18

请各位使用simsun字体的朋友用Ubuntu 5.04中的firefox试着打开这个页面http://xz.bokee.com/97/2005-07-21/29061.html,看看是否有首行字符缺失的问题。谢谢!
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#24

帖子 lyreopera » 2005-07-21 17:27

zwz 写了:先把图片上传到你自己的Web服务器上,然后用phpBB的[img]标签标记URL。

代码: 全选

[img]http://web.zhmail.com/ubuntu-firefox-chinese-indent/firefox-chinese-indent.png[/img]

怎么我上次不行di??

难道是rp……
……
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#25

帖子 zwz » 2005-07-21 20:00

进一步试验发现,不管使用哪一套汉字字体,只用禁用Anti-Aliasing,mozilla-firefox-1.0.2-0ubuntu*都会出现段落首行缺字的现象。我可以肯定这是Ubuntu 5.04缺省安装的可复制的问题。不知哪位是否可以指出问题出在哪里?libxft2?

没有碰到此问题的朋友,安装过哪些第三方的升级软件包?

在Ubuntu 5.04上运行从Mozilla网站下载的firefox二进制包,不管是1.0.6,还是1.0.2,都没有这个问题。
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#26

帖子 zwz » 2005-07-21 20:46

我向bugzilla.ubuntu.com报告了一个BUG:
https://bugzilla.ubuntu.com/show_bug.cgi?id=12851
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#27

帖子 zwz » 2005-07-26 9:54

今天发布的安全更新mozilla-firefox-1.0.6-0ubuntu0.1仍然有这个BUG。
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#28

帖子 yongyi » 2005-07-26 11:01

zwz 写了:今天发布的安全更新mozilla-firefox-1.0.6-0ubuntu0.1仍然有这个BUG。
hoary有这更新吗?我的系统怎么没发现?是breezy吧?
我直接下载安装firefox-1.0.6中文版,在系统设置为单色时,字符仍会破碎呀。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#29

帖子 zwz » 2005-07-26 11:07

的确是hoary-security:
http://www.ubuntulinux.org/support/docu ... /usn-149-2

用Mozilla官方发布的安装程序我这儿字体不会“破碎”。我发现往往和" "或"& # 160;”有关。
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#30

帖子 yongyi » 2005-07-26 11:16

这个今早我也看了一下,没留意是哪个版本的。原来是hoary,那可纳闷了,怎么源里还没更新的?还没同步?

我昨天安装的FF1.0.6,直接官方的installer,但感觉破碎现象比以前hoary的1.0.4更严重。
以前访问这里,多数只有下面的这些字(E文)会破碎
Powered by phpBB © 2001, 2005 phpBB Group
phpBB中文开发小组提供技术支持
51YES网站统计系统
现在倒好,在帖子列表中的标题部分都会破碎(中&E文),有是得选中它才看到。还有,在linuxsir发帖子时也会出现破碎(刚打的字显示空白,选中又会出来)
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
回复

回到 “互联网相关软件”