firefox中文缩进

上网、浏览、聊天、下载等
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#31

帖子 zwz » 2005-07-26 11:23

我用Mozilla基金会发布的英文版二进制包firefox-1.0.6,不会出现首行汉字丢失现象。

$ wget ftp://ftp.mozilla.org/pub/mozilla.org/f ... 0.6.tar.gz
$ tar zxvf firefox-1.0.6.tar.gz
$ firefox/firefox

你在试用时,是否确定已经重启过firefox?
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#32

帖子 yongyi » 2005-07-26 11:44

哦。你还说你那个测试页面吗?这个页面倒是无论1.0.4或我现用的1.0.6都是没问题的,像一叶兄的图一样。问题是你的1.0.6会不会出现我上一贴说的字符破碎现象呢?这个我感兴趣:wink:

哦,你用二进制包,我是直接使用firefox-1.0.6.installer.tar.gz的。好的,我稍后会试试你的那个。

我是昨天装的1.0.6,你说,我重启了firefox了没?BTW,我的机只是家庭应用。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#33

帖子 zwz » 2005-07-26 12:21

yongyi 写了:哦。你还说你那个测试页面吗?这个页面倒是无论1.0.4或我现用的1.0.6都是没问题的,像一叶兄的图一样。问题是你的1.0.6会不会出现我上一贴说的字符破碎现象呢?这个我感兴趣:wink:
不会出现我说的汉字缺失现象;看你的帖子没有问题;用ubuntu带的firefox好像也没问题(注意:我只禁用了汉字的AA)。我不知道你说的字符破碎怎么造成的。但我怀疑我碰到的现象和" "的处理有关。
我是昨天装的1.0.6,你说,我重启了firefox了没?BTW,我的机只是家庭应用。
如果你安装了Mozilla官方发布的版本仍然碰到汉字缺失现象,我怀疑你并未真正重启firefox。firefox-1.0.6.tar.gz和firefox-installer-1.0.6.tar.gz里面的二进制程序应该是一模一样的。
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#34

帖子 yongyi » 2005-07-26 12:58

zwz 写了:
yongyi 写了:哦。你还说你那个测试页面吗?这个页面倒是无论1.0.4或我现用的1.0.6都是没问题的,像一叶兄的图一样。问题是你的1.0.6会不会出现我上一贴说的字符破碎现象呢?这个我感兴趣:wink:
不会出现我说的汉字缺失现象;看你的帖子没有问题;用ubuntu带的firefox好像也没问题(注意:我只禁用了汉字的AA)。我不知道你说的字符破碎怎么造成的。但我怀疑我碰到的现象和" "的处理有关。
我想对这问题,我跟你这样跟帖下去没结果的。根本就搞不清楚是哪里的问题。
zwz 写了:
我是昨天装的1.0.6,你说,我重启了firefox了没?BTW,我的机只是家庭应用。
如果你安装了Mozilla官方发布的版本仍然碰到汉字缺失现象,我怀疑你并未真正重启firefox。firefox-1.0.6.tar.gz和firefox-installer-1.0.6.tar.gz里面的二进制程序应该是一模一样的。
这可真得请教一下,怎么才算是真正重启firefox呢?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#35

帖子 zwz » 2005-07-26 13:09

这可真得请教一下,怎么才算是真正重启firefox呢?
1)关闭所有Firefox窗口;2)用ps命令确认系统里已经没有firefox进程;3)启动Firefox。
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#36

帖子 zwz » 2005-07-26 13:12

我的BUG Report里面有详细的重现此问题的步骤。你有两个选择:

1)按照我的步骤,确认此问题可复制;

2)你提交一个报告,告诉别人怎么重现你的问题。
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#37

帖子 yongyi » 2005-07-26 13:24

1)关闭所有Firefox窗口;2)用ps命令确认系统里已经没有firefox进程;3)启动Firefox。
这ps和kill我还是懂的,虽然我没做。但是,我再说一次,我的电脑是家庭应用(意思是说不会整夜开机),我是昨天安装的,今天问题依然。难道这firefox的线程能不带电工作?
2)你提交一个报告,告诉别人怎么重现你的问题。
我觉得先要明白究竟该向哪里报bug。这字在单色情况下破碎,而在最佳形像下不破碎,就可能是跟字体渲染有关了。而linux下的字体渲染由哪些程式控制的(我不知道),就该向这些程式的开发者提bug。

个人愚见 :wink:
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#38

帖子 zwz » 2005-07-26 13:27

我想对这问题,我跟你这样跟帖下去没结果的。根本就搞不清楚是哪里的问题。
抱歉,刚才没有好好回复你这句有趣的话。

你有三个选择:

1)按照我的步骤,确认此问题可复制;
2)你提交一个报告,告诉别人怎么重现你的问题;
3)不用理会我的帖子。
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#39

帖子 zwz » 2005-07-26 13:41

这ps和kill我还是懂的,虽然我没做。但是,我再说一次,我的电脑是家庭应用(意思是说不会整夜开机),我是昨天安装的,今天问题依然。难道这firefox的线程能不带电工作?
你最好去学学网上的礼仪!我提醒你是否真正重启过Firefox,只是因为如果你没有关闭旧进程,即便你运行了新安装的版本,你仍然在使用旧版本。只是善意提醒,根本没有其他意思。你扯这么远干嘛?
我觉得先要明白究竟该向哪里报bug。这字在单色情况下破碎,而在最佳形像下不破碎,就可能是跟字体渲染有关了。而linux下的字体渲染由哪些程式控制的(我不知道),就该向这些程式的开发者提bug。
我在Ubuntu 5.04 i386上使用Ubuntu版本的firefox build时碰到这个汉字缺失的问题,而其他操作系统或其他firefox build都没有这个问题,我当然应该向Ubuntu报告。
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#40

帖子 yongyi » 2005-07-26 19:09

zwz 写了:你最好去学学网上的礼仪!我提醒你是否真正重启过Firefox,只是因为如果你没有关闭旧进程,即便你运行了新安装的版本,你仍然在使用旧版本。只是善意提醒,根本没有其他意思。你扯这么远干嘛?
:shock:
非常抱歉!
我闪!
——学网上礼仪!
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#41

帖子 zwz » 2005-07-26 19:37

补充几点:
1)在zh_CN.UTF-8环境下,我提供的测试页面http://web.zhmail.com/ubuntu-firefox-ch ... /test.html显示正常;在en_US.UTF-8环境下,显示不正常,缩进4个全角字宽,但“缩进四个”四个汉字缺失。
2)我提供的另一个测试页面http://xz.bokee.com/97/2005-07-21/29061.html不管在哪个语言环境下都不正常,表现为段落首行字符缺失。
3)关于如何重现此问题,详见https://bugzilla.ubuntu.com/show_bug.cgi?id=12851
road
帖子: 148
注册时间: 2005-04-01 15:10
来自: 浙江
送出感谢: 0
接收感谢: 0

#42

帖子 road » 2005-07-26 21:13

我的正常,第二种
zwz
帖子: 31
注册时间: 2005-07-21 10:59
送出感谢: 0
接收感谢: 0

#43

帖子 zwz » 2005-07-26 22:48

哪个第二种?你是否禁用了汉字的Anti-Aliasing,或者使用所谓单色的字体渲染方式?

我反复做过测试,按照https://bugzilla.ubuntu.com/show_bug.cgi?id=12851里的步骤是百分之百可重现此问题的。
回复

回到 “互联网相关软件”