分页: 4 / 11

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-21 15:34
john.wu
happyaron 写了:3903这个build似乎有问题啊:
http://launchpadlibrarian.net/34089850/ ... ILD.txt.gz

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-21 17:08
midoriumi
我不太清楚launchpad上面的build过程,不过从出错信息来看似乎是wxWidgets库的错误
我在一台AMD64的机器上用打好补丁的源码包编译没出问题
回学校后有时间再慢慢研究到底是怎么回事

-------

发现问题所在了,build日志中有
g++ -DHAVE_CONFIG_H -I. -I../../src -I.. -DUSE_WX_EXTENSIONS -I/usr/include/upnp -DENABLE_UPNP=1 -pthread -I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -DENABLE_IP2COUNTRY=1 -I../../src/libs -Ilibs -I../../src/include -I/usr/include -D__WEAK_CRYPTO__ -W -Wall -Wshadow -Wundef -pthread -Wall -g -O2 -c -o amule-UploadQueue.o `test -f 'UploadQueue.cpp' || echo '../../src/'`UploadQueue.cpp
../../src/UploadQueue.cpp:26:25: error: antiLeech.cpp: No such file or directory
In file included from /usr/include/wx-2.8/wx/clntdata.h:17,
from /usr/include/wx-2.8/wx/event.h:18,
from /usr/include/wx-2.8/wx/socket.h:23,
from ../../src/NetworkFunctions.h:31,
from ../../src/amuleIPV4Address.h:31,
from ../../src/ServerConnect.h:34,
from ../../src/UploadQueue.cpp:47:

打补丁的时候出错了?

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-21 17:48
happyaron
已经解决了,跟一个debian补丁撞车了。

Re: 让aMule支持DLP的源码补丁

发表于 : 2009-10-22 20:30
aoki的梦想
happyaron 写了:我来放一个DEB吧,我的PPA里:
https://edge.launchpad.net/~happyaron/+archive/ppa
需要的就用用吧,用的是官方代码+LZ的DLP补丁,软件名稍微改了一下叫amule-dlp${blah},安装这个会自动卸载原来的amule${blah}。
有9.04的和9.10的。

好像没有,能再发一次么

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-22 20:33
xrb2007
:em09 还是喜欢直接打包好的安装包。

Re: 让aMule支持DLP的源码补丁

发表于 : 2009-10-22 21:16
john.wu
aoki的梦想 写了:
happyaron 写了:我来放一个DEB吧,我的PPA里:
https://edge.launchpad.net/~happyaron/+archive/ppa
需要的就用用吧,用的是官方代码+LZ的DLP补丁,软件名稍微改了一下叫amule-dlp${blah},安装这个会自动卸载原来的amule${blah}。
有9.04的和9.10的。

好像没有,能再发一次么
ppa源的地址更新了,原来的已经删除

viewtopic.php?f=95&t=233117

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-23 16:27
aoki的梦想
:em01 非常感谢阿~~~

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-24 0:52
loopwater
Initialising aMule 2.2.6 using wxGTK2 v2.8.9
Checking if there is an instance already running...
No other instances are running.
ListenSocket: Ok.
HTTP download thread started
Loading temp files from /media/exchange/Temp.

All PartFiles Loaded.
No shareable files found in directory: /mnt
Host: amule.sourceforge.net:80
URL: http://amule.sourceforge.net/lastversion
Response: 200 (Error: 0)
Download size: 6
HTTP download thread ended
Server hostname notified

3901升级到3903之后KAD网络没有连接,怎么解决?谢谢!
** (amule:31677): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

** (amule:31677): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

** (amule:31677): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

** (amule:31677): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

** (amule:31677): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-24 23:13
midoriumi
KAD没有连接应该和DLP没有关系,试试重新引导 KAD网络

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-25 12:25
loopwater
连接不上KAD,只好退回3901

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-26 15:59
lovekid
源里的amule有补丁吗?我发现用源里的amule下载的时候也封杀的!

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-26 17:24
食古不化
是否能考虑把补丁提供给官方呢?

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-31 11:00
arvan
看到此物,让我不得不顶啊。

以后终于可以不用看到吸血驴了。 :em11 :em11

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-31 20:18
Bill Lee
我之前还一直纳闷呢,eMule Xtreme Mod和aMule都是开源的,怎么就没人把DLP移植过来
不过毕竟还是有高手想到这个问题的。
建议楼主做个deb包吧,毕竟,不是大家都会编译的

Re: 让aMule支持DLP的源码补丁(更新至3903)

发表于 : 2009-10-31 20:26
mymathersname
哈哈,第一个版本的aMule插件出来了,谢谢楼主啦……