amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

上网、浏览、聊天、下载等
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: amule-dlp 开发动态(更新 DLP4401)

#196

帖子 Bill Lee » 2011-07-14 0:33

Lavande, aur 很久没有人维护了,原来维护的人也说了他不再维护,有兴趣的自己去弄吧
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: amule-dlp 开发动态(更新 DLP4401)

#197

帖子 Bill Lee » 2011-07-14 0:58

大家好!好久没有在这里出现了。
最近准备对 dlp 的代码进行模块化,结果被 autoconf 搞的焦头烂额。 aMule 论坛上的人说 aMule 2.2.6 的代码和现在的 autoconf 已经不兼容了,接下来我会把开发重点转到 aMule-2.3.1rc1. 以后 aMule-2.2.6 的 DLP 准备按以下方式维护:
  1. 不再添加新功能
  2. upstream-bugfix 和 dynamic-load 分支不再维护
  3. 静态版本的 antiLeech.cpp 和 antiLeech 动态库继续跟随上游更新
  4. antiLeech 动态库的 API 保持不变,可以兼容 2.2.6 和 2.3.1 两个版本
aMule-2.3.1rc1 的迁移工作现在还在开始阶段,静态版本的迁移已经基本完成,可以使用,在 Google Code 上可以找到补丁,但我打算把动态加载版本作为 aMule-2.3.1 的主要开发版本,静态版本应该不会继续开发(包括未完成 forwardport 的部分),只更新 antiLeech.cpp, 供动态加载版本稳定前过渡使用。
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#198

帖子 Bill Lee » 2011-07-14 1:09

另外问大家一个问题, happyaron 的 PPA 有没有更新?最新版本是不是 DLP4401. 好像好久没在 irc 上看到他了。
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
Recko
帖子: 8
注册时间: 2010-08-14 2:22
送出感谢: 0
接收感谢: 0

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#199

帖子 Recko » 2011-07-20 19:19

前两天看到的是DLP4302。我去Google Code上提取antiLeech的代码,找不到源 https//antileech.amule-dlp.googlecode.com/hg/
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#200

帖子 Bill Lee » 2011-07-21 11:57

Recko, DLP4401 已经出了几个月了
:em06
注意源是 https://antileech.amule-dlp.googlecode.com/hg/
如果这个不能用,就换 http://antileech.amule-dlp.googlecode.com/hg/ ,可能是防火长城的影响。
注意最新版本的 antiLeech 代码是配合 forwardport-2.3.1rc1-dl-modularize 分支的,如果要配合 aMule 2.2.6 使用,请手工在 /usr/lib/antiLeech.so 建立到 $(prefix)/share/aMule/libantiLeech.so 的符号链接,或者使用上一版本的 antiLeech.
如果想要稳定版本还是用 default 分支的静态链接版本(虽然动态版本现在也已经很稳定了,但是部署相对麻烦),default 分支有 PPA 可用。
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
长头发的和尚
论坛版主
帖子: 12127
注册时间: 2008-01-11 17:02
送出感谢: 0
接收感谢: 4 次

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#201

帖子 长头发的和尚 » 2011-07-21 12:01

支持,可惜arch下没人维护了
你往幸福的方向挥挥手,从此我便追随你永不回头。
头像
lxr1234
帖子: 721
注册时间: 2009-04-10 11:15
来自: 三民主义国国民权利省我的选择市中共下台镇
送出感谢: 0
接收感谢: 14 次

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#202

帖子 lxr1234 » 2011-07-23 20:20

该更新了
强烈反对M$的ARM Secure Boot 锁定要求,大家请签名反对
http://www.fsf.org/campaigns/secure-boo ... cted-boot/
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#203

帖子 Bill Lee » 2011-07-24 8:22

lxr1234, 什么该更新了? sourceforg.net 上还是 antiLeech v44 呀?
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
头像
lxr1234
帖子: 721
注册时间: 2009-04-10 11:15
来自: 三民主义国国民权利省我的选择市中共下台镇
送出感谢: 0
接收感谢: 14 次

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#204

帖子 lxr1234 » 2011-07-24 19:09

amule原版都到几了,
用dlp会突然cpu暴走(1/8机率)
强烈反对M$的ARM Secure Boot 锁定要求,大家请签名反对
http://www.fsf.org/campaigns/secure-boo ... cted-boot/
persmule
帖子: 8
注册时间: 2011-02-12 17:40
送出感谢: 0
接收感谢: 0

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#205

帖子 persmule » 2011-07-24 21:10

我用develop分支无任何问题。
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#206

帖子 Bill Lee » 2011-07-25 13:58

lxr1234, amule.org 上还是更新到 aMule 2.3.1rc1 呀,CPU 占用率高于原版是正常的,毕竟 DLP 检测代码这么大,但“暴走”还没遇到过,已知 aMule 2.3.1rc1 (原版和 dlp 版)关闭的时候会占用很多 CPU 时间,并且要很久才能完成关闭)
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
头像
rabbit_52
帖子: 140
注册时间: 2010-05-09 9:03
送出感谢: 1 次
接收感谢: 1 次
联系:

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#207

帖子 rabbit_52 » 2011-07-30 16:22

Recko 写了:前两天看到的是DLP4302。我去Google Code上提取antiLeech的代码,找不到源 https//antileech.amule-dlp.googlecode.com/hg/
链接缺一个冒号~
Blog
注册Dropbox!同涨空间 ^_^
头像
rabbit_52
帖子: 140
注册时间: 2010-05-09 9:03
送出感谢: 1 次
接收感谢: 1 次
联系:

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#208

帖子 rabbit_52 » 2011-07-30 16:24

Bill Lee 写了:lxr1234, amule.org 上还是更新到 aMule 2.3.1rc1 呀,CPU 占用率高于原版是正常的,毕竟 DLP 检测代码这么大,但“暴走”还没遇到过,已知 aMule 2.3.1rc1 (原版和 dlp 版)关闭的时候会占用很多 CPU 时间,并且要很久才能完成关闭)
2.3.1的补丁不会打呀,找了些方法,照做类全是failed~您也给整一个打补丁的小白教程嘛
Blog
注册Dropbox!同涨空间 ^_^
persmule
帖子: 8
注册时间: 2011-02-12 17:40
送出感谢: 0
接收感谢: 0

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#209

帖子 persmule » 2011-08-03 22:54

rabbit_52 写了:
Bill Lee 写了:lxr1234, amule.org 上还是更新到 aMule 2.3.1rc1 呀,CPU 占用率高于原版是正常的,毕竟 DLP 检测代码这么大,但“暴走”还没遇到过,已知 aMule 2.3.1rc1 (原版和 dlp 版)关闭的时候会占用很多 CPU 时间,并且要很久才能完成关闭)
2.3.1的补丁不会打呀,找了些方法,照做类全是failed~您也给整一个打补丁的小白教程嘛
仿照http://code.google.com/p/amule-dlp/wiki/DynamicLoading中介绍的方法去下载develop分支(代替文中的dynamic-load分支)吧,再将编译好的libantiLeech.so放在$HOME/.aMule就可以用了。
Bill Lee
帖子: 598
注册时间: 2009-09-19 20:50
送出感谢: 0
接收感谢: 2 次

Re: amule-dlp 开发动态(开发重点转向 aMule-2.3.1rc1)

#210

帖子 Bill Lee » 2011-08-04 13:12

rabbit_52, 那个补丁是要打在原版的 aMule-2.3.1rc1 上。那个是静态版本的 forwardport, 不再支持。现在版本仓库里的 develop 分支就是 2.3.1rc1 的动态版本。
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记
回复

回到 “因特网相关软件”