分页: 16 / 17

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-04-07 17:40
xzc8825745
aMule-dlp2.3.1正式版还没有出来。好慢呀。

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-04-08 13:40
momova
xzc8825745 写了:aMule-dlp2.3.1正式版还没有出来。好慢呀。
有用的就让自己觉得幸福吧,我的arch都安装不上……

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-05-25 19:24
cxbii
真心感谢开发者了! :em11

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-06-23 18:30
huow005
fedora 17 下编译取出的 aMule-dlp 错误, 无法完成. 从 amule-2.3.1-2.fc17.src.rpm 找到 aMule-2.3.1-gcc47.patch, 内容如下

diff -up aMule-2.3.1/src/ObservableQueue.h.gcc47 aMule-2.3.1/src/ObservableQueue.h
--- aMule-2.3.1/src/ObservableQueue.h.gcc47 2011-06-13 10:50:25.000000000 +0200
+++ aMule-2.3.1/src/ObservableQueue.h 2012-05-13 19:20:12.019301155 +0200
@@ -331,14 +331,14 @@ CObservableQueue<ValueType>::~CObservabl
template <typename ValueType>
void CObservableQueue<ValueType>::ObserverAdded( ObserverType* o )
{
- NotifyObservers( EventType( EventType::STARTING ), o );
+ this->NotifyObservers( EventType( EventType::STARTING ), o );
}


template <typename ValueType>
void CObservableQueue<ValueType>::ObserverRemoved( ObserverType* o )
{
- NotifyObservers( EventType( EventType::STOPPING ), o );
+ this->NotifyObservers( EventType( EventType::STOPPING ), o );
}

编译通过.

从版本库中检出 dynamic-load 分支。
hg update dynamic-load
编译通不过. 只开发分支可以通过. 安装好的仍然是 2.2.6, 不是 2.3.1

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-07-18 19:19
detroy
2.26接着用,不着急 :em03

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-08-11 17:59
heartflying
想要2.3.1正是版啊

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-08-18 13:52
yazi_beicheng

代码: 全选

Linking alcc
Compiling AsyncDNS.cpp
Compiling DeadSourceList.cpp
Compiling FileArea.cpp
Compiling FileAutoClose.cpp
Compiling IPFilterScanner.cpp
Generating Scanner.cpp
Compiling Scanner.cpp
Scanner.cpp: 在函数‘int yy_get_next_buffer()’中:
Scanner.cpp:1234:30: 错误:将类型为‘int&’的引用初始化为类型为‘yy_size_t {aka unsigned int}’的表达式无效
./Scanner.l:28:13: 错误:在传递‘void ReadLexBuff(char*, int&, size_t)’的第 2 个实参时
make[3]: *** [libmuleappcore_a-Scanner.o] 错误 1
make[2]: *** [all-recursive] 错误 1
make[1]: *** [all-recursive] 错误 1
make: *** [all] 错误 2
==> 错误: 在 build() 中发生一个错误。
    正在放弃...
==> ERROR: Makepkg was unable to build amule-dlp.
这是怎么一个情况?? 源代码有错误? archlinux环境下 求解阿

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-08-19 13:49
lxr1234

代码: 全选

./configure: line 8613: syntax error near unexpected token `{'
./configure: line 8613: `fi             { $as_echo "$as_me:${as_lineno-$LINENO}: result: $result$resultstr" >&5'
现在连configure都不行了
不能做成补丁吗,不然还有装个hg,占资源阿

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-08-24 11:14
fnta
非常感谢楼主啊,每次看到屏蔽的那些吸血客户端,心中很有成就感~~~ :em01

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-09-19 13:33
qq472790741
楼上的,archlinux编译错误看这里,
https://bbs.archlinux.org/viewtopic.php?id=147265

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-09-19 13:37
qq472790741
如果出现了notifyobserver错误请看这里
https://aur.archlinux.org/packages.php?ID=2227

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2012-10-31 10:18
zhaoawd
configure: WARNING: unrecognized options: --enable-mmap
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking if this is a FreeBSD 4 or earlier system... no
checking for g++... g++
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for gawk... (cached) mawk
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking whether make sets $(MAKE)... (cached) yes
checking for flex... no
checking for lex... no
checking for ranlib... ranlib
checking for bison... bison -y
checking for ranlib... (cached) ranlib
checking for strip... strip
checking for ar... ar
checking for ld... ld
checking for zlib >= 1.1.4... yes (version 1.2.7)
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for gdlib-config... /usr/bin/gdlib-config
checking for gdlib version >= 2.0.0... yes (version 2.0.36)
checking gd.h usability... yes
checking gd.h presence... yes
checking for gd.h... yes
checking for File::Copy... ok
checking whether we need the GUI... yes
checking GeoIP.h usability... yes
checking GeoIP.h presence... yes
checking for GeoIP.h... yes
checking for GeoIP_open in -lGeoIP... yes
checking for the --with-toolkit option... will be automatically detected
checking for the --with-wxshared option... will be automatically detected
checking for the --with-wxdebug option... will be automatically detected
checking for the --with-wxversion option... will be automatically detected
checking for wx-config... /usr/bin/wx-config
checking for wxWidgets version >= 2.8.0 (--unicode=yes)... yes (version 2.8.12)
checking for wxWidgets static library... no
checking if wxWidgets was built in DEBUG mode... no
checking if wxWidgets was built in STATIC mode... no
checking which wxWidgets toolkit was selected... gtk2
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
./configure: line 8613: syntax error near unexpected token `{'
./configure: line 8613: `fi { $as_echo "$as_me:${as_lineno-$LINENO}: result: $result$resultstr" >&5'
在配置./configure时出现这个错误,是怎么回事

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2013-01-18 17:29
kluma
楼主现在还开发吗?
amule现在已经出正式版了,项目主页上的amule-2.3.1rc1-DLP4401.patch能用到amule2.3.1正式版上吗?

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2013-09-11 21:16
haime
这东西估计LZ自己都忘了,或者没有时间理……

Re: amule-dlp 开发动态(aMule-2.3.1 测试版本可用)

发表于 : 2013-10-21 12:51
ub36241189
当我发送 hg clone https://amule-dlp.googlecode.com/hg/ amule-dlp
反馈的信息是:
中止: 失败: Network is unreachable
求解答?