新的qq插件 pidgin-lwqq 0.4.0 更新

上网、浏览、聊天、下载等
回复
头像
Kuka
帖子: 433
注册时间: 2008-10-19 13:04
系统: Ubuntu 14.04
来自: 湖北省武汉市
送出感谢: 6 次
接收感谢: 5 次
联系:

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1156

帖子 Kuka » 2015-01-28 18:10

:em06 我和大家遭遇一样呢,用不了。
今天比昨天更有智慧,今天比昨天更慈悲,今天比昨天更懂得爱,今天比昨天更懂得生活美,今天比昨天更懂得宽容.
博客
G+
注册并安装Dropbox帮我扩容500M,请猛戳
孤草
帖子: 14
注册时间: 2007-06-01 22:49
送出感谢: 0
接收感谢: 1 次

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1157

帖子 孤草 » 2015-01-29 14:58

无法登录的问题解决啦, 刚提了pull request,着急的朋友自行改下代码编译安装吧。。。就改一个url参数。
https://github.com/EricInBj/lwqq/commit ... b8ab1f9e97
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 69 次
联系:

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1158

帖子 lainme » 2015-01-29 21:18

PPA更新了。只需要单独更新liblwqq0即可。
头像
gdgglhy
帖子: 440
注册时间: 2010-04-23 12:19
系统: arch
送出感谢: 6 次
接收感谢: 8 次

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1159

帖子 gdgglhy » 2015-01-29 21:42

:em11 arch的也更新了
jinjiachen
帖子: 2125
注册时间: 2012-12-16 15:43
系统: debian
送出感谢: 9 次
接收感谢: 27 次

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1160

帖子 jinjiachen » 2015-01-30 13:13

意思是又可以用了?还以为要挂了,哈哈 :em11
头像
xianpys
帖子: 7
注册时间: 2012-05-13 20:23
系统: Debian GNU/Linux
送出感谢: 0
接收感谢: 0

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1161

帖子 xianpys » 2015-02-01 0:34

Debian 8,安装后pidgin里找不到webqq的协议,这是怎么回事?
jinjiachen
帖子: 2125
注册时间: 2012-12-16 15:43
系统: debian
送出感谢: 9 次
接收感谢: 27 次

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1162

帖子 jinjiachen » 2015-02-01 20:36

xianpys 写了:Debian 8,安装后pidgin里找不到webqq的协议,这是怎么回事?
debian是要自己编译的,不要告诉我你只是安装了pidgin?
头像
xianpys
帖子: 7
注册时间: 2012-05-13 20:23
系统: Debian GNU/Linux
送出感谢: 0
接收感谢: 0

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1163

帖子 xianpys » 2015-02-01 21:41

jinjiachen 写了:
xianpys 写了:Debian 8,安装后pidgin里找不到webqq的协议,这是怎么回事?
debian是要自己编译的,不要告诉我你只是安装了pidgin?
编译安装了lwqq和pidgin-lwqq,没有出错。但是很奇怪dpkg -l找不到,打开pidgin也看不到webqq的协议
jinjiachen
帖子: 2125
注册时间: 2012-12-16 15:43
系统: debian
送出感谢: 9 次
接收感谢: 27 次

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1164

帖子 jinjiachen » 2015-02-02 8:34

xianpys 写了:
jinjiachen 写了:
xianpys 写了:Debian 8,安装后pidgin里找不到webqq的协议,这是怎么回事?
debian是要自己编译的,不要告诉我你只是安装了pidgin?
编译安装了lwqq和pidgin-lwqq,没有出错。但是很奇怪dpkg -l找不到,打开pidgin也看不到webqq的协议
那这个应该没问题啊,重新编译下
头像
xianpys
帖子: 7
注册时间: 2012-05-13 20:23
系统: Debian GNU/Linux
送出感谢: 0
接收感谢: 0

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1165

帖子 xianpys » 2015-02-02 10:23

jinjiachen 写了:
xianpys 写了:
jinjiachen 写了:
xianpys 写了:Debian 8,安装后pidgin里找不到webqq的协议,这是怎么回事?
debian是要自己编译的,不要告诉我你只是安装了pidgin?
编译安装了lwqq和pidgin-lwqq,没有出错。但是很奇怪dpkg -l找不到,打开pidgin也看不到webqq的协议
那这个应该没问题啊,重新编译下
我的操作是这样的,一路都没问题:
git clone -b dev https://github.com/xiehuc/lwqq.git
git clone -b dev https://github.com/xiehuc/pidgin-lwqq.git
cd lwqq/
mkdir build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
make
make install (这步用的root)
cd ../../pidgin-lwqq/
git submodule init
git submodule update
mkdir build
cd build
PKG_CONFIG_PATH=/usr/lib/pkgconfig/ cmake ..
PKG_CONFIG_PATH=/usr/lib/pkgconfig/ make
PKG_CONFIG_PATH=/usr/lib/pkgconfig/ make install (这步也是root)

make install的输出里也有:
-- Installing: /usr/lib/purple-2/libwebqq.so
行走之間
帖子: 108
注册时间: 2009-06-14 19:01
送出感谢: 0
接收感谢: 0

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1166

帖子 行走之間 » 2015-02-04 9:31

上周才更新了最新lwqq,昨晚開始又不能登錄 Webqq了,提示Unknow error。
头像
xianpys
帖子: 7
注册时间: 2012-05-13 20:23
系统: Debian GNU/Linux
送出感谢: 0
接收感谢: 0

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1167

帖子 xianpys » 2015-02-05 8:35

xianpys 写了:
jinjiachen 写了:
xianpys 写了:
jinjiachen 写了:
xianpys 写了:Debian 8,安装后pidgin里找不到webqq的协议,这是怎么回事?
debian是要自己编译的,不要告诉我你只是安装了pidgin?
编译安装了lwqq和pidgin-lwqq,没有出错。但是很奇怪dpkg -l找不到,打开pidgin也看不到webqq的协议
那这个应该没问题啊,重新编译下
我的操作是这样的,一路都没问题:



make install的输出里也有:
-- Installing: /usr/lib/purple-2/libwebqq.so
执行了如下命令后能找到协议了:
ln -sf /usr/local/lib/liblwqq.so.0 /usr/lib/liblwqq.so.0.4.1
不过还是登录不了,提示未知错误
孤草
帖子: 14
注册时间: 2007-06-01 22:49
送出感谢: 0
接收感谢: 1 次

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1168

帖子 孤草 » 2015-02-05 15:43

@xianpys
@行走之間

未知错误是因为web qq服务器返回了一个新的登录错误:
ptuiCB('71','0','','0','您的帐号由于异常禁止登录,请联系客服。(2009081021)', 'QQNUMBER');

lwqq之前没有处理这个错误,作为未知错误了。

多重试若干次之后就可以了。至于为什么会有这个错误还未知,也许是利用lwqq的登录行为和webqq不太一样判断出来的。(web qq本身经常有大大小小的更新,现在的lwqq有不少地方和web的不太一致,不过目前倒也还能用)
头像
xianpys
帖子: 7
注册时间: 2012-05-13 20:23
系统: Debian GNU/Linux
送出感谢: 0
接收感谢: 0

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1169

帖子 xianpys » 2015-02-05 20:44

孤草 写了:@xianpys
@行走之間

未知错误是因为web qq服务器返回了一个新的登录错误:
ptuiCB('71','0','','0','您的帐号由于异常禁止登录,请联系客服。(2009081021)', 'QQNUMBER');

lwqq之前没有处理这个错误,作为未知错误了。

多重试若干次之后就可以了。至于为什么会有这个错误还未知,也许是利用lwqq的登录行为和webqq不太一样判断出来的。(web qq本身经常有大大小小的更新,现在的lwqq有不少地方和web的不太一致,不过目前倒也还能用)
多谢,试了十多次果然登上了
孤草
帖子: 14
注册时间: 2007-06-01 22:49
送出感谢: 0
接收感谢: 1 次

Re: 新的qq插件 pidgin-lwqq 0.4.0 更新

#1170

帖子 孤草 » 2015-02-06 19:11

@xianpys

我折腾了一下午,找着了问题的原因,愿意折腾的话, 可以编译我改过的版本,不过改得恶心,暂时不打算提交
https://github.com/EricInBj/lwqq/
https://github.com/EricInBj/lwqq/commit ... 79b4041a3d

现在我这边几个号都可以一次性登录成功了。
:em05
回复

回到 “互联网相关软件”