分页: 1 / 1

安装opera出错如下,如何处理?请指教

发表于 : 2005-10-18 0:40
saman
saman@ubuntu:~$ sudo dpkg -i opera_8.50-20050916.6-shared-qt_en_etch_i386.deb
选中了曾被取消选择的软件包 opera。
(正在读取数据库 ... 系统当前总共安装有 61920 个文件和目录。)
正在解压缩 opera (从 opera_8.50-20050916.6-shared-qt_en_etch_i386.deb) ...
dpkg:依赖关系问题使得 opera 的配置工作不能继续:
opera 依赖于 xlib6g (>= 3.3.6) | xlibs;然而:
软件包 xlib6g还没有被安装。
软件包 xlibs还没有被安装。
opera 依赖于 libqt3-mt (>= 3.3.4) | libqt3c102-mt (>= 3.3.4);然而:
软件包 libqt3-mt还没有被安装。
软件包 libqt3c102-mt还没有被安装。
dpkg:处理 opera (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
opera

发表于 : 2005-10-18 0:43
eexpress
~$ sudo apt-get install xlib6g
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
现在没有可用的软件包 xlib6g,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
可是下列的软件包取代了它:
xlibs libxaw6-dbg libxaw6
E: 软件包 xlib6g 还没有可供安装的候选者

$ sudo apt-get install xlibs
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
xlibs 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 26 个软件未被升 级。

发表于 : 2005-10-18 1:14
saman
意思是装不了8.5了?

发表于 : 2005-10-18 1:16
yonsan
:o 去opera主站下个 static 版本的opera8.5 就没这么多问题了!
懒得只为了opera而装个qt3库!

发表于 : 2005-10-18 1:32
eexpress
他那个就是最新的包。
我以前下的2个包。不确定是否充分,但好像是必要。因为我放在一起。
libstdc++6_4.0.0-7ubuntu6~5.04ubp1_i386.deb
libstdc++6-dev_3.4.3-9ubuntu4_i386.deb

发表于 : 2006-02-07 22:41
saman
这个opera8.5我一直用到现在,就是无法在线mp3和wmv,不知楼上几位能否解决,opera确比firefox快啊