求助,gnome-tweak无法运行

上网、浏览、聊天、下载等
回复
yushu280
帖子: 8
注册时间: 2016-02-06 22:12
送出感谢: 0
接收感谢: 0

求助,gnome-tweak无法运行

#1

帖子 yushu280 » 2017-09-29 8:30

如题,点击无法运行,命令行提示错误:
GLib-GIO-ERROR **: Settings schema 'org.gnome.shell' does not contain a key named 'disable-user-extensions'
本人使用的是debian sid,gnome 22.3
求大神指点
上次由 yushu280 在 2017-09-29 16:57,总共编辑 3 次。
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: 求助,gnome-twea无法运行

#2

帖子 poloshiao » 2017-09-29 8:45

gnome-twea无法运行
1. gnome-tweak ?

2. 請提供 作業系統版本 及 登入桌面
因為提供的建議 可能不同
yushu280
帖子: 8
注册时间: 2016-02-06 22:12
送出感谢: 0
接收感谢: 0

Re: 求助,gnome-twea无法运行

#3

帖子 yushu280 » 2017-09-29 16:59

poloshiao 写了:
gnome-twea无法运行
1. gnome-tweak ?

2. 請提供 作業系統版本 及 登入桌面
因為提供的建議 可能不同

是debiansid,gnome22.3,请指点下
yushu280
帖子: 8
注册时间: 2016-02-06 22:12
送出感谢: 0
接收感谢: 0

Re: 求助,gnome-twea无法运行

#4

帖子 yushu280 » 2017-09-29 17:04

poloshiao 写了:
gnome-twea无法运行
1. gnome-tweak ?

2. 請提供 作業系統版本 及 登入桌面
因為提供的建議 可能不同
是debian sid ,gnome 22.3。请指点下
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: 求助,gnome-tweak无法运行

#5

帖子 poloshiao » 2017-09-29 17:42

是debian sid ,gnome 22.3。
1. 套件 gnome-tweak-tool
https://packages.debian.org/search?suit ... nome-tweak
sid (unstable) (gnome): tool to adjust advanced configuration settings for GNOME
3.25.91-1: all
1-1. https://packages.debian.org/sid/gnome-tweak-tool
套件: gnome-tweak-tool (3.25.91-1)
1-2. https://packages.debian.org/sid/all/gno ... l/filelist
在 sid 發行版中 all 硬體架構下的 gnome-tweak-tool 套件文件清單
/usr/bin/gnome-tweak-tool

2. 如果是非 root 使用者登入
alt + F2
gnome-tweak-tool
2-1. 如果需要使用 root 權限
alt + F2
gksudo gnome-tweak-tool
2-1-1. 第一次使用 gksudo 需要先安裝 gksu 套件
https://manpages.debian.org/unstable/gk ... .1.en.html
gksu - GTK+ frontend for su and sudo

3. 如果是 root 使用者登入
alt + F2
gksu gnome-tweak-tool
3-1. 第一次使用 gksu 需要先安裝 gksu 套件
https://manpages.debian.org/unstable/gk ... .1.en.html
gksu - GTK+ frontend for su and sudo
yushu280
帖子: 8
注册时间: 2016-02-06 22:12
送出感谢: 0
接收感谢: 0

Re: 求助,gnome-tweak无法运行

#6

帖子 yushu280 » 2017-09-29 19:29

poloshiao 写了:
是debian sid ,gnome 22.3。
1. 套件 gnome-tweak-tool
https://packages.debian.org/search?suit ... nome-tweak
sid (unstable) (gnome): tool to adjust advanced configuration settings for GNOME
3.25.91-1: all
1-1. https://packages.debian.org/sid/gnome-tweak-tool
套件: gnome-tweak-tool (3.25.91-1)
1-2. https://packages.debian.org/sid/all/gno ... l/filelist
在 sid 發行版中 all 硬體架構下的 gnome-tweak-tool 套件文件清單
/usr/bin/gnome-tweak-tool

2. 如果是非 root 使用者登入
alt + F2
gnome-tweak-tool
2-1. 如果需要使用 root 權限
alt + F2
gksudo gnome-tweak-tool
2-1-1. 第一次使用 gksudo 需要先安裝 gksu 套件
https://manpages.debian.org/unstable/gk ... .1.en.html
gksu - GTK+ frontend for su and sudo

3. 如果是 root 使用者登入
alt + F2
gksu gnome-tweak-tool
3-1. 第一次使用 gksu 需要先安裝 gksu 套件
https://manpages.debian.org/unstable/gk ... .1.en.html
gksu - GTK+ frontend for su and sudo
感谢你的回答,但没有用处。alt + F2与我点击软件图标,是一样的都没反应。我也试过sudo gnome-tweak-tool,是可以调出来软件,但某些设置是不完整的。还是没用,而终端中运行gnome-tweak-tool,则提示报错,就是我在问题中描述的报错
GLib-GIO-ERROR **: Settings schema 'org.gnome.shell' does not contain a key named 'disable-user-extensions'
不知怎么解决
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: 求助,gnome-tweak无法运行

#7

帖子 poloshiao » 2017-09-29 19:46

我也试过 sudo gnome-tweak-tool
終端機 試試
1. gnome-tweak-tool
2. gksudo gnome-tweak-tool # 適用於非 root 使用者
提示报错,就是我在问题中描述的报错
GLib-GIO-ERROR **: Settings schema 'org.gnome.shell' does not contain a key named 'disable-user-extensions'
3. 參閱
https://bugs.debian.org/cgi-bin/bugrepo ... bug=873765
gnome-tweak-tool: Error on start: GLib-GIO-ERROR **: Settings schema 'org.gnome.shell' does not contain a key named 'disable-user-extensions'
3-1. 暫時解決方案
https://bugs.debian.org/cgi-bin/bugrepo ... g=873765#5
After downgrade to version 3.22.0-1 its usable again.
把 gnome-tweak-tool 降級到 3.22.0-1
3-1-1. https://packages.debian.org/search?suit ... nome-tweak
3-2. 徹底解決方案
https://bugs.debian.org/cgi-bin/bugrepo ... =873765#10
gnome-shell >= 3.24
把 gnome-shell 升級到 3.24 以上
3-2-1. https://packages.debian.org/search?suit ... nome-shell
yushu280
帖子: 8
注册时间: 2016-02-06 22:12
送出感谢: 0
接收感谢: 0

Re: 求助,gnome-tweak无法运行

#8

帖子 yushu280 » 2017-09-29 22:34

poloshiao 写了:
我也试过 sudo gnome-tweak-tool
終端機 試試
1. gnome-tweak-tool
2. gksudo gnome-tweak-tool # 適用於非 root 使用者
提示报错,就是我在问题中描述的报错
GLib-GIO-ERROR **: Settings schema 'org.gnome.shell' does not contain a key named 'disable-user-extensions'
3. 參閱
https://bugs.debian.org/cgi-bin/bugrepo ... bug=873765
gnome-tweak-tool: Error on start: GLib-GIO-ERROR **: Settings schema 'org.gnome.shell' does not contain a key named 'disable-user-extensions'
3-1. 暫時解決方案
https://bugs.debian.org/cgi-bin/bugrepo ... g=873765#5
After downgrade to version 3.22.0-1 its usable again.
把 gnome-tweak-tool 降級到 3.22.0-1
3-1-1. https://packages.debian.org/search?suit ... nome-tweak
3-2. 徹底解決方案
https://bugs.debian.org/cgi-bin/bugrepo ... =873765#10
gnome-shell >= 3.24
把 gnome-shell 升級到 3.24 以上
3-2-1. https://packages.debian.org/search?suit ... nome-shell
谢谢大神,降级gnome-tweak-tool解决了。我采用sudo echo "gnome-tweak-tool hold" | sudo dpkg --set-selections就可以避免更新了吧。
然后等以后更新,bug修复了,再用sudo echo gnome-tweak-tool install | sudo dpkg --set-selections恢复更新。感谢大神的热心指点!
poloshiao
论坛版主
帖子: 18280
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1957 次

Re: 求助,gnome-tweak无法运行

#9

帖子 poloshiao » 2017-09-29 23:59

sudo echo "gnome-tweak-tool hold" | sudo dpkg --set-selections
如果想解除这个版本的锁定,不知该用什么指令?
試試
sudo echo "gnome-tweak-tool install" | sudo dpkg --set-selections

參閱
1. https://manpages.debian.org/stretch/dpkg/dpkg.1.en.html
dpkg - package manager for Debian
Package selection states
install
hold
deinstall
purge
2. http://www.debianadmin.com/how-to-preve ... ebian.html
How to prevent a package from being updated in Debian
Using dpkg
Remove the hold
echo "package install" | dpkg --set-selections
yushu280
帖子: 8
注册时间: 2016-02-06 22:12
送出感谢: 0
接收感谢: 0

Re: 求助,gnome-tweak无法运行

#10

帖子 yushu280 » 2017-09-30 8:56

poloshiao 写了:
sudo echo "gnome-tweak-tool hold" | sudo dpkg --set-selections
如果想解除这个版本的锁定,不知该用什么指令?
試試
sudo echo "gnome-tweak-tool install" | sudo dpkg --set-selections

參閱
1. https://manpages.debian.org/stretch/dpkg/dpkg.1.en.html
dpkg - package manager for Debian
Package selection states
install
hold
deinstall
purge
2. http://www.debianadmin.com/how-to-preve ... ebian.html
How to prevent a package from being updated in Debian
Using dpkg
Remove the hold
echo "package install" | dpkg --set-selections
谢谢啦
回复

回到 “互联网相关软件”